Help me fix an e4200v1

Discussion in 'Tomato Firmware' started by 68rustang, Jun 12, 2013.

  1. 68rustang

    68rustang Serious Server Member

    I pulled a pretty bone headed move last night. I was updating all my devices to Shibby's Tomato v110, I have 2 e4200v1s and 1 WNR3500Lv2, and I accidentally flashed one of the e4200's with the WNR3500Lv2 firmware file. As to be expected now that e4200 doesn't work. The "Cisco" light just has a steady flash. I am able to ping it at I have done many 30/30/30 resets. I have tried using tftp.exe, tftp2.exe and the Firmware Upgrade Utility to flash:

    stock Linksys firmware - It goes to about 70% and quits and goes in a re-try loop.

    Proper Tomato v110 from Shibby: it will say it completes but the router never reboots and if I manually reboot it just goes back to being pingable with a flashing logo.

    dd-wrt trailed min build: same as Tomato.

    I have tried it from both Win7 and Win8 computers.

    From what I have read if it is responding to ping requests at with a TTL=100 I should be able to use tftp to recover it. That is apparently not the case or I am doing something wrong.

    I have read the Peacock thread and all of Google ;) Any ideas?
  2. leshan

    leshan Network Guru Member

    serial adapter to erase nvram
  3. 68rustang

    68rustang Serious Server Member

  4. leshan

    leshan Network Guru Member

    yes, or you can buy usb adapter from ebay. You can also buy a 25 programmer and a 16dip clip on ebay to program the chip.
  5. 68rustang

    68rustang Serious Server Member

    I ordered a Nokia cable for $3.00 from ebay, hopefully it works. If I am understanding what I have been reading, Using the cable I should be able to erase nvram. Once that is done I should be able to tftp correct firmware to the router and all will be right with the world again.
  6. leshan

    leshan Network Guru Member

    If you tftp correct firmware successfully already, you just need to erase nvram.
    If the serial recovery will not work, the programer will work for sure.
  7. 68rustang

    68rustang Serious Server Member

    It actually worked! Thank you for your help.

    After wiping the NVRAM I had to tftp the stock firmware back over but after that everything came back to life.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice