Help me un-brick my WRT350N

Discussion in 'Cisco/Linksys Wireless Routers' started by spidey3, Jul 16, 2007.

  1. spidey3

    spidey3 LI Guru Member

    Short story:
    I have managed to brick my brand new WRT350N whilst upgrading from the stock 1.03.2 firmware to 1.05.8beta. It is now stuck with a flashing power light and solid usb light and nothing else.

    I need help un-bricking it.
    What should I try first? Is there any chance I might be able to do this without opening the case? Should I just return the thing to Best Buy?

    The longer story:
    My venerable old WRT54GS v2 with Sveasoft Talisman died a horrible death last week [lightning strike], and I went out to Best Buy and got a brand spanking new WRT350N to replace it.

    1st order of business was to load up the latest Talisman firmware. Problem was that with both 1.2.7 and 1.2.8 I just couldn't get settings to "stick". Every time I saved, the router would reset to factory defaults [yes, I already checked that I registered the correct MAC address when downloading the firmware]. After struggling for 3 hours, I decided that it just wasn't worth the effort, and flashed back to the stock firmware. I managed to get everything configured using Linksys stock 1.03.2 -- but then decided that I should try the latest beta firmware as it was purported to resolve some of the USB drive issues which had been reported. This firmware upgrade appeared to succeed -- but once the router rebooted, it never returned from the blinking power light state.

    Any suggestions on next steps?
  2. Rekoil

    Rekoil LI Guru Member

    Did you try resetting the settings by holding the reset button for 30 seconds?
  3. spidey3

    spidey3 LI Guru Member

    Yes -- tried that; no luck :frown:
  4. Slimey

    Slimey Network Guru Member

    try tftping the old firmware while the router is just booting from being powered on
  5. spidey3

    spidey3 LI Guru Member

    In the end I gave up and took the thing back to Best Buy. They exchanged it no-questions-asked.
  6. Bricked WRT350N with Flashing Green Pwr Light

    I had flashing green pwr light on my WRT350N after I attempted the v1.03.7 firmware upgrade from the original v1.03.2. I was now unable to access the GUI via I tried several times doing the hard reset with no results. I thought for sure I was out a new router until I performed the following.

    This was all performed on a Macbook Pro running OSx v10.5.2

    I re-downloaded "WRT350N_1.03.7_US_code.bin" and saved it on my Desktop. I renamed it "code.bin" no quotes.

    With the WRT350N powered on and connected to my Mac via LAN port 4 and no WAN cable connected to my Cable Modem, I performed the following:

    Opened Terminal
    <type> cd Desktop (which took me to my Desktop directory which is where my renamed file "code.bin" is located.)
    $ tftp
    tftp> verbose (allows you to see respones)
    tftp> binary (sets file transfer to octet)
    tftp> connect
    tftp> put (this is the send file command)
    (file) code.bin

    Here is the response you will get back IF successful.
    putting code.bin to [octet]
    Sent 6575104 bytes in 12.1 seconds [4347176 bits/sec]

    At this point it took about 3 minutes for the flasing green power light to go SOLID GREEN. Just let it sit there for awhile and it "should" go solid green. At that point I was able to access using the default login/password

    I was so happy :)
  7. charlotchaplin

    charlotchaplin Addicted to LI Member

    The 1.05.8beta for my WRT350N v.1 its ok and reliable?

    Is it the version 1.04.3_US would be better? Why Linksys does not offer this version on the Web site?
  8. charlotchaplin

    charlotchaplin Addicted to LI Member

    Help me!!!
  9. mevans336

    mevans336 Addicted to LI Member

    Just wanted to drop a note and say thanks. I received an Open Box WRT350N form Newegg and it had the flashing power light. I followed your instructions and it's working perfectly.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice