help mounting CIFS

Discussion in 'Tomato Firmware' started by maurer, Nov 8, 2010.

  1. maurer

    maurer Network Guru Member


    I have the following share visible from windows 7 on a media player (it's linux based so I believe it's samba):

    no username and no password

    how can I mount it under CIFS client in web on RT-N16 with latest k26?
    I've tried with:
    but i get:
  2. tmr250z

    tmr250z Network Guru Member

    A few of things you could try:

    - I think shares are only supposed to be one folder deep from the root directory. So try just \\\LocalStorages instead.
    - Is the folder enabled as a share? Try this:
    - Maybe try leaving the username and password blank or give the account a username and password and fill it in there.

    Hope one of those helps. If not, I'm all out of ideas.
  3. maurer

    maurer Network Guru Member

    thanks for the hints,
    but it's not working...
    the bad part is that i don't have access to the smb.conf, only the TV gui witch has only 3 options (enable,domain and machine name)
  4. atomicrabbit

    atomicrabbit Addicted to LI Member

    I am using both CIFS shares on my router. Note that I'm sharing a folder from my computer which has a username and password. I believe tmr250z is right in that the shares can only be 1 folder deep.

    Also, try removing the domain, as that would only apply if you created a domain controller in your network and your media player was part of that domain. Considering you entered "WORKGROUP" as the domain, I assume you're part of a workgroup, NOT a domain. The router is probably trying to access the share on a domain named "WORKGROUP" which doesn't exist.

    Regarding the username and password, if you can access the media player from your computer without entering a username and password, I would assume that leaving it the user/pass fields blank as well would work.

    What "media player" is it, if you don't mind me asking?
  5. maurer

    maurer Network Guru Member

    iamm ntd29 - made by novatron korea
  6. atomicrabbit

    atomicrabbit Addicted to LI Member

    Did any of my above suggestions work?
  7. maurer

    maurer Network Guru Member

    actually it worked with:
    UNC \\\LocalStorages\
    User Any
    Pass Any
    Security "no NTLM"
  8. atomicrabbit

    atomicrabbit Addicted to LI Member

    good to hear
  9. ArmoredDragoon

    ArmoredDragoon Networkin' Nut Member

    Old thread I know, but I wanted to bump because it comes high in google searching on this issue. It seems that the SMB client doesn't accept paths longer than a single folder deep. So e.g. \\\foo\bar doesn't work and yields -6, but \\\foo does work. Not sure if this is a bug, or intended behavior, but when I use regular samba or windows file sharing, I don't have this issue.
  10. duprade

    duprade Serious Server Member

    I ran into the same issue .. and I think its because it wouldn't accept a path longer than 15 characters under Netbios
  11. koitsu

    koitsu Network Guru Member

    The share is called "foo". CIFS/SMB mounts shares, not sub-directories of shares. I realise Windows lets you get away with this sometimes (depends on what OS version, etc.), but it's nonsense. You mount a share, not a directory within that share. It's not really a bug, it's how CIFS/SMB has been designed for a very long time.
  12. duprade

    duprade Serious Server Member

    Just out of curiosity... because from what you explained it seemed what I did wouldn't work ... but I'm not an expert by any means....

    On my setup, I created 2 directories on my DLINK-321 NAS ... named CIFS and CIFS2 ... and I mounted those 2 directories onto my RT-N16 and it works. With the path going directly to those folders.

  13. koitsu

    koitsu Network Guru Member

    duprade, I think you misunderstood. He's talking about using a UNC path of something like \\\CIFS\blah (assuming blah is a subdirectory accessible within the CIFS share hosted by Note the difference:


    By the way, your NetBIOS names are completely 100% wrong. In your case case you would want to put STORAGE there, or leave the field empty entirely. NetBIOS names != UNC paths. Take a look throughout existing forum posts at how common this mistake is; so many people are using CIFS/SMB sharing yet have no real familiarity with its configuration, what field means what, etc.. It's not as "obvious" as NFS. :)
  14. duprade

    duprade Serious Server Member

    Oops! :eek:/ Thanks for pointing that out.

  15. koitsu

    koitsu Network Guru Member

    *laugh* Nice picture. Made me chuckle. :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice