Help needed to de-brick my WRT54G

Discussion in 'Cisco/Linksys Wireless Routers' started by Tommy_misiak, Sep 10, 2007.

  1. Tommy_misiak

    Tommy_misiak LI Guru Member

    I have a WRT54G V6 and recently upgraded the firmware to DD-WRT V23 SP1. It worked great but after a storm it just stopped. I can´t access it and my laptop does not even recognize when wired. Reading some forums it said that bootloader and kernell should be ok and only a NVram clear would do it but Telnet does not find it either.

    When I plug the router, Power led blinks permanently. DMZ and WLAN leds are off and the 4 ethernet plus internet leds are always on. I though of using the Voidman method (shocking pins 15 and 16) but there was no mention on whick pin to use for v6.

    Anyone can help me please?? I live in Brazil and the WRT54G costs over USD 200,00 here.

  2. danix71

    danix71 LI Guru Member

    Maybe the storm got to do with sudden death ? :frown:
  3. frenchy2k1

    frenchy2k1 LI Guru Member

    have you tried resetting the device? (holding the reset button for 15 seconds)
    This clears the nvram.
  4. Tommy_misiak

    Tommy_misiak LI Guru Member

    Thanks for your reply. Yes I have tried resetting the router as weel as all other instructions on revival guide. The router does not reply to cmd ping nor telnet. I also tried to shock pins 15 and 16 as per Voidman method but it did´t work either and that s why I asked if those pins where rigth for V6. My last hope now is to use a EJTAG cable. I will make one next week.

    Thanks anyway..
  5. Tommy_misiak

    Tommy_misiak LI Guru Member


    Hi, I tried again to shock pin 16 to antena earth and now the router is responding to ping. However, the power light continues blinking. I tried to tftp originial Linksys firmware and I even got sucessful message but can´t access //

    The good thing is that the router is now replying to ping and also recognized by Windows vista as lan. Does anyone now what can I do next? i read someting about erasing NVram but I didn't find instructions on how to do it...

    I am already trying to resurrect my router for almost ten days now. Please help!!

  6. danix71

    danix71 LI Guru Member

    If uploading the firmware is done correctly and the router respond to ping, then the following step is to keep pushed (for 30-35 sec) the reset buton (with power on). Then try to access
  7. ataris_kid

    ataris_kid Guest

    Hey there,

    I was just curious as to which pins you shorted to successfully recover your v6. I looked at pictures of the pins to short, but my board doesn't look like the ones that I've seen.

    Thanks =)

    Edit: I guess it'd make sense to say that I do not see an Intel chip on my board, and therefore I can't match up the pin numbering. I'd attach a picture, but it's down at school at I'm home for the weekend.
  8. slater22

    slater22 Guest

    short pin 16 question

    I have this same model router wrt54g v6 and have the exact same problem. When I plug the router, Power led blinks permanently. DMZ and WLAN leds are off and the 4 ethernet plus internet leds are always on. I cannot get this to work however. Can someone give me another way of reviving this router. For some reason when I connect pin 16 to ground it does not do anything.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice