Help, Please! Half bricked my WRT54GL 1.1

Discussion in 'Tomato Firmware' started by TheKid, Apr 12, 2007.

  1. TheKid

    TheKid LI Guru Member

    Hello All,

    I'm a noob with these 3rd party firmwares for the WRT's, however, have extensive networking knowledge. . . I've been following the forum for a few weeks now and been doing my reading to a grip on what to do, how to do it, etc.

    I need a client set up in another room and loved the 'geeky' :wink: way to get it from a WRT54GL 1.1 rather than shelling out the additional cash to get a specific device. Not to mention, I could turn the router into something else should I have needed to at a later point in time.

    So. . . I got the WRT54GL 1.1 yesterday. Looking at all the firmwares, Tomato looked like a nice one and proved to give me just what I was looking for.

    The installation looked pretty straight forward. . . flash 1.06 from the Linksys GUI, 'Upgrade Firmware'. I did this, it completed, I was patient and let the router sit for 5 mins.+. It sat on the 'Upgrade Successful/Continue Button' page for this 5 mins. The router never rebooted or changed pages, so I unplugged it to reboot it. Well, at that point, "brick," or at least half brick.

    The power light on the front just blinked and the router never booted. I kept my wits and went back to reading. The router was returning pings -- I get 4 good pings for every 4 bad pings, so I was halfway alive -- at least, enough for me to TFTP the original Linksys firmware back onto the device (the TFTP only took 10 secs or so which was alarming -- I figured this process would take MUCH longer). I was able to get the device to boot again (into the Linksys GUI) after this -- even though it seemed to take a lot longer to boot than it did originally (30 secs or so). I reset the device to factory defaults and then tried the process again. When flashing this time, however, about 80% into the process the GUI returned the dreaded 'Upgrade are failed.' dialog.

    So, I now seem to be stuck. . . I can get the Linksys firmware back onto the device (TFTP), but even when I do, the router still doesn't seem "normal." For example, reset to factory defaults doesn't return -- the router must be manually rebooted. So, something is not right, even when returning to the Linksys firmware. The problem is, I can't see how to get Tomato (or any other firmware for that matter) onto the unit now.

    Sorry for the long post, but can anyone of you experienced people please assist me in trying to get the router back to its original state, get another firmware on it where I can clear the NVRAM, or do whatever so that I can get it back to a state where I can get Tomato on it -- as I originally wanted to do. I would figure since I get pings, can TFTP, etc. that it's probably not a lost cause at this point. . . If so, I can return it -- I can get the Linksys GUI back on it. :smile: I'm still not sure why the original upgrade to Tomato failed. The file was the correct size/downloaded correctly, flashed accordingly, I was patient when it completed, etc.

    I'm going to try and put DD-WRT mini on it and see where I get, but any detailed help would be GREATLY APPRECIATED!! I couldn't seem to find a similar scenario out there when researching the problem.

    Thanks. I look forward to the replies. . .

    -- Dave
  2. jochen

    jochen Network Guru Member

    Try the following:

    - unplug power
    - press and hold the Reset button
    - plug power in, and keep on holding reset for 30 seconds
    - release reset after 30 seconds
  3. Deimdos

    Deimdos Network Guru Member

    If there is ping, then still there is hope :D. As you said, try with dd-wrt micro version, and do a hard-reset after upgrade (a minute at least to be really sure)
  4. bogderpirat

    bogderpirat Network Guru Member

    dude.. try replacing your ethernet cable.
    this sounds quite irregular and not like a software problem. if it doesn't work even after trying another cable and from another computer, you should return it if possible.
  5. TheKid

    TheKid LI Guru Member

    Tried darn near everything. . .

    Okay, since posting my original message, I've tried a few things. . . Different cable, different machine, etc.

    No matter what I do, I can only get the Linksys firmware installed on the unit. NO OTHER 3rd party firmware will install. They all fail during the GUI upgrade process with 'Upgrade are failed.'

    I never am unable to ping the unit, so it's not bricked. I just get upgrade failures from the Linksys GUI, need to then TFTP the Linksys firmware back to the unit (and, no, I can't TFTP any other firmware without it failing as well -- 'incorrect pattern'), and let the unit reboot. It comes back alive with the Linksys firmware, no problem. I can even upgrade the Linksys firmware from the Linksys GUI successfully -- even though I have had more than a few occasions where this also failed with 'Upgrade are failed.'

    Basically, it seems no matter what do (reset 30 sec., reload Linksys firmware, etc.), I can't get the unit back to its stock/original state to install an alternate firmware. Again, Tomato installed from the Linksys GUI originally (the first time I flashed). I got the 'Upgrade is successful.' page. I was just never able to boot the unit into Tomato. . . This is when this pattern started.

    Any other suggestions that I might try in order to get this thing clean and back to where I might be able to chuck another firmware on it before I RMA the thing?

    At least I can get the Linksys firmware back on it and working so the return won't look obvious. :biggrin:

    Thanks all!

    -- Dave
  6. fastpakr

    fastpakr Network Guru Member

    What Tomato image are you applying, i.e. WRT54GS, etc...?
  7. TheKid

    TheKid LI Guru Member

    Tomato Image Applied

    I dumped the v.1.06 WRT54G code.bin on it -- that's what the install notes mentioned for the WRT54GL v1.1.
  8. fastpakr

    fastpakr Network Guru Member

    OK, just checking. I'm not sure what you're dealing with, then. At this point, given what you've already tried, I'd box it up and return it for a replacement.
  9. roadkill

    roadkill Super Moderator Staff Member Member

    It tend to happen when you use Firefox I got it a couple of times
    I use Opera when upgrading now and all works well...
    try to use a different browser or simply TFTP the firmware.
  10. fastpakr

    fastpakr Network Guru Member

    I would have suggested that too, but he indicates that he tried TFTP'ing the firmware already, and got 'incorrect pattern' there as well.
  11. roadkill

    roadkill Super Moderator Staff Member Member

    TFTP Code pattern is incorrect -
    The firmware image you're uploading was intended for a different model.

  12. TheKid

    TheKid LI Guru Member

    How is it the Wrong Firmware

    When TFTP'n, I tried uploading the generic DD-WRT micro to the WRT54GL v1.1. Don't see how this is the wrong firmware? (see images below)

    Everything I have referenced showed this to be the correct image for this router model. As well, all other images I used I checked and ensured were the correct images for my router. . .

    WRT54G (code.bin) - Tomato v1.06 (the image for the WRT54GL v1.1)
    dd-wrt.v23_mini_generic.bin - (SP2 and image for WRT54GL v1.1)

    I could not TFTP any firmware and get the router to boot, other than the Linksys firmware. Linksys' own firmware, once up, would not even update itself from the Linksys GUI without giving me a 'Upgrade are failed.' message.

    Bottom line, I think there is something wrong with this router as none of this behavior seems "normal". I have already processed a RMA. Maybe I'll have better luck with the next v1.1.
  13. roadkill

    roadkill Super Moderator Staff Member Member

    don't use the micro version use Linksys official.
    but I do think that RMAing it is smart since the symptoms
    could be from a BAD chipset too...
  14. mikester

    mikester Network Guru Member

    Give this a try:

    * give your PC a static IP
    * copy the stock Linksys firmware to "c:\code.bin"
    * connect PC to LAN port 1
    * hold WRT reset button 30 seconds
    * unplug power, wait 1 minute, stick finger in eye, then plug back in
    * plug power back in, power light starts flashing
    * type the following command from the command prompt
    C:\>TFTP -i PUT code.bin
    * wait for a few minutes, watch wrt reboot
    * poke finger in other eye, ping -t
    * pray the new firmware image starts up

    BTW I had a hardware problem where the device would take the new firmware but loose it immediately after reboot. I had to get the hardware replaced.
  15. roadkill

    roadkill Super Moderator Staff Member Member

    if I remember correctly:
    tftp -i PUT code.bin code.bin
    double code.bin is recommended, one local one remote I think...
    I also had this with one of my routers and I connected it through a switch and configured a static IP on the computer ONLY then I was able to TFTP recover.
  16. digitalgeek

    digitalgeek Network Guru Member

    I have used Firefox from day one (with Tomato) and never had any problems. This sounds the unit to me too. The first time I flashed with Thibor I used IE and had no problems. (never TFTPed until I bricked my G trying to Overclock it)
  17. TheKid

    TheKid LI Guru Member

    Thanks for all the input. . . It's much appreciated!

    I tried everything mentioned in the above threads (except for the finger in my eye :wink: ) before processing the RMA today.

    Again, being that I can't even update the official Linksys firmware (to itself) after getting the unit operational, running the Linksys 4.30.9 firmware (GUI), I suspect there has to be something wrong with the H/W (I'd get a 'Upgrade are failed.' dialog.)

    Linksys' firmware was the only firmware that would load and operate on the unit AND THEN it seemed you couldn't even use the upgrade firmware option AT ALL, regardless of what you wanted to load. . . ANY load of ANY firmware would fail. At least I was able to TFTP the Linksys firmware back onto the thing before sending it back for replacement! It also seemed that the units boot time increased to around 30-40 secs. after all this madness. Strange stuff, man, strange stuff!

    We'll see how the next unit treats me. . . Hope it's better than this one. These 3rd party wares look outstanding! I'm anxious to check them out.

    -- Dave
  18. mikester

    mikester Network Guru Member

    That might be your problem - you need to poke a finger in both eyes to get them all - er - tomatoee :cool:
  19. roadkill

    roadkill Super Moderator Staff Member Member

    digitalgeek:I was referring to the update process ONLY is problematic with Firefox
    which is acceptable, I didn't have any problems after the upgrade.
  20. digitalgeek

    digitalgeek Network Guru Member

    exactly, I have never had any problems with updates using firefox.
  21. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I can't seem to get through this thread cause I end up only being able to see out of one eye....
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice