HELP: setting up WRT54GC with DSL modem

Discussion in 'Cisco/Linksys Wireless Routers' started by sildenafil, Jun 25, 2006.

  1. sildenafil

    sildenafil LI Guru Member

    I don't exactly understand why I have so much problem with it, but now I am on the edge of giving up...
    I think I have tried everything, but I just can't access the internet with the WRT54GC router!

    So I got the WRT54GC to upgrade my home wireless network to 11g. I use the 2wire 1000SW DSL modem/router/11b from SBC.

    So I set it up as:

    phone --> 1000SW
    1000SW LAN --> WRT54GC WAN
    WRT54GC LAN --> my computer (WinXP)

    since both the WRT54GC and 1000SW has router function, I setup the two routers with different subnet,
    with the default 1000SW setting:
    DHCP enabled

    and WRT54GC:
    DHCP connection
    - assigned
    - gateway
    DHCP enabled.

    and then my computer:

    So everything seems to work, but then I just cannot connect to the internet (or connecting with an extremely slow speed). I cann't load google page, while seem to be able to load the header of some other pages...

    I can ping the WRT54GC (, and the 1000SW ( perfectly fine, as well as accessing their web-based setup utilities.
    I can also ping and various websites, with 20-40ms time. (so they are connected...)

    But then why can't I browse the internet??

    Some of my other checks:

    If connected directly to the 1000SW, either with its USB or 11b, I can browse the internet. So my internet connection is fine, the problem must be within the 1000SW subnet.

    I tried connecting 1000SW to the LAN port on WRT54GC, and my computer also on one of the LAN port. I turned WRT54GC DHCP off, so WRT54GC works as a bridge.
    this way my computer actually get assigned a IP from the 1000SW in the 172.16.1.xx, and it worked (for 2 weeks, then mysterious not working anymore, after I installed linux on a different computer)

    I also tried setting both router in the same subnet:
    with DHCP on or off, two DHCP on but different IP ranges...
    nothing worked... :<

    Anyone know how to troubleshoot this?
    Thanks so much!!!
  2. ajdoakwood

    ajdoakwood LI Guru Member


    I have a very similar problem. Did you find out how to fix this?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice