HELP! Strange things happening while upgrading to Tofu13b...

Discussion in 'HyperWRT Firmware' started by LeChuck, Feb 2, 2006.

  1. LeChuck

    LeChuck Network Guru Member

    Hi everyone... (especially Tofu!)

    I hope you can give me some little advice and opinions about the upgrade process of my WRT54Gv2.2 that I just have been through...

    I wanted to flash from HyperWrt 4.20.6 Rupan to Tofu13b, because I always wanted to have that terrific WOL-feature... and besides Tofu-Firmware was supposed to be really good, fast and most importnat, reliable... exactly what I need.

    So I started with taking precautions:

    1. Cleared VRAM via Telnte.
    2. Reset to Factory Defaults via GUI
    3. Reset to Factory Defaults via Hard-Reset
    4. Switched NIC to 10 Base-T Half-Duplex

    Pretty ok, isn't it?

    Then I logged in and started the upgrade process via the GUI... I used Firefox 1.5 for that...

    THe progress bar of the upgrade slowly filled up until it reached about two thirds of the whole thing... then I think the router flashed its Power-LED. AFter that the progress bar filled up again, and when it again reached the "two thirds"-mark of it, I got the message "Upgrade are failed!"...

    Besides the bad English that was bugging me ( ;-) ) I was worried about the message... upgrade failed? What the heck, I did everything to prevent that! How could it?

    Then I tried to ping the machine... and success... I got a ping... But then the weird thing was, that I could not log on to it via the Browser...

    Then I tried TFTP for a while, nothing worked...after that, the next logical thing to do, would be a hard-rest of the device. Said, Done!

    And then it worked... !!!! :) I could log on to it via the browser and configure it! I am just worried now, that something is maybe wrong...

    So... SHOULD I BE WORRIED ABOUT THIS? The router is runing fine right now, everything is working, I am using wireless on my notebook with WPA-TKIP, and I am running my BitTorrent-Client on my desktop, that is going really good... as usual... don't notice a difference to previous firmware... everything seems stable and fine right now...

    But is this the way an upgrade of the firmware is supposed to take place? Should I reflash or do you guys think it is cool as it is...?

    By the way, could someone tell me, what scripts are already inside the firmware?

    I used that script here
    echo 2048 > /proc/sys/net/ipv4/ip_conntrack_max
    echo 2048 > /proc/sys/net/ipv4/tcp_max_orphans
    echo 512 > /proc/sys/kernel/threads-max
    echo 0 > /proc/sys/net/ipv4/tcp_orphan_retries
    echo 1 > /proc/sys/net/ipv4/tcp_abort_on_overflow
    echo "60 180" > /proc/sys/net/ipv4/ip_conntrack_udp_timeouts
    echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
    echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
    echo "300 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts
    echo "30 3 * * * root /sbin/reboot" > /etc/cron.d/reboot
    in my previous firmware and I could leech with BitTorrent as hell!! 500 kb/sec no problem!

    What portions of above script are already in there??? Maybe I want to add the other lines again...

    Thanks a lot for your help, be sure it is highly appreciated...

    Best regards,

  2. bcat

    bcat Network Guru Member

    I wouldn't worry to much if I were you. Stuff happens, especially with flash memory. :)

    As for the startup script, you probably don't need it. The latest Tofu firmware is already pretty well-tuned when it comes to P2P.
  3. asianangel28

    asianangel28 Network Guru Member

    I've tried many startup scripts, but still have problems, thinking of trying your script.
    can you tell me what the extra lines in your script is for?
    It's really different from the other scripts that people usually recommend :
    echo 4096 > /proc/sys/net/ipv4/ip_conntrack_max
    echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
    echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
    echo 512 > /proc/sys/net/ipv4/neigh/default/gc_thresh1
    echo 2048 > /proc/sys/net/ipv4/neigh/default/gc_thresh2
    echo 4096 > /proc/sys/net/ipv4/neigh/default/gc_thresh3
    echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

    by the way what bittorrent client do you use?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice