HELP - Vista and NSLU2

Discussion in 'Cisco/Linksys Network Storage Devices' started by RipMan, Apr 7, 2007.

  1. RipMan

    RipMan LI Guru Member

    HELP - I recently purchased and NSLU2 and Vista. I can see the NSLU2 in My Network but when I click on the icon it opens the Linksys web page. I cannot right click on the icon in My Network and select explore. I want to goto network neighborhood and click on the icon to browse the shares. This all works on an XP machine, but not Vista. I've already changed my NTLM settings to use NTLMv2 if available. I can successfully navigate the file structure on the unit by using \\ method but cannot get to it by name. My unit is name NAS1 and this is what shows up in My Network. I've verified workgroup names match.
  2. LordFlux

    LordFlux Network Guru Member

    Hmmmm... very strange. I'm using two NSLU2 units and running OEM 64-bit Vista Ultimate and have no problem accessing the units. I didn't even have to change the NTLM setting.

    So you can see NAS1 in My Network, but when you double-click it, it takes you to the NSLU2 web page. That sounds like the UPnP feature kicking in. I have UPnP disabled on my units. Not sure if that makes any difference, but have you tried disabling UPnP?

    Have you tried manually mapping a drive? By typing in \\NAS1\Disk 1\ ?
  3. RipMan

    RipMan LI Guru Member

    When I disable UPnP I can no longer see the drive in network neighborhood. I'm running Vista Ultimate as well. The only way I can seem to get to the drive is via the IP address.
  4. LordFlux

    LordFlux Network Guru Member

    Are you attempting to log into the NSLU2 using a user name? Or do you have Guest Logins and Convert Failed Logins to Guest Logins enabled?

    What NSLU2 firmware are you using?
  5. RipMan

    RipMan LI Guru Member

    I do have guest login enabled and convert failed login to guest enabled as well. I'm running Unslung 6.8 as the firmware.
  6. doppler56

    doppler56 LI Guru Member

    Just maybe

    Vista and the nslu2 have to be setup into the same

    Another possiblity you may have to turn off vista's
    a hardware firewall.

    Usually this solves most network ID problems with the
    nslu2. A hint the thruput out of the NSLU2 can greatly
    increased with the xp/vista software firewall off.
  7. LordFlux

    LordFlux Network Guru Member

    RipMan stated that he had already checked that the workgroup names were the same. And I did not have to turn the Vista firewall off to get the NSLU2 to work for me. I installed Vista, made sure my workgroup was the same as the rest of my PCs, DHCP assigned me an IP address, and that was it... I was able to see the NSLU2 units under My Network and I mapped the drives. Been working perfect ever since.

    RipMan, I don't know what to tell you about your problem -- I'm stumped. Can you access the Internet from your Vista machine? Maybe the patch cable is bad? I'm grasping at straws here.
  8. RipMan

    RipMan LI Guru Member

    I'm able to access the internet. Using my Vista machine now to post this message. I'm stumped. I don't see any other XP computers from my vista machine. The XP machines (2 of them) are able to see the NAS perfectly. It might be time to dump Vista for a while :)
  9. gelf

    gelf LI Guru Member

    I have the slug and vista and i don't have any problems, but I do see what you see and I think you are confused between the upnp web server of the slug in the network area (a whitish / grey icon). That is what you are seeing, I see it to and I also see one for my router, and when I click on either I get the associated web interface. The slug also appears as a computer (ie the blue icon) which is where I see the shares.

    Are you sure you have the slub in the same workgroup and also same IP range, ie for both you computer and the slug. Ie if you router dishes out this range you will need to change the slug default from
  10. LordFlux

    LordFlux Network Guru Member

    I just thought of something. Make sure Network discovery and File sharing is turned on under Network & Sharing Center.
  11. Melvin Ganik

    Melvin Ganik LI Guru Member

    I have 2 slugs (firmware V2.3R63), 3 WinXP machines (XP Home), and 2 Vista machines (Vista Home Premium). Same problem. WinXP has a nice interface to the slugs, but Vista requires that I map the slugs with the actual IP address (e.g. \\ Note that I can enter the IP address without the share (e.g. \\, click on "Browse", and Vista will list all of the shares that can be mapped. But, I can NOT use \\NAS1\DISK 1 to easily map the drive.

    All my machines are on the same workgroup. My PC and slug logon names and logon passwords match. Network Discovery and File Sharing are on. My Network Location type is set to Private (not the default Public).

    I tested lowering the security by setting of the LMCompatibilityLevel to 1, and there was no change. My results are exactly the same as LanMan's observations.

    I also note that I had a similar problem with my network printer. With WinXP, the printer port could be easily set up using the printer's network name. But, on Vista, I had to set up the printer port with the IP address of the printer.

    According to Kelly64 (msg dated 04-09-2007), after questioning Linksys, he determined that Linksys does not currently support Vista on their NAS devices. As I'm new to Vista, I can say that the new Vista security and other changes have caused a lot of problems with my "old" apps. But I digress ... I promise not rant here about Vista problems in general.

    On Vista, I can set the mapping to automatically re-establish each reboot (to avoid manually mapping the drives). It sounds like Lord Flux has done this. (Just enable "Reconnect at Logon" tick box on the Map Network Drive page.) This is the only ease of use solution I know of for use with Vista.
  12. Toxic

    Toxic Administrator Staff Member

    I dont know too much on Vista yet but is there anything like a HOST file (or LMHOST) that you can add the IP address to a shared name. and then use the share name of the SLUG
  13. Melvin Ganik

    Melvin Ganik LI Guru Member

  14. Toxic

    Toxic Administrator Staff Member

    Glad to be of service!
  15. Melvin Ganik

    Melvin Ganik LI Guru Member

    UPDATE: The issues I had mentioned here were based on a few new PCs with Vista, and they came with a 90 day trial of Norton Internet Security. I just uninstalled Norton Internet Security, and WOW! Now I can access the NSLU's easily from the "Network" button on the Start Menu (just like I thought I should be able to). All NSLU's now show up, along with other PC's and the network printer.

    Point is, if you have Vista and are having trouble easily accessing your NSLU devices, it just might be Norton Internet Security (or similar app).

    Maybe there's a setting in the Norton app that I could have changed, but I didn't like Norton for a number of reasons anyway. I was very surprised to see the positive changes once it was uninstalled!

    Turns out I didn't need to modify the Hosts file after all!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice