Help - What am I doing wrong?

Discussion in 'Tomato Firmware' started by disenter, Jun 21, 2014.

  1. disenter

    disenter Network Newbie Member


    I have got tomato running on my RT-AC66u fine, but I can't for the life of me get the internet up on it...

    I have a cable connection run by a Netgear cable modem/router, which I usually run in bridged mode, and via the stock or merlin firmware, the AC66u finds and deals with fine.

    But there seems to be no such detection of connection on tomato, and every option i've tried just doesn't seem to work...

    I've had the same issue when trying DD-WRT as well.. just does not want to talk to the other router, bridged or not.

    I'm sure im doing something wrong... but why is it that the stock firmware and Merlins firmware is very simply and easily capable of detecting the connection type and tomato and dd-wrt are not?

    Can anyone tell me, or point me to a guide to making this setup work?

  2. Siff

    Siff Serious Server Member

    Have you set the gateway on the RT-AC66U to the IP address of the Netgear? Same for DHCP (if the Netgear is your DHCP server) and DNS.
  3. disenter

    disenter Network Newbie Member

    well... I did try that.

    I mean, I had it the netgear (cable modem/router) running bridged mode (this is just a simple tick box on the netgear, and stops it running any dhcp functions etc - fairly much just a modem - though does have a reachable ip address - for the config page atleast), so as to allow the AC66u to be my gateway/firewall/dhcp/dns etc, but that wasn't working (does with merlin or stock firmware). Whilst bridged, i even took note of the ip address/gateway and dns information from the isp end, and tried adding that as a static entry on the ac66u/tomato.. my ip externally is dynamic, but since it was assigned, I thought it might work... didn't.

    So I did try running the netgear unbridged, but this then wants to run a dhcp, dns yadda yadda.. so I even tried disabling all of that in the ac66u (less than ideal - but for testing, i tried it). I did set the gateway to be the netgear, but this was then different subnets netgear -, and the ac66u - - which is what tomato said it had to be, atleast for a static entry whilst trying to make it run bridged. It said they needed to be different domains/subnets - which seemed a bit off to me, but if it works, it would be better security wise i suppose.

    My next step is perhaps to try both in the same domain/subnet, but I really would like to have the netgear just run bridged, and have the ac66u do all the work as the gateway.....
  4. disenter

    disenter Network Newbie Member

    So, I kind of have it up this way.....

    internet ---> cable modem/router running as normal mode ----> rtac66u being dhcp/wifi/gateway/firewall etc (everything passes through it).

    Both routers in same domain, and set tomato's dhcp gateway option to that of the netgear. Don't use WAN ports and it seems to work ok.

    But now I can't get the wifi to work??

    Neither 2.4 or 5ghz bands .. cannot get my iphone5s to connect to either..........
  5. disenter

    disenter Network Newbie Member

    so i followed the guide from shibby about resetting the nvram to get 5ghz working?... Well, it did get it working for 5ghz - kind of. It now only has 20Mhz/40Mhz, and only 2 channels for some reason on 5ghz, and 2.4ghz no matter what I do, it will not work. I mean, I set it, and then on the status it seems to have completely ignored what channel i've set it to and just does what it wants, and will not allow anything to connect to it...

    Even more curious is, even though I cannot set 80Mhz for 5ghz band, it shows 80Mhz on the overview page. How is it that it's running something that I apparently cannot set, and what happened to all the other channels on 5ghz??? I have 2 channels to choose from now.. or else just 'Auto'.

    I was optimistic .. but this is not cool.
    Last edited: Jun 21, 2014
  6. Siff

    Siff Serious Server Member

    Sorry, I thought that you are running the Netgear in normal mode. If you want to run in in bridged mode, then you have to connect the Asus's WAN port to the Netgear, set the Asus as DHCP server and that's pretty much it...

    For the 5GHz: I don't have AC router, so I cannot comment on the 80Hz channel width setting. Try resetting the NVRAM again and reboot after setting the 5Ghz radio.

    Hope this helps.
  7. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    5GHz watch Shibby's video, or simply:
    NVRAM erase
    Set Advanced Wireless region to Singapore
    Reboot using the GUI
    Now go to Basic page and set it up
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice