Help with USB Printer

Discussion in 'Tomato Firmware' started by AmyGrrl, Jun 10, 2010.

  1. AmyGrrl

    AmyGrrl Network Guru Member

    I tired searching for some guide on how to do this... but couldn't find any...

    I have an Asus RT-N16 running teddy_bear's Tomato Firmware v1.27.9045 MIPSR2-beta11 K26 USB Ext. I'm trying to connect an HP Deskjet 3930 to it. The device is USB 1.1 and it seems to be detected by the firmwire, but I still can't see the printer over the network. Can anyone provide a good guide on setting a printer up. I'm wondering if this printer isn't supported by the firmware. I've tried enabling OHCI & UHCI at the same time. Then just UHCI. Currently have only OHCI enabled. I don't see any errors in the logs about the printer.

    Anyways... Thanks for any help that will be given...
  2. danimaltron

    danimaltron Networkin' Nut Member

    I'm having a similar problem.

    I can see my printer (Samsung CLP-300) attached in GUI, but in the Mounted? column, nothing is there. So I guess I need to mount it somehow. How can I do that?

    I'm also using an RT-N16 router, and the same firmware as AmyGrrl by the way.

    Does anyone know how to add the set the printer up on Mac OS X after that? I tried going to add a printer > IP > > select proper drivers ... but nothing happens, presumably because the GUI says it's not mounted. But I don't know that I'm setting the printer up on my Mac for sure either.

    Thanks! Great job on the firmware.
  3. teddy_bear

    teddy_bear Network Guru Member

    "Mounted" column is only used for storage drives, it never shows anything for printers.

    Read the whole 1st post of USB Mod thread - it has links to printer setup guide on Windows, as well as to special instructions for some HP printers (like 1018, 1020 etc) which require a firmware file. Or try searching that thread for information about your specific printer model.

    I have no idea how to setup the printer on Mac OS, but possibly Windows instructions will be close enough.

    Please note, Asus RT-N16 only has OHCI controller, so checking UHCI won't do anything. Enabling both - USB 2.0 and OHCI - should work in most cases, although some older USB 1.1 printers may conflict with USB 2.0 driver, and will only work if you disable USB 2.0. When you disable one of the USB drivers, you may need to reboot your router for this change to take effect.

    If you set everything up as described there, and still don't have your printer working - most probably it's not compatible with the generic kernel printer driver used by the firmware. Although most printers work with it just fine, some (mostly inexpensive models) require special drivers and software - in such case you're out of luck :(...
  4. AmyGrrl

    AmyGrrl Network Guru Member

    forget it this is way too much work to get this old printer working... I'm going to toss the POS printer... do we have a compatibility list up somewhere of supported printers in Tomato...
  5. teddy_bear

    teddy_bear Network Guru Member

    What hotplug script exactly are you referring to? Better just post your entire script...
  6. danimaltron

    danimaltron Networkin' Nut Member

    I got it to work in Windows, via VMware. So there is some sort of setup problem on Mac. The settings screens are a bit different.

    For example, I don't see anything about setting the protocol as RAW. I will research this more and post back if I find any more info, and maybe you can add it into the guide to help others.
  7. danimaltron

    danimaltron Networkin' Nut Member

    Well.. it doesn't look promising. It works great in Windows, but in Mac there is not the right drivers. I believe I need CUPS drivers, which aren't available.

    But I did get close. On a few attempts, I got the printer to mak noises and LOOK like it was going to start printing. The rollers were going and everything. But it never picked up a sheet of paper and actually printed anything.
    So the driver must not be quite right I suppose.

    Oh well, was fun trying
  8. Kisch

    Kisch LI Guru Member

    Did you configure TCP/IP RAW printer port on your PC?
  9. AmyGrrl

    AmyGrrl Network Guru Member

    yes I have... I can get it print about half a page then it just stops...
  10. danimaltron

    danimaltron Networkin' Nut Member

    Does anyone know which printers have been reported to work? It would be nice to get a list going
  11. AmyGrrl

    AmyGrrl Network Guru Member

    I agree a list of printers that list which ones work and which ones don't would be great... I would like to get a newer printer actually... this HP printer is too old... I actually forgot I had it until I found it on the closet... I thought it would be neat to see if I could get it working with the router, but it doesn't.. time to move on...
  12. teddy_bear

    teddy_bear Network Guru Member

    Although you don't see many posts about successfully working printers (people don't complain when everything's fine), I assure you that the list of printers that do not work will be a lot shorter.

    So if anyone wants to compile the list, it should be the printers that you could not make to work no mater what you've tried.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice