Help with WRT54G TFTP Flashing

Discussion in 'Cisco/Linksys Wireless Routers' started by Osis1ty, Jul 17, 2007.

  1. Osis1ty

    Osis1ty Guest

    Hi everyone,

    this is my first time posting even though i'm on the site always finding out information or how to solve issues with various routers my friends have.

    But anywho to get the point! I came home from vacation and my router wasn't working correctly. It was slow, wasn't providing internet for some reason, etc. So i did a hard reset and that's when i got the blinking light. I did the research and ended up shorting out the pins to finally be able to ping to it again but now i'm stuck.

    I've tried everything, my power light is blinking, DMZ is blinking slowly. I use tftp to upload firmware, it can't ping it for awhile, then it starts pinging after about 20 seconds with the power light still blinking and the dmz light frozen.

    When i try a hard reset then a flash as soon as i plug it in. I flash it and it stops pinging all together. I let it sit for about 10-20min and it doesn't ping. I unplug it and plug it back in and i go back to square one.

    Any ideas?
  2. kingvj

    kingvj Network Guru Member

    reduce LAN card speed to 10mb half duplex, assign static IP and then do a continuous ping to the router. If the router responds, disable firewall/antivirus s/w. do a tftp and upload the firmware. if the router doesn't respond, replace it..!!
  3. ifican

    ifican Network Guru Member

    So have you been successful in uploading the firmware?
  4. Osis1ty

    Osis1ty Guest

    The router responds no problem. It's just that i put the firmware on it and it just keeps on blinking. Maybe i'll just go buy another one. I have a wrt54g V2.0 btw.

    Yes the firmware uploads successfully everytime.

    it either:
    -stops pinging for a little and comes back with the light still blinking
    -or if i upload the firmware right after a hard reset it uploads the firmware and stops ping all together (I just left it for an hour while watch a movie and it's still not pinging). In which case i unplug it and plug back in where i'm at square one.

    I've also tried uploading probably about 5 or 6 different versions of the official linksys firmware. Haven't tried and custom because the guides said to do it with the official.

    My v2.0 is the only router for me! Parents want me to use this Netgear crap router! HELP!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice