Help with WRT54G v2

Discussion in 'Cisco/Linksys Wireless Routers' started by jwranger, Jan 15, 2006.

  1. jwranger

    jwranger Network Guru Member

    I think I got a brick now, I am running Sveasoft firmware and it has been running fine until I reset it with the "factory default" option. Now the power light on the router is just blinking and I cant access the web setup? any suggestions?

    Thanks in advance
  2. jwranger

    jwranger Network Guru Member

    I tried shorting out the 15pin trick and go it to ping in safemode but when I try to push the firmware upusing "tftp" I get a "timeout occurred" and know tftp might have a limit of 2mb but I tried useing the latest from linksys and Freifunk just because its only 1.5mb. Any suggestions?

    Thanks in advance
  3. vincentfox

    vincentfox Network Guru Member

    Have you read any of the un-bricking guides already?

    Something often not mentioned, is it's handy if you go through ANOTHER switch instead of coupling directly to LAN port on the WRT. This keeps your PC seeing live ethernet the whole time, which makes timing the tftp send much easier.

    After that it's mostly persistence. Took me 30 tries to unbrick one router.
  4. Couledouce

    Couledouce Network Guru Member

    Took me a good many tries to debrick mine too, I even left it on a shelf 3 months for a cooling off period, then one last try before the trash can.

    Setting the PC connection to a static IP address was the one thing I wasn't doing that made the difference for me.

    Good luck.
  5. jwranger

    jwranger Network Guru Member

    Thanks for responding, Yes I have read them all and I am setup right with static IP ( ( now is it true that you have a limit of 2mb to push up to the router when using tftp or does that matter?
  6. vincentfox

    vincentfox Network Guru Member

    I have read of a 3-meg limit.

    Factory firmware, or DD-WRT "mini" version should work fine.
  7. jwranger

    jwranger Network Guru Member

    So I will just keep trying to tftp up the firmware until it works right
  8. jwranger

    jwranger Network Guru Member

    I have tried over 50 times to push the firmware up to the router without luck and i don't think it will come back to life. So I called linksys and acted stupid and they want to send me a now router and I would have to send them my old router my (v.2) and they will whatever the latest one is. Is it a bad ideal?

    Should I do it???

    Thanks in advance
  9. SteelersFANinMA

    SteelersFANinMA Network Guru Member

    You could try building a JTAG cable for the router before trashing it. As far as them sending you a latest version router, (v5 running VxWorks) it's a bad deal unless you can take it to a local store and trade it for a pre v5 router.
  10. jwranger

    jwranger Network Guru Member

    Well, I sent it back so we will see what I get. If I do get a v5 then go to a store and buy one that is pre v5 and return it and give them the one I
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice