hELP: wrt54g v1.0 Flash Ok but still not working

Discussion in 'Cisco/Linksys Wireless Routers' started by san9jay, Jun 4, 2007.

  1. san9jay

    san9jay Network Guru Member

    I Have a wrt54G V1.0 that was bricked when doing a reset.

    I successfully reflashed using the tutorial (method 2 Grounding pin 16) with the WRT54G_2.02.2_US_code.bin firmware using TFTP.

    After that I upgraded to the latest linksys firmware 4.30.5 using the linksys upgrade utility.

    All was well at this point. I powered off and restarted the router and it was working fine.

    I should have left it alone BUT I thought I would try the DD-WRT V23 firmware and upgraded the firmware using the web interface. The flash seemed to go ok and I got a success message but after that the router would not work. On power on the power LED and DIAG led would stay on and there was no traffic on the LAN port.

    I cursed myself and opened up the box again tried the pin 16 to ground mechanism again and reflashed the WRT54G_2.02.2_US_code.bin again using TFTP.

    Again TFTP said it was ok and immediately after the flash the diag LED went off but no traffic on the LAN port. I powered off and on and again the diag LED stays on all the time with no traffic on the LAN port.

    I have repeated the flashing procedure many times even using the Linksys firmware upgrade utility directly. The flash seems to go ok but the router on power reset hangs with the diag led on all the time.


  2. san9jay

    san9jay Network Guru Member

    Looks like I did not follow the instructions of the DD-WRT install.

    Apparently I was supposed to first install the minimal version and then upgrade to the standard version of DD-WRT.

    On another forum a users says that not doing this could have caused the NVRAM to get corrupted.

    My question is now that it is corrupt how can I recover the device.

    I have already tried
    1) "Hard reset (holding reset button for 30 secs while plugging in the power). that does not help
    2) Going back to an older version of the Linksys firmware (tried 1.02 and 2.02 and 4.30. The firmware installs successfully over TFTP but the router hangs with a permanently lit diag light and no traffic on the LAN ports.

  3. san9jay

    san9jay Network Guru Member

    i built a JTAG cable. Backed up my cfe, nvram and kernel

    flashed a new cfe generated for my device using the skynet tool.

    rebooted and the device now pings and I was able to install a new firmware but it still has a blinking diag light and still does not work.

    I tried clearing the nvram but still no luck..

  4. vincentfox

    vincentfox Network Guru Member

    Do you have a serial console attached? What is shown there?

    I'm sure you have read this somewhere already, but pin-shorting is DANGEROUS and not a recommended way to fix anything. The risk of flash-chip damage is high. Much easier and safer to fix things in most cases from serial console or JTAG.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice