Help: WRT54G v5 - Bricked

Discussion in 'Cisco/Linksys Wireless Routers' started by felix83, Oct 27, 2006.

  1. felix83

    felix83 Guest

    Hi all,

    I tried to upgrade my firmware to DD-WRT v23 SP2 using the guide from Scorpiontek for Linksys WRT54G v5.

    But after the final step, I hit a problem and now i think my router is bricked!

    Here's my symptoms:
    1. Power LED just keeps blinking
    2. My LAN LED only lights up for ports with a LAN cable plugged in.
    3. NO DMZ LED ligthed
    4. Can't access web GUI from IE -
    5. But able to ping successfully

    I've gone thru various posts in this forum and other external links and here are the recovery steps i've tried/attempted:
    1. Management Mode - failed, there's NO web GUI at all.
    2. TFTP.exe utility - I get Firmware Upgrade succesful but the power LED still keeps blinking even after power cycling.
    3. Command prompt TFTP - I get transferred succesfully but the power LED still keep blinking even after power cycling
    • I've tried TFTP using TWO different official Linksys firmware 1.00.6 and 1.01.0
    • I've also gone thru the De-Brick guide here in

    Also, after reading the various posts here - I think i've narrowed down my mistake when flashing the firmware to DD-WRT. I didnt reset to factory settings before proceeding.

    Anyone can give me some tips or any other methods to debrick my WRT54G v5?
  2. tfud

    tfud Guest

    I have the same problem, forget to set to defaults as well.
  3. mrdude

    mrdude Network Guru Member

    I had the exact same problem as in the first post...I could ping the router but had no tftp access or web interface.

    I managed to get it working by doing this..

    I downloaded the linksys tftp tool...and set it to 50 times to try and flash the firmware...

    It wouldn't I had to keep pulling out the power cable and pluging it back in.. while trying to tftp, I must have tried sending the firmware via tftp about 300 times untill it eventually got sent..then you leave the power pluged in and the router will eventually reboot itself.

    Then it should be working.
  4. rakeshjmd

    rakeshjmd LI Guru Member

    blinking pwr light

    please hold reset switch for 40 seconds& then while holding the reset switch
    unplug power cable for 10 sec & then replug it ***then release switch & do a small power cycle of the router ==> change card speed to 10 half duplex
    your issue may be solved
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice