Help..WRT54GS flashed with Thibor16b

Discussion in 'HyperWRT Firmware' started by octyl, Jan 14, 2007.

  1. octyl

    octyl Network Guru Member

    Yes I know, I'm a idiot but it's after the fact now and I can't get Thibor15c flashed back into it. can someone please help? it seems to be working right but it's the wrong firmware and I would like it out...

  2. Thibor

    Thibor Super Moderator Staff Member Member

    you're right, you ARE an idiot. i don't think the web interface will allow you to flash an incorrect firmware, so you will have to tftp it. look for instructions on how to do that.
  3. shadow2k6

    shadow2k6 LI Guru Member

  4. octyl

    octyl Network Guru Member

    I keep getting "wrong code pattern" from the tftp program using the boot_wait method, shorting the pins out wouldnt make much diffrence would it? also it doesn't say which pins to short out on a wrt54gs version 2.1.

    the boot_wait does appear to be working as it's returning the error "wrong code pattern" and also "invalid password" when i tried "admin" just to dbl check.

    also why is it checking the code pattern now, yet it didnt check it when i was putting in the wrong firmware?

    is there a override...?

    BTW: thanks for the fast reply...
  5. shadow2k6

    shadow2k6 LI Guru Member

    I've never had to recover from a serious brick condition, but I've recovered with tftp process several times.
    1. Assign a static IP address to your computer (try
    2. Download latest LINKSYS firmware for your router
    3. Open 2 windows running the ping -t in the first window and the second window have open to run "tftp -i PUT LinksysFirmwareFilename.bin" ready to run so you can just hit enter when the router starts responding to ping.
    4. This should upload the latest linksys firmware. If not, try again. Timing is everything.
    5. Reset your linksys router.
    6. After you have working linksys firmware, you can then load your favorite thirdparty from the web interface.
    7. Assuming this worked, don't forget to set your workstation address back to dhcp.

    This should work assuming that your router responds to ping at some point when starting up.
  6. Thibor

    Thibor Super Moderator Staff Member Member

    ok, this is risky but it WILL work.
    start an upgrade process using the SL bin file, and pull the power cable when it's about 1 minute in.
    THIS WILL BRICK THE ROUTER, and put it into recovery mode.
    now do the tftp process that has been described above.
  7. Toxic

    Toxic Administrator Staff Member

    try forcing a DDWRT Generic bin file with TFTP
  8. Thibor

    Thibor Super Moderator Staff Member Member

    ya, that might do it, i'm not sure what codepattern it has.
  9. octyl

    octyl Network Guru Member

    no go on the generic ddwrt bin file tftp'd in boot strap mode...( wrong code pattern same with tomato) how risky are we talking on bricking it? It is working right now (typing this msg over it ) could i just leave it as a wrtSL54gs without problems?

    it's been running fine...


    Update... Thibor you are the man...!!!! Thank you so much! worked like a charm. Donation sent your way not only for all the great work you do for everyone but taking the time to help the idiots.... LOL..thank you man!
  10. Thibor

    Thibor Super Moderator Staff Member Member

    Received, thank you very much, very generous man. glad you've got it working. try not to do it again, a little more observation in future, eh :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice