Discussion in 'Networking Issues' started by g.g.ubuntu, Apr 28, 2007.

  1. g.g.ubuntu

    g.g.ubuntu LI Guru Member

    Hello there everyone! Nice to stumble onto this site, especially when I am in such trouble. I hope whoever reads this has time because I need to explain quite a bit my system is not the average.

    First of all, I have a dual boot system XP and Ubuntu (great linux distro for those not in the know :)), I use the grub bootloader and I can switch at will. My hardware set up isn't that difficult I suppose either. I am in canada and us Bell as my provider, I get a 384k DSL line (really only usually 330Kb, I'm a bit far from the nearest city). My modem is connected directly to my Linksys WRT54GS Version 6.0. I then have wireless network cards for 3 of my computers (2 desktops and 1 labtop). In addition, I have a hardline coming out of it to go to my main computer which is the dual boot pc I'm on right now. (This is twofold, Ubuntu has a bit of trouble with wifi cards and I use it to ensure I can always get a direct line to the router if the wifi drops.).

    So, thats clear enough. Now comes the big problem. I will start out by saying that I do use Bit Tornado (a bit torrent client, good one too) for most of my downloading, for the most part it is all Musical/Audio Podcasts and Video Podcasts and other assorted files from legitimate sites. I like to use it as a lot of sites out there don't have the bandwidth to support direct FTP downloads to their entire audience. I also use it to download huge linux distros.

    Anyway, suffice to say I like using my Bit Tornado. I had it set up before with old firmware, it was the version that came right before the new firmware 1.52.0, I think it was 1.51.6 or something like that. I had it configured fine for Bit Tornado, allowing 3 open ports to be directed to my Ubuntu Boot (not my windows XP). I had also of course set Bit Tornado to listen on those three ports so it can connect to the Trackers and bypass the NAT.

    So everything worked fine for months, and then just 3 days ago it broke. I dunno how, but my router completely reset itself. By that I mean that the whole router did a factory reset, I've never seen that before I must say. So I woke up at 8 AM one day to find that my Wifi had been enabled and wide open all night (I left it on to download a large linux distro (over 2 gigs). I was very alarmed. The password had been reset to the default and the wan management had been on... meaning anyone could have flashed anything onto it.

    I was alarmed, I had of course changed the password to a 15 character random password. So, I unplug the internet after having downloaded the newest firmware (1.52.0) and figured flashing the newest firmware would make sure there was nothing wrong with it. So I did and BOOM!

    Ever since, I couldn't forward ports... or change the security settings. I could however set up the wifi network and put WPA PSK on it to secure it. I found this highly confusing and so I decided to wipe the firmware and put DD WRT on it. I followed the tutorial on this site (thank you ummm, scorpion/shawn, very helpful) and it went flawless. However, it doesn't seem to have changed the problem. I do prefer the new interface but I still can't change the settings other than the wifi and pass.

    So, my basic problem is that I have to get Bit Tornado working again. I've eliminated every problem that could possibly be caused by software/my OS.I've been testing whether my ports were changed via this program shields up (link)https://www.grc.com/x/ne.dll?bh0bkyd2
    Scanning common ports tells me if I was able to allow IDENT13 to not be filtered, and scanning custom ports tells me if I had actually port forwarded the specific port. I am almost certain that my problem is with my router, (either that or my provider is throttling my Line but it's doubtful as I've been doing it for over a year and a half).

    Has anyone ever had this problem where they could modify and change their wifi name and encryption but not their ports? I find it very weird... is it possible something fried in the hardware router preventing me from changing the ports? In addition, does anyone have a diagnostic that could give me a definitive answer that the problem lies with the router itself?

    I hope someone can help and thank you for spending time reading all this, hope I didn't miss any information you need to help. I do have significant networking experience, mostly with wired but lately with wireless, so feel free to get somewhat techy. Oh and just in case you forgot, I flashed DD WRT on it successfully, at least I think ><.

    Hope someone can help. I will check back later, have to go out for a bit.
  2. g.g.ubuntu

    g.g.ubuntu LI Guru Member

    Ummmm, anyone? I really would like to know if my router is hosed... I would rather fix it but will buy if its turned into a brick.
  3. ifican

    ifican Network Guru Member

    The only way to definitively tell is to use a known good working router and see if the problem persists. It is a strange problem, nothing i have ever read about, but i have learned over the years never to count out what your isp is doing. When you say port forwards are not working, does the router accept them and they just dont seem to work, or does it not take any input in those fields?
  4. g.g.ubuntu

    g.g.ubuntu LI Guru Member

    Yes, I actually can access all the pages on the DD WRT firmware, I can also modify the ports and forward them and then when I save the page seems to work. I can log back in later and it will still be checked. I however after doing this check two fold (here, link). That link takes ya to a tracker that is operational and basically either reports you can connect through your open port or not. I also use the shields up and do a custom probe, both ways always respond that my port is stealthed (when I know I set it to open).

    The same happens when I turn off Ident Filtering or any other filter setting. So yes bottom line is I can modify the fields, they just don't seem to change anything in actuality... I also can't try another router, cuz my only other one is an old 3COM 4split that doesn't have a gui, just splits a connection.

    It seems unbelievable as since I've flashed DD WRT on it, its impossible the software is bad isn't it?
  5. ifican

    ifican Network Guru Member

    Anything is possible, but i find it unlikely that it bad software, though the flash may have corrupted something. Had you tried resetting to factory defaults, flashing, resetting again and then testing. I know it seems like a pain, but sometimes something in nvram gets corrupted and it stays through the flash process and makes routers do goofy things like you are experiencing. If you are sure you have port forwarding setup correctly, if you have two machine you can test it by putting one machine in front and the other behind the router and seeing if you can hit that port, that way it takes your isp out of the equation, if it works and then does not when connected to the internet, your isp is doing something with you connection.
  6. g.g.ubuntu

    g.g.ubuntu LI Guru Member

    Hmmm, I'm not sure if I understand exactly what you mean by reset factory defaults... I mean I already flashed DD WRT on it... you mean the button in administration to reset it to defaults? and then reflash DD WRT or the Linksys firmware? Please clarify what you mean, and thank you for helping :)

    PS: sorry for responding so late, I was out.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice