Hidden menus/functions in official Linksys "wrt54gs.3.3

Discussion in 'HyperWRT Firmware' started by Gheimposse, Jan 3, 2005.

  1. Gheimposse

    Gheimposse Network Guru Member

    Hy guys ... I just wrote different postings in each and nearly every forum site from HyperWRT, over Sveasoft , Wifi-Box to TinyPEAP cause I liked to have a special firmware having the following features:

    - wifi restrictable access to the webmenu
    - reboot, restart, telnet, etc. (hyperwrt 2.0b3)
    - 0-251mW wifi power (Sveasoft 6.0RC5a)
    - 13 (hyperwrt 2.0b3) or 14 wifi channel (Sveasoft 6.0RC5a)
    - extra option in the firewall menu for cookies,activec, etc. (Hyperwrt 2.0b3)
    - vlan support (Sveasoft 6.0RC5a)
    - VPN Server (Wifi-Box)
    - Radius server (tinyPEAP based on Sveasoft satori 4.0)

    Cause at the moment each and everyone is focusing on different targets I didn´t saw a chance for my ideas.
    So I downloaded the official Linksys wrt54gs 3.37.2 firmware from Linksys.
    UnTARing the package under windows went through the folder to /www.
    Having the HyperWRT 2.0b3 on my router I compared the "firewall" page from the original to the Hyperwrt one realising that both offering the cookie, activex, etc. option .... only the original does not show it in the webinferface.
    I also saw a folder /vlan not finding any .asp page for this in the /www folder!
    I took me the half night to went through the HyperWRT and the actual Sveasoft firmware to take out the best .asp of both to put them in the actual, official Linksys firmware.
    To put the best of HyperWRT, Sveasoft, TinyPEAP, Wifi-Box in one firmware I need the help of all of you cause I need the actual sourcecodes from the following versions:

    HyperWRT 2.0b3
    Sveasoft 6.0RC5a

    Maybe someone can help me or the programmers of the different releases may support me. GPL isn´t a run for money ... so I hope
    I´ll be supported with those to develope a new unique firmware.
    I´m not a programmer ... but I still adapted the "wireless advanced"
    webinterface from the actual hyperwrt 2.0b3 firmware to offer up
    to 252mW txpower in steps from 0-300% (=252mW) antenna power.

    Call me a BORG. :computer:
  2. Avenger20

    Avenger20 Network Guru Member

    HyperWRT and Wifi-box source-code is both available for free at sourceforge.net
    For Alchemy firmware, you'll have to wait until it's a public release.
    Don't know about TinyPEAP, can't find any source code, you probably have to send them a mail.

    If you want all the Satori/Alchemy features, the best way is to start with their firmware and add features from other firmware you like (the way around is much more difficult).
  3. Jago

    Jago Guest

    I wish I could help you, but I'm not a programmer at all :(

    If you put "Static DHCP" on your wishlist for a "perfect" firmware it's just like mine :)

    If there is any way I could help you just let me know and I'll do what I can!


  4. Gheimposse

    Gheimposse Network Guru Member

    Thanks for the info Avenger20.
    But maybe I´ll start with your firmware cause the Alchemy 6.0RC5a (and all previous down to Satori 4.0) didn´t worked properly with my WRT54GS.
    However only your firmware works 100% stable ... the others connect one time and then loose the line and (nearly) never connect again. :evil:
    I can´t imagine why others didn´t work properly ... I did all possible way to flash the new firmwares correct:
    1.) set the current fw to factory defaults.
    2.) upgrade the new fw.
    3.) set the new firmware to factory defaults or use "start with factory defaults" if using a sveasoft and updating it with another.

    I also tried to flash firmwares step-by-step ... starting with a satori 4.0 (which works stable and connects the dsl line!) then upgraded to a alchemy 6.0rc1, then 6.0rc3, then 6.0rc4 and finally to the 6.0rc5a.
    Also using this step-by-step upgrade the dsl line was lost after the first connect and didn´t reconnect!

    After flashing the Sveasoft fw I now have the same problem with your hyperwrt fw ... I can´t reach *.ebay.de.
    The last time I solved the problem by flashing starting with a 2.0b1 over a 2.0b2 the the current 2.0b3 fw. Now it didn´t help! :?:

  5. zaphod

    zaphod Network Guru Member

    hey buddy,

    not so load we could read ya ;-)

    first thing:

    check your MTU Settings for the wan link... if you use pppoe then try to use 1492 manually..

    if that didnt help:

    try this: get the latest original firmware from linksys for the gs.

    1. factory default
    2. after that power off router
    3. restart and flash with the web-interface the orig. firmware
    3. after flashing is complete and its rebootet itself, another factory default
    4. after up again turn it off
    5. switch on, make your settings and try

    if its also got the problem check your nvram-settings (but you need to flash another firmware to get telnet or ssh or cmd-interface per web)

    command: nvram show

    also check if your complete ram is used: could try free, dmesg kmesg ano so on...

    be careful with the flashing procedure.. it could brick your router ( i also bricked my wrt54gv1 router.. but with help from here its an undead ... an living one again :)


  6. Gheimposse

    Gheimposse Network Guru Member

    Ok ... thanks for the tips.
    I still tried to flash the Alchemy 6.0rc5a ... turning of the router by pulling the power cord and reboot it and than setting the factory defaults.
    MTU was on automatic (using 1492) but didn´t work at all.
    I also flashed the alchemy 6.0rc5a after having the hyperwrt up and running.
    After the flash the alchemy took all settings beeing entered by the hyperwrt but not beeing able to reconnect the line after the first connect and lost of line some minute(s) later.
    I also entered all settings in a clear firmware from Linksys itself: same error!
    Than I loaded a sveasoft alchemy again ... also same error.
    Both took the settings from the previous version!
    Than I flashed the hyperwrt firmware and also this fw took the old settings from the alchemy ... but working 100% stable!!! *can´t explain*
    So ... funny thing was that the default firmware (when delivered) was a german firmware. Every other firmware was english! So it was a WRT54GS-DE.
    Is there any problem with this one regarding other firmwares???
  7. zaphod

    zaphod Network Guru Member

    no problem i know...

    got a wrt54gv2 eu and running hyperwrt 2.0b3 with no probs

    also a v1 us and no probs with alchemy 6.0 rc5a

    but i am only using the v1 for the wds link between 2 rooms so dont know if it will get stable wan connects with pppoe..

    but i know there is a pppoe bug in the firmware which is something with the mtu-size ... so set it manually to 1492 for pppoe.


  8. Gheimposse

    Gheimposse Network Guru Member

    Ok ... now the alchemy-6.0rc5a is up and running!!!
    Took me some reboots and the adjusting the mtu size. *thx*

    By the way ... did somone tried the VLAN function in alchemy firmware?
    I did it ... and it didn´t work! I choosen "W" on vlan10 with "None" and port 1-4 with "LAN" .... but could still reach my wired pc from my wireless pc. :-(
    is this a bug??? Still tried to check the "more" (help) ... but it only opened an empty .asp page. *damn errors*
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice