Holy cow the WRT54G v5 SUCKS

Discussion in 'Cisco/Linksys Wireless Routers' started by meimei, Dec 28, 2005.

  1. meimei

    meimei Network Guru Member

    I was just at my coworkers' house to configure their WRT54G. So loaded with confidence (have been playing with WRT54G v2 and v3.1 for months) I arrive and fire up the web interface (

    That's weird. The page doesn't load fully (no text is displayed, only textboxes and checkboxes). Ok time for a refresh! Still doesn't work. Hmmm maybe they have so much crapware on their PC it's interfering with IE. Ok how about Firefox? That's weird! It still doesn't load.

    Ok I'll try a different computer... IT STILL DOESN'T FREAKING LOAD!


    I noticed the firmware 1.00.1. So I figured the device's firmware must be corrupt or something because all I know is version 4.xx firmwares from the older WRT54G models. So I just did a search on the WWW only to find out there's been a fifth revision of the WRT54G: v5.

    I told them to return the unit to the store they bought it from and insist on getting a replacement, no matter what!

    To be continued...
  2. NateHoy

    NateHoy Network Guru Member

    First try would be to call Linksys and ask them if they'll replace the unit for an older model. Linksys is reportedly doing this for people.

    If not, go back to the store and dig through their stock of WRT54G units. If you find one whose serial number does NOT start with CDFB, buy it.

    Barring that, it's well worth the extra money (IMHO) right now to buy a WRT54GS, which still have Linux even though they've cut the memory down. Or get a WRT54GL, which is a WRT54G V4. Linksys is charging a premium for both units, because the WRT54G V5 is a bit cheaper to make (hence why they made this conversion).

    Linksys is not saving money with this conversion, though. At least I doubt it. Reviews on the new units are generally not very positive, and there's a lot of trust lost when you start screwing around with a working unit and don't tell anyone.

    Linksys would have done very well to introduce the WRT54G V5 as a new router, for example calling it the WRT54GV "Value Edition". They would have sold like hotcakes for the low-end market, and the modding community would have continued happily paying a premium for the Linux-based units. Instead, they traded the good name of the WRT54G for a quick buck. This WILL haunt them in the long run.
  3. Valmor

    Valmor Network Guru Member

    I feel your pain man. I was lucky enough to get everything working and the latest firmware on, which makes things run nicely. BitTorrent crashes it for me though which ruins everything. :(
  4. andyamo

    andyamo Network Guru Member

    WOW! I have EXACTLY the same story! The web interface is completely buggered. Just a bunch of ASCII characters, and half-loaded buttons.
    I tried to help my buddy do a re-flash, but the Linksys site only supplies the .bin file and not the windows-based flash upgrade utility.

    Well, I can't! , unless there's a back-door, or a utility that will support v5.

    So, it's time to get on the horn and start complaining!
  5. vincentfox

    vincentfox Network Guru Member

    I find it constructive, to go to Amazon, Buy.Com, and any other major site with a Customer-Review function. Post what you feel about the product. Some people do read these things before purchasing, so it might save others some troubles.
  6. j3r3myk

    j3r3myk Guest

    I had the web admin interface problem on my WRT54G v5, but it was cured with an upgrade to firmware 1.00.6.

    The trick is to apply the firmware upgrade without a working web admin interface.

    This is what I did:-

    With the router powered on, hold the reset button for 30 seconds.

    While continuing to hold the reset button, power the router down for another 30 seconds.

    Keep holding the reset button for yet another 30 seconds after powering the router up again.

    Then go to in IE (NB. this didn't work in Opera when I tried it). You'll get a simple 'Administration Mode' web page, which allows you to upgrade the firmware.

    Once that completes, power-cycle the router again, and the web admin interface should be OK, although infuriatingly it still has a few bugs when viewed in Opera. Stick to IE and you should be OK.
  7. Ricardito

    Ricardito Network Guru Member

    Sounds familiar

    I recently switched to the WRT54G v5 from a 2Wire905 router, thinking I might get a better signal throughout my house. (It also had more than one ethernet plug-in, which the 2Wire didn't.) It's been nothing but trouble, losing internet connections at random times. Linksys sent me a replacement, but I'm having the same problems with the new one--updating to latest firmware was no discernable help either. After many hours on the phone with Earthlink and Linksys, I'm about to send it back and ask for a refund. I've been told that the 2.4GHz cordless phone in our house could be causing interference. I find it odd that the 3+ year-old 2Wire NEVER had such problems--even though it sat, literally, next to the phone base--but this latest model by Linksys does. Oh, and the signal strength is no better.
  8. vincentfox

    vincentfox Network Guru Member

    If you bought it from Amazon, or similar online web-site, please consider posting a customer review!

    Or, if you bought it from brick-and-mortar, after you return it send a terse email to the addresses on Linksys Contact Us page.

    Will take very little time and worth the effort!
  9. VortexSwirling

    VortexSwirling Network Guru Member

    If you search Amazon's customer reviews for V5, there are numerous warnings. The problem is those reviews don't top the list so you have to search for them.

    I've found when reading reviews you should only look at the negative ones. (All the positive stuff is in the advertising). So if a buyer on Amazon were to filter for one star ratings it comes up right away.

    Just a comment. It doesn't really help this thread initiator.
  10. andyamo

    andyamo Network Guru Member


    Your admin management login trick worked PERFECTLY! You saved me 2 hours on the phone and a major arguement.

    Three cheers and thanks again!
  11. micah

    micah Guest

    does this mean that the router can't be upgraded to third-praty firmware like alchemy or dd-wrt ?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice