Hoping to un-brick a WRTSL54GS via tftp

Discussion in 'General Discussion' started by benwei, Jan 22, 2008.

  1. benwei

    benwei LI Guru Member

    Hey all,

    I'm trying to un-brick a WRTSL54GS that I tried to do a firmware upgrade on. Right now when it is powered up, the USB light stays on solid and the power light blinks continuously. *The ethernet light will also come on if I connect it to my laptop. *

    I am able to get it to take an image via tftp (I see the ethernet light flash as the image is transferring, and my tftp client on my laptop reports that it sent the file successfully), but after it is transferred, nothing seems to happen. *I have let it sit for up to 15 minutes after flashing, then restarted it, only to get the same blinkenlights. *

    I've tried the stock Linksys firmware image, an OpenWRT image, and a Tomato image, all with no effect. *

    Anybody have any ideas on how to fix this, or what could be going on with the download-but-no-actual-flashing problem?

    Thanks a bunch,Anybody know what's going on here and how I can fix it?

    Thanks so much,
  2. danix71

    danix71 LI Guru Member

    Try to keep pushed the reset button cca. 30 sec.. Then off, then on (the router). See then.
  3. benwei

    benwei LI Guru Member

    Hi danix71,

    Thanks for the suggestion -- I tried holding down the reset button for 30 seconds both after doing a firmware flash and just after powering the router on, but it didn't seem to have any effect.

    A few more details of note:
    I originally had OpenWRT Kamikaze installed, and wanted to try out Tomato, so I used the tftp method to flash on the Tomato image for my router, and after that flash was when things stopped working and I just got the blinking power light.

    Also, I am able to ping my router via the Ethernet connection, and I am also able to offer it a tftp download at just about any time it seems (i.e. I don't have to do it immediately after the router boots, which is what I am used to). It's as if the thing is stuck in the bootloader somewhere awaiting an tftp image download, but then doesn't act on said download when it arrives.

    Thanks again,
  4. danix71

    danix71 LI Guru Member

    I had the same experience as you have: Linksys original, openwrt then tried Tomato. Didn't work for me, router not responding on ping. So, I applied the *pins short-circuit* method...but that was my case...
  5. benwei

    benwei LI Guru Member

    I tried the pin-short-circuiting route to no avail.

    However, if I understand it correctly, this won't even help me with what I need. From what I understand, the point of shorting the pins is to get the router into a mode where it is able to accept a firmware image via tftp. My router is *stuck* in such a mode it seems. It responds to pings and accepts firmware images, but does nothing with them.

    Thanks again,
  6. danix71

    danix71 LI Guru Member

    Yes, you understood correctly. That's why I've said *it was my case*. Sorry, but don't know why your router doesn't *do anything* with the tftp-uploaded-firmware...Maybe this advice will help...
  7. stangri

    stangri LI Guru Member

    Afaik, if the power is blinking and USB is constantly on, the router is not accepting the new firmware over tftp.

    I'd second danix71's post -- try shortening the correct pins to force the router to listen to the tftp firmware update. I've had same experience as he have had, only when going from thibor to openwrt on WRTSL54GS. Shortening the pins helped.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice