How come my Linksys CD doesn't install correctly?

Discussion in 'General Discussion' started by Xpred, Jun 26, 2005.

  1. Xpred

    Xpred Network Guru Member

    Whenever I try to install a WMP54G access card, my CD never can read it. It autoplays one sec, and the screen disappears. I manually open the CD files and try to run setup.exe. I click it, and it has that "loading mouse" icon, then does nothing. It seems to do this for all my Linksys CDs.. maybe my OS is wrong?
  2. matthiaz

    matthiaz Network Guru Member

    Shake it off, dude! Just download the driver off of linksys' page or even better: use the newest broadcom driver found here!
  3. Xpred

    Xpred Network Guru Member

    I tried doing the drivers off the Linksys page and burnt it onto a CD using another computer. (remember, my computer does not have internet yet because I havent been able to install any drivers). It's exactly the same files in the CD. When I just click setup.exe, the screen will appear, and disappear. The broadcom driver doesn't do jack for me either.
  4. bigdog

    bigdog Network Guru Member

    Check to see if you have a firewall that may be interfering with it. I tried the Linksys "EZ Setup" CD for my router just to see what it did and my firewall nuked it each time (no warning, just crashed the app)
  5. Xpred

    Xpred Network Guru Member

    There is no firewall enabled on anything. My Windows Firewall is completely turned off. I found a temporary solution which is to run the setup.exe under Compatibility Mode Windows 98/ME. Does anyone know why I have to run under this mode so it won't crash immediately (disappear) right after I open it through Windows XP Professional?
  6. jagboy

    jagboy Network Guru Member

    i am thinking that it is a service patch that you might need from microsoft. try doing a windows update.
  7. DocLarge

    DocLarge Super Moderator Staff Member Member

    FYI, peops, the man "does not" have internet access, so he can't do any upates or downloads... 8O

    I "just" went through this with that F'ing WMP54G card not more than 3 months ago (it works now). One day, it just decided to work with the drivers on the linksys cd. Prior to that, I was using replacement drivers from RaLink for the WMP54G. You should download this from another computer obviously:

    Choose the Windows drivers dated 2005/04/25. This will be a alternative that shouldn't give you too much heartburn :)

    Should you burn this to a cd and it still not launch properly, just "righ" click on "my computer", go to properties, bring up device manager, go to "properties" for the linksys card, choose "update driver", and then just go to the files on the disk (make sure you expand the file prior to burning it.). This workaround should help.


  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice