How do I flash Tomato to ASUS RT-N66U?

Discussion in 'Tomato Firmware' started by Rocky Grim, May 22, 2013.

  1. Rocky Grim

    Rocky Grim Networkin' Nut Member


    I cannot seam to figure out how the heck to flash Tomato to my ASUS RT-N66U. I have tried flashing to the ASUS original firmware and updating from the router page. It tells me that it is the wrong firmware. I have also tried using the ASUS restoration utility or whatever it is called. I put the router in recovery mode (power light flashing) and select Shibby's firmware and hit upload. It constantly tells me wrong IP address. I have tried using and .10 on my computer but it will not flash it. When using the recovery utility I can only select a firmware to attempt to upload only after installing the software. If I close the software then try to click browse to select a firmware to upload it will not work. It will not even show the box to pick a firmware. It does nothing at all! What am I doing wrong? Has anyone successfully flashed a version B-1? Also, if I want to use a Toastman build for the RT-N66U can I flash any of the builds with 64 bit NVRAM or less?

  2. darkknight93

    darkknight93 Networkin' Nut Member

    just a thought:

    Just set IP address manually to SN and Gateway+DNS; then open up command prompt (cmd) and type: "ping -t" for continous ping-requests.

    In recovery mode the router answers with TTL=100, TTL=63/127 indicates that the router itself is working and not in recovery mode - in the short Episode of TTL=100 you can run the Firmware Recovery tool from Asus and Flash the tomato build (.trx files)

    If you have any further questions, feel free to ask!
    Infact I dont have a clue what toastman builds you can use for RT-N66U
  3. Rocky Grim

    Rocky Grim Networkin' Nut Member

    Hello and thank you for your reply. The page you linked me from is the page I found and was trying to use to flash the router. The information in my first post is what happened what I tried. It will either says Invalid IP or it will not let me select a trx router image to flash. When I click browse nothing happens at all. It just sits there forever. I see that others where having similar issues and where able to flash the router through the router tftp page. One time while trying to log into the router it took me to a page that said something about tftp. It looked like it was going to let me flash the router via tftp from the browser. I didn't know what it was at first so I closed the page. I wish it would pop up again. I think that may be my only way of flashing it. If anyone know how to get back to the tftp router base please left me know.
  4. Monk E. Boy

    Monk E. Boy Network Guru Member

    Silly question, but you are using Ethernet to flash it, right?

    For what it's worth, you don't have to assign an IP address to your Ethernet card at all, you can just put it in DHCP mode, plug it into the router (which is in recovery mode, the slowly flashing light), wait for it to get a self-assigned IP address, then run the Firmware Recovery Utility to flash Tomato to the router.

    As far as which Tomato image to flash, you probably need to choose either a 32K or 60K MIPSR2 RT-N build. A 64K version will work but if the bootloader isn't fully updated then your router will brick when it gets over 32K in NVRAM.

    The ASUS firmware will not let you flash anything besides a genuine ASUS firmware to the router (though the normal ASUS website). The utility will complain that the firmware may not work/isn't legitimate/cry profusely but you can OK past it and it'll still flash the firmware to the router.

    If you want to visit the recovery website, assign to your Ethernet card, then open a web browser and go to - that'll open the recovery website. Pay specific attention to the "Erase NVRAM" button there. If, after flashing, your router never fully boots and sits there booting/rebooting/rebooting constantly, put it back into recovery mode, visit this site, and erase the NVRAM. It should then boot normally.
  5. shibby20

    shibby20 Network Guru Member

    you propably use Win7 (long network detection problem). Try Win XP :)
  6. Jacky444

    Jacky444 LI Guru Member

    I managed to get over this issue with using Leatrix Latency Fix. It disables Nagle's algorithm (whats this?) which is probably the cause of the issue.
  7. Rocky Grim

    Rocky Grim Networkin' Nut Member

    Has anyone successfully gotten the flash process to work using Windows 8? I am on Windows 8 x64 and all my other computers are running Windows 7. Therefore, I have not a single computer in my possession
    that is Windows XP anymore.

    I can flash the router from the recovery website right? How do I get that to come up again? I have heard of people flashing Tomato from there. I was able to get to the recovery website one time a couple days ago but haven't seen it since. Do I need to be in recovery mode them try to log into the router?
  8. shibby20

    shibby20 Network Guru Member

    try restore default settings first or using button (not restore but the 2nd one)
    Rocky Grim likes this.
  9. Jacky444

    Jacky444 LI Guru Member

    I used Asus Recovery software on Windows 8 to do it. Also did same on friends RT-N66U with Windows 7. both X64.
    I really don't see why U can't do it.
  10. Rocky Grim

    Rocky Grim Networkin' Nut Member

    Thanks for your help guys. Shibby I contacted ASUS and thats what they said to do. They said to hold in the black button for 30 seconds with the router powered on. Then, I pulled the power out and held the black button down for a few seconds and plugged power back in at the same time. Finally, I was able to upload your build. I think with the ASUS firmware if you enter your settings then try to flash it will not work until you do a reset for 30 seconds. Anyways thanks for your help guys. I greatly appreciate it.

    PS. Anyone know of a good guide that will give me steps on how to stream movies from my PC to other computers and my SmartTV using Tomato etc?
  11. fubdap

    fubdap LI Guru Member

    @Rocky - Now that the memory is fresh is on your mind, maybe you can put together a quick user guide on how to flash Tomato on N66U. Future router owners will love you for it.
  12. Monk E. Boy

    Monk E. Boy Network Guru Member

    I've flashed about a dozen of them...
    1) Hold down reset button
    2) Connect power to router
    3) Keep holding down reset until power light starts slowly flashing on and off
    4) Connect Ethernet cable from PC to router
    4a) If you've flashed another firmware to the device, or configured ASUS's firmware, assign to your Ethernet card, visit, click erase NVRAM, go back to step 3
    5) Set your Ethernet card to DHCP mode, wait for self-assigned IP address (169.254).
    6) Load ASUS firmware recovery utility
    7) Select Tomato firmware
    8) Click Upload
    9) Wait.
    9a) If router is stuck in endless boot/reboot cycle - a couple reboots after flashing is normal and expected (hence 9) - put it back into recovery mode, assign to your Ethernet card,, select erase NVRAM, go back to step 9.
    10) If you're using Toastman's firmware, DHCP is disabled by default, you will have to assign to your Ethernet/wireless card before you'll be able to talk to, others will get a DHCP address and you can start initial configuration.

    Alternate branch:
    5) Assign to your Ethernet card
    7) Select firmware, upload to router
    8) Wait
    8a) If router is stuck in endless boot/reboot cycle - a couple reboots after flashing is normal and expected (hence 9) - put it back into recovery mode, assign to your Ethernet card,, select erase NVRAM, go back to step 9.
    10) If you're using Toastman's firmware, remember that DHCP is disabled by default, you won't be able to talk wirelessly until you enable it. Your current system has assigned to it manually, so it'll be able to talk to

    It really isn't all that different than any other ASUS router, except for the erase NVRAM option on the recovery mode website. And for all I know, all routers with newer CFEs have it, mine are just old.
    misuercarriere likes this.
  13. Rocky Grim

    Rocky Grim Networkin' Nut Member

    Anyone know if this Toastman build is compatible with the RT-N66U? tomato-K26-NVRAM64K-1.28.0502.6MIPSR2Toastman-RT-N-Std
  14. Monk E. Boy

    Monk E. Boy Network Guru Member

    64K builds are only compatible if your particular N66U has the latest CFE. Otherwise it will install, but then the router will brick (completely stop working) once tries to write/read over 32K to NVRAM. I've heard that new N66Us are shipping with the latest CFE, but all I've personally seen is apparently old stock.
  15. jerrm

    jerrm Network Guru Member

    This has not been my experience. Shibby 64K builds work fine on older CFE1.0.1.2. Usually run about 26K free, 38K used. Pretty sure I've tested Toastman, but don't have one running right now, thought they both used the same 64K patches.
  16. alpovs

    alpovs Networkin' Nut Member

    This is incorrect. I ran 64K Toastman and Shibby builds on older N66U's (CFE without problems.
  17. Rocky Grim

    Rocky Grim Networkin' Nut Member

    I just flashed the build I posted earlier. I have been running it ever since earlier when I posted it with no problems.
  18. transcend

    transcend Reformed Router Member

    n66u's are unbrickable by incompatible firmware, which isn't even the case.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice