How do I use router's internet connection via VPN?

Discussion in 'Other Firmware Projects' started by gw, Aug 10, 2004.

  1. gw

    gw Guest

    How can I use the router's internet connection when connected via VPN?

    I am in holiday in the US (I live in Japan) and want to continue to play the online game of Lineage II on the Japan servers. Unfortunately, I have to have an IP address from Japan to be able to connect to the game (they have IP blocked all other countries).

    I am using the " Release Version: 01/02/2004" (I think that is the latest), and can successfully connect to the router's VPN server, but am unable to use the router's internet connection at all.

    Please let me know if you have any ideas.

  2. ctyhuntr

    ctyhuntr Network Guru Member

    VPN and to the internet

    I am having the same problem... however, I notice that I can ping out to everywhere on the internet and traceroute to it. Just unable to webbrowse to it. The interesting thing is I can get to all the site without any problem, but nothing else.

    Please help. Thanks.
  3. Sly

    Sly Guest

    Using a windows machine the solution is to check the "Use the default gateway on the extenal network" option in the properties of the VPN adapter.

    Regards Sly

    Using the VPN tunnel my speed is 1MB per minute max? What is the maximum performance you have seen with the WRT54G ?
  4. secotton

    secotton Network Guru Member

    VPN with internet

    I have been having the same problems, until I found out that it was the client. I could always VPN into the router, but I couldn't do much beyond that.

    I finally found some people saying to change the MTU size to 1392 and this seems to work really well as the MTU size for PPPTP connections (VPN).

    The following is from the MS site and says how to change the MTU size for the VPN connections:;en-us;826159&Product=winxp

    The size I entered for MTU is 1392 and everything works perfectly now.

    If you're not using the Microsoft VPN client, this probably won't do too much for you - but the issues described above seem to be the same issues I was also having.

    It seems that when using VPN, the overhead created with VPN doesn't allow data to flow through the VPN connection using the default MTU size of 1492.
  5. Mosfet

    Mosfet Network Guru Member

    Mac OSX users and Linux users are welcome too!

    Just do the following steps:
    1. open a command terminal
    2. su root
    3. ifconfig ppp0 mtu 1392

    Where ppp0 is the interface name of your vpn connection.
    You can also shorten it to one line doing:
    sudo ifconfig ppp0 mtu 1392

    I tried this on my Powerbook and it works great!
    Should be the same result for linux.
  6. faisal2w007

    faisal2w007 Network Guru Member

    any can help me i wants telnet in WRT54Gwho i can do this

    for all

    plc help :(
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice