How do you remotely access routers down line in a WDS setup?

Discussion in 'HyperWRT Firmware' started by rbngan, Apr 21, 2007.

  1. rbngan

    rbngan LI Guru Member

    I have the following set up. WRT54Gv2-Thibor15c-AP+WDS-A> to WRT54Gv3-Thibor15c-AP+WDS-B> WRT54GSv4-Stock. It is working beautifully for over a year now thanks to Thibor, Toxic and others that gave me help setting this up.

    I searched for remote access help and could not find anything addressing this issue. Since I'm 160 miles away from the location, I'm trying to access each of the routers remotely through my web browser. I can access WDS-A with no problem. I can access all the routers through a browser while connected to the local network. My problem is that I can not access WDS-B or the stock WRT remotely.

    I have remote access turned on for all the routers (HTTPS). I assigned each router their own port number (8082 to WDS-b and 8083 to the WRT). I port forwarded in WDS-A the respective ports to the respective routers IP(WDS-B XXX.XXX.XXX.2, WRT XXX.XXX.XXX.3).

    Am I missing something? Or is not possible to access the routers down line in WDS setup remotely? Do the port numbers have to be in a certain range? I'm grasping at any possible solution.
  2. Thibor

    Thibor Super Moderator Staff Member Member

    your problem is that you are not connecting to the wan port of the wds routers, but the LAN. turn off remote access as it's not needed and use the port redirection page to forward 8082, 8083 to port 80 of the respective router.
  3. rbngan

    rbngan LI Guru Member

    Thanks, I think I see how the connections are working. Once I connected to the WDS-A, everthing behind it is considered LAN and controled by the WDS-A.

    Ok, I got the WDS-B to access remotely but only with http, not https. Under Web access, I tried checking only the https box and could not get in remotely, but could get in https locally. I tried checking both the http and https and got access only with http (not https) remotely and http/https locally. Any way to use https? Since it is behind WDS-A is shouldn't be an issue is it or can my password be compromised?

    I could not get access to the stock router (WRT54GSv4). Is this a limitation of the stock firmware or could it be a setting I have not checked? Could it be a firewall setting? All the routers have the following firwall settings: For the WDS routers, the extra settings are all unchecked. Firewall SPI is enabled in WDS-A and disabled in WDS-B and WRT, Block Anonymous Internet Requests is checked, Filter Multicast is checked, Filter Internet NAT Redirection is unchecked, Filter IDENT(Port 113) is checked.
  4. rbngan

    rbngan LI Guru Member

    Fixed - After all these years I finally figured it out. HTTPS is port 443 not port 80. I changed the port forward from 80 to 443 and it now works when I remote access "https://local or remote address:8082". It prompts for password and a way I go. These are on DD-WRT routers only (I had to say goodby to Thibor's work - his was the best - and I finally upgraded all my stock routers to DD-wrt due to my need for two wireless broadcast - one for WDS, one for AP).
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice