How does AES+TKIP work in WRTs?

Discussion in 'Cisco/Linksys Wireless Routers' started by mlai, Mar 23, 2006.

  1. mlai

    mlai Network Guru Member

    I tried enabling AES+TKIP with WPA and WPA2, my laptops still can only connect to my WRT54GXv2 via AES only. And my WM5 device flat out refused to connect (because it only supports WPA/TKIP.).

    What does AES+TKIP suppose to do? And is there a way to make both AES and TKIP devices work simultaneously?

    Many thanks.
  2. howardp6

    howardp6 Network Guru Member

    When you enable WPA/WPA2 Personal with AES+TKIP all legacy devices that support WPA TKIP are allowed to connect with that encryption and all other devices that support WPA2 AES use that encryption. The is the IEEE standard. The WRT54GX series does not support bridging or repeating, so you are out of luck unless you are using a WET54G or WET54GS5.
  3. mlai

    mlai Network Guru Member

    Thanks for the response. In other words, I should be able to have clients (in this case my laptop with Intel 2200BG) on WPA2/AES and also have legacy clients (Windows Mobile5 device) on WPA/TKIP on my WRT54GXv2, right? However, I am unable to connect via WPA/TKIP on either my laptop (when set to WPA/TKIP manually) nor my WM5 device.......

    So something wrong with the WRT54GXv2? I am still using firmware as the wreak havoc on my LAN because the DHCP server just can't be disabled for the wireless interface with the new firmware......
  4. SBTRS

    SBTRS Network Guru Member

    Are you sure about the firmware version? The SRX200 is currently at 1.01.14. I have both WPA and WPA2 enabled and TKIP+AES selected and I can connect with WPA2/AES or WPA2/TKIP or WPA/AES or WPA/TKIP. With thise settings you should be able to connect with either client configuration.
  5. howardp6

    howardp6 Network Guru Member

    He has a WRT54GX version 2.0 with SRX and with removable antennas. The latest version is 2.00.15, which was released in St Patricks Day. Did you do a factory reset before and after the upgrade to 2.00.15? It may solve the problem with the DHCP server. Only do a firmware update from a wired connection. On both my WRT54GX v.10 and my WRT54GX4 I can connect with WPA TKIP. You should be able to connect with WPA TKIP. I would try the 2.00.15 again.
  6. mlai

    mlai Network Guru Member

    Yes. I did a factory reset before and after the upgrade (hard reset as well). It does not solve the DHCP server problem.

    I can connect to the router with WPA/AES, WPA2/AES, WPA/TKIP, WPA2/TKIP if I select only AES or TKIP. But if I select AES+TKIP, only AES clients can connect.

    I tried the WTR54GS and the problem is the same there. However, on a WRT54GC, everything works as expected (both WPA/TKIP and WPA2/AES clients can connect simultaneously). I think there may be a problem with the Airgo chipsets as I believe both products are based on the airgo chipsets....
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice