How I bricked a WRT54GL

Discussion in 'Tomato Firmware' started by Planiwa, Jul 8, 2009.

  1. Planiwa

    Planiwa Network Guru Member

    I wanted to replace a WRT54G v2 that is now crashing more than daily, with a newish WRT54GL, both running Tomato 1.25.

    My plan was to clone the configuration of the old one onto the new one, so that I could just take the new one to the site, plug it in, and it would take over "smoothly".

    The cloning process seemed straightforward:

    1. nvram export --set >file ### on old router
    2. remove those command lines that are hardware-intrinsic (MAC addresses)
    3. feed the remainder to a shell on the new router
    4. commit
    5. reboot

    It seemed like such a good idea at the time.

    The first snag was that the output of the export command produced several command lines that contained inadquate quoting. One by one, I ended up having to leave out the most complex configs -- scripts, scheduled scripts, QoS settings, static IP settings. (This, of course, made the whole thing rather less useful than planned.)

    But the real snag came after the reboot:

    Now, power flashes fast, 1,2,4,Internet are on.

    No DHCP, no manual access -- no pingability during or after booting.

    30/30/30/10/10 changes nothing

    . . .

    Router to be Cloned,
    Using simple Shell Commands,
    Has become a Brick.

    Sigh. :-(
  2. danix71

    danix71 LI Guru Member

  3. Toastman

    Toastman Super Moderator Staff Member Member

    That's what happened to me when fyellin and I tried a similar scheme. In fact, JTAG hasn't recovered it. The flash chip is unreadable, no idea why...
  4. TVTV

    TVTV LI Guru Member

    Maybe a pin short would work? If the router's already a brick...
  5. Toastman

    Toastman Super Moderator Staff Member Member

    Nope. The only thing that is left is to call a priest. Planiwa, I wonder if yours will follow in it's footsteps?
  6. vanhh

    vanhh Network Guru Member

    Which pins do you use? They are not the same between wrt54gl ver 1.1 and wrt54g. On wrt54gl ver 1.1, I believe pins are 16 and 17 not 15 and 16 like the G version. Planiwa, hope you don't have a need for priest like Toast did, :) :).
  7. mstombs

    mstombs Network Guru Member

    Did you try the latest dd-wrt /Tornado tjtag (v3?) - it supports many more different flash chips than the original HairyDairyMaid wrt54g utility.
  8. Toastman

    Toastman Super Moderator Staff Member Member

    I did, maybe I am making a mistake, but neither could read or write to the flash and perhaps memory is also involved. Perhaps someone with more knowledge than me might be able to see what is wrong, but to me, looks like busted flash or memory. My flash chip was supported by all versions I tried, in theory.

    Shorting these pins really is a last resort, but I've tried it. Now things are definitely fried. The good news is that it was quite old. Planiwa's is a new one :eek:
  9. Edhel

    Edhel Network Guru Member

    Ended up bricking my WRT54GL ages ago. Luckily shorting one of the pins to the antenna brought it back enough for me to tftp. Dangerous yes, but otherwise I'd have a lovely paperweight....
  10. MrSVT

    MrSVT LI Guru Member

    I used this technique to revive mine; I bricked mine with a test firmware that I modified and build myself. Be careful, pins are different between firmware versions, look at the bottom of the page.

    Revival trick #2 did it for me....
  11. Planiwa

    Planiwa Network Guru Member

    Thanks for all the suggestions. I am going to take my time to research this and try whatever I find is appropriate for the WRT54GL, bricked in this particular manner.

    Toastman -- does your brick display the same lights?

    fast-blinking power
    1 2 4 Internet

    (5 lights altogether)

    the right incantations of reset will make #3 light up too.

    I need to find the secret to decoding the message encoded in those lights. :)

    Meanwhile, I'll continue writing Haikus about my brick, black and blue. . . .

    Five lights hold the key,
    To the router's state of mind.
    And the de-brick trick.​
  12. Toastman

    Toastman Super Moderator Staff Member Member

    Sometimes the lights are the same, sometimes they change, I don't think it's useful as a diagnostic tool. Most of the time, all lights are on. Power is always flashing. If your router isn't destroyed, I would suggest do not try to short any pins, until you have exhausted the JTAG option. JTAG is actually the easiest and safest. When googling for help I found dozens of people who have destroyed their routers by shorting pins. And many different variations of which pins to short by well-meaning but un-knowledgeable people.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice