How to build Tarifa from source

Discussion in 'Tarifa Firmware' started by ringer004, Sep 5, 2008.

  1. ringer004

    ringer004 LI Guru Member


    I was wondering what is needed to build Tarifa from source. There are a few things I'd like to play with. I'm using a Slackware 11.0 x86 PC.

    I downloaded the source for Tarifa b032 and base Linksys 4.71.1

    I installed the tool chain in /opt as directed in the instructions.

    The build for the base Linksys firmware worked perfectly, as far as I can tell. A number of .bin files showed up in the image directory.

    When I tried to install the Tarifa source on top of the linksys source, I had some build issues. I tried various ways to put the Tarifa source into the Linksys tree (cp -R, tar and untar). Neither made any difference. I built with and without the busybox and udhcpd directories deleted prior to the copy.

    I did get a build to complete by deleting the busybox and udhcpd directories first prior to the copy, but the build prompted for numerous busybox config options. I answered the default for all these, not knowing if these were the correct options.

    I also had to answer a config prompt regarding SNMP, which I answered 'Y', and this was not prompted for in the base Linksys build.

    Thanks for any help.
  2. jchuit

    jchuit Network Guru Member

    Compiling the Tarifa firmware.

    You need the correct sourcecode from Linksys that has NEVER been compiled, otherwise ../router/iptables 1.3.5 will not compile correctly.

    If the original Linksys firmware does compile, then Linux is correctly installed.
    (Zlib and gcc is needed, ncurses optional, toolchain installed in /opt/.., and a PATH is set).
    It is handy to have ncurses for setting compile options.

    And now the important step: first delete in ../router/ busybox, udhcp, iptables, dnsmasq.
    and the following is obsolete: ../router upnp and netconf.

    The question that the Tarifa firmware askes at initial compile are all set correctly on default (just hit enter or select the first (upper) option), the SNMP option should be set to YES. In the 034 build the SNMP option will default to NO, and will be a real compile time option.

    The conntrack RTSP helper that is compiled in at default, on a original 4.30.12 firmware does crash under local video streams. (This has never been tested and should be removed), I will also remove the conntrack SIP helper, just to be sure.
    (Do: Linux/linux make config and deselect RTSP helper.)(Or if ncurses installed go to router/config make menuconfig)

    The 4.30.12 firmware has 3 bugs in the webinterface,
    1. wireless basic: if ses is disabled, a radio channel can not be selected on some models.
    2. Administration, after saving a faulty return message is given.
    3. A javascript error, this is solved in the Tarifa034beta3 build

  3. ringer004

    ringer004 LI Guru Member

    Build Tarifa from source

    Thanks for the reply.

    I managed to get a build to complete. I used original Linksys 4.71.1 and Tarifa b032. Your documentation stated that the starting source code was 4.71.1. I stated this here since you mentioned 4.30.12 in your reply, which should have nothing to do with B032 according to your documentation.

    Again, thanks for your help.
  4. jchuit

    jchuit Network Guru Member

    Upto 033, Tarifa is based on 4.71.1 source.
    The problem is that some wrt54gl v1.1 router do have a startup bug, it is related to the used flash.
    It looks like the router is functioning normal. The module ctmisc isn't loaded as it should. You can check this by listing the dmesg messages.

    Tarifa 034 uses the 4.30.12 source.
    I am going to continue to build on the 4.30.12 source.
    You can download a preview here:

    The user interface is still original, the rest is complete.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice