How to disable DNSMasq?

Discussion in 'Tomato Firmware' started by Beftus, Jun 26, 2008.

  1. Beftus

    Beftus Network Guru Member

    How do I completely disable DNSMasq in Tomato? There isn't a handy checkbox for that just like in DD-WRT.
    Before you ask, I can't access a specific site. If I bypass my WRT54GL and plugin directly into my modem I can access the site.
  2. fyellin

    fyellin LI Guru Member

    I don't know the answer to your question, but you can certainly configure DNSmasq to do no caching, and to pass all requests through.

    Can you let us know what site you're having trouble reaching, and what settings you have on your DNS page?
  3. Beftus

    Beftus Network Guru Member

    I can't access (Opera error message: You tried to access the address, which is currently unavailable.), everything else works OK. In trying to eliminate the cause I've done the following with no success:

    - installed the latest dd-wrt v24 (tried with dnsmasq enabled & disabled)
    - reinstalled tomato 1.19
    - enabled & disabled the Windows hosts file
    - tried with Opera 9 and IE 7
    - rebuild the XP tcp/ip stack
    - clear Windows DNS Cache (ipconfig /flushdns)
    - OpenDNS & ISP's DNS (tried entering static DNS and leaving it up to DCHP)
    - enabled/disabled Windows firewall
    - can't ping, 100% loss
    - tracert to times-out after 11 hops, why?

      1     1 ms   <1 ms   <1 ms
      2    12 ms     9 ms     9 ms []
      3    13 ms     9 ms     8 ms
      4    26 ms     9 ms     8 ms
      5    10 ms     8 ms     8 ms []
      6    11 ms    12 ms     8 ms []
      7    20 ms    11 ms     9 ms [195.69.144
      8    17 ms    18 ms    18 ms []
      9    14 ms    14 ms    18 ms [
     10    16 ms    17 ms    17 ms [
     11    34 ms    18 ms    17 ms []
     12     *        *        *     Time-out bij opdracht.

    Running XP-SP3 on a Pentium 3GHz, 2 Gigs RAM, 200, 250 and 400 GB HDD's
    WRT54GL v1.1 and a 3Com 3C905B-TX.

    If I plugin directly into my Motorola modem (after a modem reboot) I can access though it's not really an option. To me this indicates the problem isn't in my PC but in the router. DNSmasq perhaps?
  4. fyellin

    fyellin LI Guru Member

    I'm getting 100% lossage pinging that site from both home (behind a tomato router) and from work (a well-known company with excellent internet connectivity).

    I'm not sure what this means.
  5. fyellin

    fyellin LI Guru Member

    Bleah. Ignore my previous post. It looks like has turned off "ping", so that tells us nothing.

    I try the command:
    curl -I
    from both home and work, and both reach the web site and find out that that the page has moved to

    The router itself doesn't have "curl", but
    wget -O -
    seems to return the website just fine.

    So don't read anything into the fact that the site isn't responding to a ping. I don't really understand what could be causing the other problems. The very fact that traceroute is attempting a path to the website before giving up means that dns is doing its job correctly.
  6. HennieM

    HennieM Network Guru Member

    In your startup script
    sleep 6
    cat /etc/hosts.dnsmasq >> /etc/hosts
    kill `pidof dnsmasq`
    The "cat ..." is just to retain my own hostname in the hosts file.
    I just accessed that site (which redirected me to via a Tomato router running as a pure AP, with no dnsmasq. However, as I use an alternate DNS/DHCP server, whether dnsmasq is running or not makes zero difference in my setup.

    Another thing to try: The /flushdns of XP does not always work. This is probably due to the dns client- or more correctly the dns cache-, being broken. If you have a local DNS server (such as dnsmasq on a router), there's no reason to keep XP's broken dns client running. Try turning it off in Services.
  7. fyellin

    fyellin LI Guru Member

    It's good to know that dnsmasq can be shut off.

    But if the user can type
    and gets the message:
    PING ( 56 data bytes
    then dnsmasq is doing its job of resolving the host name to its IP address. The problem is probably elsewhere.
  8. Beftus

    Beftus Network Guru Member

    I still can't access from behind my Tomato (or DD-WRT) powered WRT54GL. I disabled dnsmasq and XP's DNS service and still no go. I'm stumped for ideas... Thanks for the input though, appreciate it
  9. PeterT

    PeterT Network Guru Member

  10. Beftus

    Beftus Network Guru Member

    Thanks PeterT, I can get access thru a cgi-proxy! Although it's not really an option:

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice