How to Fix a bricked WTR54GS ?

Discussion in 'Other Linksys Equipment' started by bzzbr, Aug 3, 2007.

  1. bzzbr

    bzzbr LI Guru Member

    Hi all,

    First, notice this problem is on a "WTR54GS travel router" and not a WRT54GS router.

    The router seems to be dead. When the power is on, the "secure easy setup" and the ethernet leds just stay on.
    It cannot respond at ( default address ) . Already reset the unit several times.
    Any one knows how to re-flash the firmware in this unit ?

  2. ifican

    ifican Network Guru Member

    I personally have not seen anything come across this board about that router except a mention in passing.
  3. stangri

    stangri LI Guru Member

    Have you tried manually setting the ip-address on your computer to say and trying to open in the browser?

    I don't think Linksys has released any firmware for this box, but it should be covered under 3-year warranty, so unless you've opened it up before -- just contact Linksys for replacement.
  4. bzzbr

    bzzbr LI Guru Member


    Yes, I've already tried to access the web interface using a manual configured ip, with no response.
    I'd never opened the hardware box and you are correct about the warranty. The problem : I'm living in Bazil and bought the hardware last year in US. To send it to Linksys US I need a return adress in US.

    Tks !
  5. stangri

    stangri LI Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice