How to for ASUS WL-500G Premium V2

Discussion in 'Tomato Firmware' started by beder, Sep 17, 2008.

  1. beder

    beder Addicted to LI Member

    i try to flash a ASUS WL-500G Premium V2 with the actual tomato firmware (1_21), but it does not work.

    I reboot the root, push the reset button while booting, wait till the power led is flashing, start the asus firmware restauration tool and load the firmware. But after rebooting the device after the flashing it does not react, i even cant ping it.

    Did I do something wrong?
    Has eanybody flashed this router?
    Is there a special firmware file for this router?
    If yes, is there also a firmware file for the speed mod?

    Thanks a lot in advance for your help!
  2. Mastec

    Mastec Network Guru Member

    I had to use tftp to load Tomato onto my WL-500gP V2
  3. eRd12

    eRd12 LI Guru Member

    You can use .bat file from tomato package and a file named tomato-ND.trx
  4. beder

    beder Addicted to LI Member

    I just flashe the file tomato-ND.trx from the acutal tomato package.
    It seems that I does not work properly, everytime I open the web interface I get asked for a username and a passwort for the site dd-wrt!

    I uploaded succesfully dd-wrt a few minutes ago, just to try it out.
    Flashing ddwrt worked very well.

    Unfortunately it still does not work with tomato...
  5. beder

    beder Addicted to LI Member

    Can you tell me which file you took and how you flashed the router exactly?
  6. eRd12

    eRd12 LI Guru Member

    You can use these files:

    Make these things:
    1.Set IP to, mask to and gateway to on your ethernet card - plug cable to the computer card and lan port in router.
    2.Press reset button and hold, plug the router to electricity, when the PWR light will turn off release reset button, PWR light should blink slowly.
    3.Now open bat file and press any button, router should get the newest tomato, wait about 2-3 minutes and replug the router.
    4.You can reset the router after flashing by pressing reset button (on connected router to power) for couple of seconds - pwr light should turn off.
  7. bripab007

    bripab007 Network Guru Member

    Did you do a reset of the router before and after the attempted firmware flash?
  8. beder

    beder Addicted to LI Member

    What do you mean with reset? I disconnected the power cable for a minute to reboot it. Is there another way?
  9. eRd12

    eRd12 LI Guru Member

    It is restart. Reset is by pressing reset router or by reset option in gui.
    This could be reason why you saw dd-wrt site after flashing tomato :biggrin:
  10. LLigetfa

    LLigetfa LI Guru Member

    Clear the browser cache.
  11. beder

    beder Addicted to LI Member

    Oh man, you where so right. I flashed it again and reseted the router, now it works great with the originial tomato firmware.

    Has anybody a idea how i can run the speed mot of Victek?
    Thanks again!
  12. beder

    beder Addicted to LI Member

  13. gsan

    gsan LI Guru Member

    does the Tomato V1.21 Victek mod support ASUS WL500G Premium V2 ??
  14. RockT

    RockT Addicted to LI Member

    yes it does
  15. Victek

    Victek Network Guru Member

    Pls use tomato RAF 1.22.8500ND version.
  16. Mastec

    Mastec Network Guru Member

    Flashed 3 days ago onto my WL500gPv2. Works great.... Nice work.
  17. gsan

    gsan LI Guru Member

    can you tell step by step how to flash wl500gP to tomato with tftp?? thanks!
  18. a9988cd

    a9988cd LI Guru Member

  19. Mastec

    Mastec Network Guru Member

    If you are on a Vista machine you need to activate the TFTP client because it's off by default.

    • Go to Start
    • Click on "Control Panel"
    • Click on "Programs & Features"
    • Click on "Turn Windows features on or off"
    • Scroll down until you find "TFTP Client"
    • Check the box and click "OK"

    Download the the file which I attached. Unzip it to the same folder where you have your tomato-ND.trx file. Execute the asus_install.bat and follow the instructions on the screen.

    In short you need to setup your PC's TCP/IPv4 with the following.....

    • IP Address:
    • Subnet Mask:
    • Default Gateway:

    Once that's done unplug your router's power cord. Execute the bat file. The file will now be waiting for a reply from you router. While holding the BLACK reset button plug the power cord back into the router. Hold the rest button for an additional 4 - 5 seconds. The power light will start blinking and the router will start accepting the tomato file.

    Hope that helps

    Attached Files:

  20. Toastman

    Toastman Super Moderator Staff Member Member

    Just want to add to this ASUS thread, new tomato releases by Teddy Bear and Victek address USB support for these routers!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice