How to get into my modem through the router

Discussion in 'Cisco/Linksys Wireless Routers' started by amree, Nov 30, 2005.

  1. amree

    amree Network Guru Member

    Modem : Aztech 600E
    Router : WRT54GS

    Connection Layout :

    Telephone -> Modem -> Router (PPPoE) -> Computers

    How can I access my modem's admin page ? obviously won't work coz it will open the router's admin page.. so, can anyone tell me how to do it ? I need to access to check the modem status and some other stuffs (margin and etc).

    Thanks in advance..
  2. MattLL

    MattLL Network Guru Member

    Chang the addresse of the router to something like and that will let you acceses your modem.

    I have 2 Routers back t back and I had to chang the one addresse to acceses it
  3. OldeBill

    OldeBill Network Guru Member

    So, are we trying to do something like this ...

    Before (doesn't work)

    Recommended (will work)
  4. amree

    amree Network Guru Member

    I'm sorry guys.. that method doesn't work, simply changing my router address won't settle it.. By changing the IP address I can't even ping but I can ping which means the modem somehow got blocked by the router, so, maybe there's something in the setting that should be changed. I really appreciate the reply.. thanks... so, you guys have anymore suggestion ?
  5. Xenomorph

    Xenomorph Network Guru Member

    i have a SpeedStream 5100 as (the only address it will use) and my WRT54G 3.0 as

    I can access both the modem and router fine.

    When you're on the same network as the router, it will act as a gateway to allow you to access the other network, the one with the modem.

    Try resetting the modem and router back to defaults, and then change the router to the different network and try again.
  6. sded

    sded Network Guru Member

    Change your subnet mask (on your NIC) to
  7. OldeBill

    OldeBill Network Guru Member

    sded, I'm feeling a bit confused about this. With the subnet mask on the PC NIC set to, the PC will expect that 192.168.1.XXX and 192.168.2.XXX, and even 192.168.0.XXX are all part of the same network. Nonetheless this the router LAN segment, to which the PC is attached, is part of a different IP network than the modem on that's part of the router WAN segment.

    For that matter, the router should still see that the WAN and LAN are different networks and route to get between them.

    What IP address is assigned to the PC when it's directly attached to the modem?
  8. amree

    amree Network Guru Member

    What do you mean by different network ? Care to elobrate ?

    I've tried changing my subnet mask on my NIC to and when I type, I still went to my router page.

    If it's connected directly to the modem, I'll get 192.168.1.x.

    Maybe the answer lies in VLAN ?
  9. OldeBill

    OldeBill Network Guru Member

    I can't shake the impression that the issue could be resolved by setting the modem on a different IP network from the PC. So, first off, to answer the question, please see .

    After that I do think that the thing to do is to open the router's management pages with your Internet Browser. Go to the 'Basic' page, click on the 'Basic Setup' tab and set the router's LAN IP address to with a subnet mask of and SAVE the changes.

    Next, click on Start and Run, enter cmd into the window and click OK. At the DOS prompt type ipconfig /all and press Enter. Your IP address should now be 192.168.2.XXX, if not type ipconfig /release and press Enter, and then type ipconfig /renew and press Enter. Once more type ipconfig /all and press Enter and confirm your IP address.

    If it's good, type exit and press enter. Try to ping the modem at

    Good Luck.
  10. 4Access

    4Access Network Guru Member

    Something seems a little fishy here... If what you said is true then that would mean that your WRT is also getting a 192.168.1.x IP address on the WAN interface which would cause all kinds of problems since it would result in a configuration like OldeBill pointed out:
    Having the WAN & LAN interfaces of the router on the same subnet would cause all kinds of problems... are you able to access the internet with your current configuration? If not then following OldeBill's advice above should solve the problem. If you were able to access the net originally from behind the WRT then either we're missing some info or you've got something else weird going on...

    What is the "Internet Connection Type" option on your WRT set to? "Automatic Configuration - DHCP" or "Static IP"? If you'd be willing to post at least the first portion of your WRT's WAN IP address from the Status page that would be helpful aswell.
  11. virgil

    virgil Network Guru Member

    When you set your WRT54GS to gateway mode (i.e. a broadband router that logs on via PPPoE thru a DSL modem) it does not talk to the modem anymore via 192.168.1.x

    Look at Setup -> Advanced Routing -> Show Routing Table and you will see something like this (based on 2nd example of OldeBill):

    You would need to transfer the PPPoE login function to the modem, and change the WRT54GS Internet Connection Type from PPPoE to either Automatic Config (DHCP) or Static IP. Then OldeBill's recommendation will apply.
  12. amree

    amree Network Guru Member

    For future reference.. i'll you about my configurations.

    Connect directly to the modem (Aztech 600E)

    Internet <- Modem <- PC

    - If I'm not using a router (Linksys) and connect directly to my modem (which could be set to bridge or router mode, usually I set it to router mode if I'm connecting directly to it), I'll get 192.168.1.x. In the configuration, I turned off the DHCP, so I set Local Area Connection IP as follows :

    IP Address :
    Subnet Mask :
    Gateway :

    Prefered DNS server :
    Alternate DNS Server :

    Connect to the router

    Internet <- Modem <- Router <- PC

    - Right now, I am using the default setting of my modem which is Bridge Mode. My Internet Setup in Linksys is set to PPPoE. I also disabled my DHCP Server so that I can get a static IP for my PC. My Local Area Connection settings are still the same as above.

    Info in the Status page of Linksys :

    Configuration Type
    Login Type : PPPoE
    Login Status : Connected
    IP Address : 219.95.99.x
    Subnet Mask :
    Default Gateway :
    DNS 1 :
    DNS 2 :

    (My ISP asks the customer to put this so that I can browse the Internet)

    Info in Basic Setup page :

    Router IP
    Local IP Address :
    Subnet Mask :
    Gateway :
    Local DNS :


    These are the steps that I've tried :

    Change my router IP to

    I change my Local Area Connection IP to :

    IP Address :
    Subnet Mask :
    Gateway :

    DNS : same as above

    Result : I can enter router page at, but when I ping, I got "request time out"

    Change my modem IP to (My router right now is

    My Local Area Connection settings :

    IP Address :
    Subnet Mask :
    Gateway :

    DNS : same as above

    Result : I still can access my router at but cannot access


    BTW, I connect my router to the modem using the WAN port.

    I never knew that the router is also getting 192.168.1.x. But, right now and before this, I never had any problem connecting to the Internet. *Sigh* Am I doing something wrong here ?


    Screenshots of my current settings, I had to connect directly to the modem to get the modem's admin page screenshot :




  13. amree

    amree Network Guru Member

    Yeap.. you got that one right.. the routing table entry list shows just like you mentioned.

    Is this mean my modem is going to be in router mode, not in bridge mode anymore ? So, that means, I can't use my Linksys router to do port forwarding and so on ?
  14. virgil

    virgil Network Guru Member

    If you set your DSL "modem" to bridge mode, there aren't really many things it would be doing other than to act like a DSL transciever so there isn't much configuration to do in it.

    Once you set the DSL "modem" to router mode (depending on the feature set) it would handle the NAT and port forwarding, and your WRT54GS now acts as a secondary router that also does NAT, port forwarding, firewall et al. between the network segment created by your DSL "modem" and the WAN port of the WRT54G.

  15. amree

    amree Network Guru Member

    Correct me if I'm wrong, your suggestion is.. set my modem to do the PPPoE, so now, my modem is in router mode and then connect my router to it and set the router to DHCP/Static IP then, change the IP address just like OldeBill's recommendation ?

    So, right now, to do the port forwarding, I need to do on both of the modem and the router ? Is this mean I will lost some of the Linksys functions such as the DDNS ? Thanks for the replies, I really appreciate it.
  16. 4Access

    4Access Network Guru Member

    Now that more of the info is in things are making sense. You didn't originally mention that you were chainging the mode your modem was operating in depending on whether you connected your PC or Router to it....

    Correct me if I'm wrong but even when the modem is in Bridge mode you can connect your PC to the modem and load the modem's admin page at right? If not then you'll have to tell us how you change the modem from Bridge to Router mode since my suggestion below won't work:

    1. Start by changing the Modem's "Management IP" from to with a netmask of (Based on the first screenshot you posted this should be possible.)

    2. Put the modem in bridge mode.

    3. Follow the steps outlined in this post. Note that this will require a custom firmware like DD-WRT or possibly HyperWRT. :thumb:
  17. amree

    amree Network Guru Member

    Haha.. it works :grin: Thanks a lot dude.. care to explain what the commands did ?
  18. 4Access

    4Access Network Guru Member

    Glad to hear it!

    The first command:

    ifconfig vlan1:0 netmask
    Assigns the router a second IP address on the WAN interface, namely

    The second command:

    iptables -t nat -I POSTROUTING -o vlan1 -d -j SNAT --to-source
    Configures the firewall so you can access the modem using the IP address you setup above. :thumb:
  19. amree

    amree Network Guru Member

    :grin: Thanks again.. can't stop smiling right now
  20. OldeBill

    OldeBill Network Guru Member


    "Your's is the superior intellect", I'm humbled and awestruck.

  21. 4Access

    4Access Network Guru Member

    Thanks for the kind words but I don't deserve all the credit! You and the others in this thread helped narrow down the problem. Besides, the real praise should go to individuals like BrainSlayer and all the other Firmware devs that make this kind of thing possible. :clap:

    Cheers :thumb:
  22. virgil

    virgil Network Guru Member

    I tried the firewall script 4Access provided:

    ifconfig vlan1:0 netmask
    iptables -t nat -I POSTROUTING -o vlan1 -d -j SNAT --to-source
    but couldn't connect to the modem (in bridge mode)

    so I tried entering them individually under Run Command but at the second line, i got
    any ideas on what is wrong? :cry:

    Tried this on tofu10 and tofu11...
  23. 4Access

    4Access Network Guru Member

    Answered here. Please don't cross post.
  24. virgil

    virgil Network Guru Member

    Sorry about that - but didn't feel comfortable posting it only in DD-WRT seeing as I was using HyperWRT.

    As per tofu

  25. 4Access

    4Access Network Guru Member

    That's OK, I didn't think about the fact that the other thread was in DD-WRT forum...

    BUT my whole point about not cross-posting was to prevent having two threads discussing the same problem since you have to search for both to get all the info on the issue... Unfortunately your responce here with new info creates exactly that problem!!! :knock:

    Regarding Tofu's response:
    I think he must be confused or mistaken.

    I looked into it a little more and feel stronger that "ERROR" is not a valid iptables target. DD-WRT doesn't include an "ERROR" target and I can't find any info on an error target. For example try searching google for:

    iptables "-j ERROR"

    You'll notice there are no relevant results.

    Additionally the fact that SNAT shows up in /proc/net/ip_tables_targets means it is included. Most importantly sded reported in the other thread that he got it working on tofu11...

    I had a thought though... what version is your WRT? If it's a v1.x then the script might need to be modified. What is the output of just 'ifconfig' by itself?
  26. virgil

    virgil Network Guru Member

    I have a WRT54G v2.2 and a WRT54G v3.1 and am using tofu 10. I also wondered about sded's results.

    Output of 'ifconfig' is:
    I have tried flashing between tofu9_ipt127, 10 and 11 with no change in results.
  27. tofu

    tofu Network Guru Member

    That "ERROR" is really not an error message. If you google it (try netfilter/iptables and "error target"), you can find the details about it being used as an internal marker. There's a patch to hide this behavior in pom. I think DD-WRT uses a newer kernel, so it's probably already in that kernel or it maybe it was patched.

    netfilter may have SNAT, but iptables doesn't have the SNAT extension, so it (the iptables part of this anyway) is not going to work... sorry.
  28. sded

    sded Network Guru Member

    Tofu, much of the confusion comes from the fact that it works perfectly for me in Tofu11, and
    Response to # cat /proc/net/ip_tables_targets is
    I have a Gv4 and got to Tofu11 by an upgrade from dd-wrt mini generic v23 after clearing the nvram there. Could this have been added in the 4.30.1 GL kernel? I am currently running Tofu11 and accessing the DSL modem on through the WAN port, after pasting the 2 commands from 4access to the firewall script and rebooting. I use ADSL Monitor to watch line conditions and it works fine with Tofu11.
  29. tofu

    tofu Network Guru Member

    Try it without the iptables command (leave the ifconfig in) and see if it also works... :)
  30. sded

    sded Network Guru Member

    Ah, yes indeed

    Erased NVRAM and rebooted, put just the ifconfig command in the firewall script and rebooted, and it worked again. But doesn't the cat command results show SNAT as an ip_tables target? Oh well, works great and makes Tofu11 more compatible with the rest of my system. Thanks again; Ed.
  31. tofu

    tofu Network Guru Member

    There are two parts in "iptables." One is in the kernel (Linux itself) and the other is the command iptables (the thing we run as users). The things listed in /proc/net/ip_tables_targets is in the kernel. So in this case SNAT is in the kernel, but the SNAT in the iptables command counterpart is missing.
  32. 4Access

    4Access Network Guru Member

    Looks like I was wrong with my previous comments, sorry about that.
  33. 4Access

    4Access Network Guru Member

    Noticed you're using PPPoE so maybe that's the problem. I have no idea if this will even work (and can't easily test it) but try the following command:

    ifconfig ppp0:0 netmask
  34. Lanik

    Lanik Network Guru Member

    I was messing around and so far I got to bring up my router interface.
    ppp0:0    Link encap:Point-Point Protocol
              inet addr:  P-t-P:  Mask:
              UP POINTOPOINT RUNNING MULTICAST  MTU:1492  Metric:1
    Still can't get to my router interface. :(
  35. cgondo

    cgondo Network Guru Member

    i got the same problem.

    Using Tofu 12 been trying to access modem page but i can not make it work

    I also use PPPoE

    Is there a work around?
  36. axnabil

    axnabil Network Guru Member

    I know this post is a bit old....but I would appreciate if someone could answer my query.

    I've read both thread (this one and This by 4Access).

    My question is, what if I have wrt54G version 5 (firmware 1.00.4).
    No chance at all?

    For me, instead of a modem connected, I have a wireless bridge connected to WRT54G WAN port. So Its good that I can login to the wireless bridge to check the signal quality and strength.

    For now, my solution is....go directly to the wireless bridge and plug it to my laptop LAN port.
  37. axnabil

    axnabil Network Guru Member

    can anyone help please.
    Is it possible with v5 or not?

    Appreciate any reply on this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice