How to reset root password

Discussion in 'Cisco/Linksys Network Storage Devices' started by cpt_tr, May 31, 2010.

  1. cpt_tr

    cpt_tr Addicted to LI Member


    I have been using jac4 firmware for a quite long time. Unfortunately I have forgotten the root password.

    I have both tried to reset password with the reset button and tried it with the GUI (firmware page) but neither is working.

    Is there any way to reset the root password?

    BTW, I am using only one disk. So there is no RAID disk issue.

  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    To reset the root password, do the following:
    1. Create a directory "rc.d" under the root directory of the "DISK 1" share if you don't already have one.
    2. Download this file into the rc.d directory
    3. Unzip the file in-place. You should now have a file called rc.resetrootpassword in the rc.d directory
    4. Push the power button on the back of the NAS. It will beep and turn itself off after a few seconds.
    5. Push the power button again to power it up. You will hear a beep after a few seconds, then another beep when the unit restarts itself after a few minutes, then two beeps to let you know that it's running again.

    After this, you can log in through SSH with username root, password root. You can change your password again with the passwd command. Remember to copy your /etc/passwd file to the /harddisk/volume_*/conf directories from the SSH prompt after you change it. If you don't copy the file, the new password won't survive a reboot.

  3. cpt_tr

    cpt_tr Addicted to LI Member

    Hi Jac,

    Thank you for quick reply. Well I have searched this solution but I was not sure to apply.

    I cannot login with ssh. So just using the \\[nas200address] under the DISK1 folder I created a rc.d folder And copied the script under the folder rc.d. I push power button to turn it off. And then power up by pressing the power button. I heard the first one-time beep. after some time heard the second one-time beep. then another onetime beep. then the two-time beep. And now I can login with root :)

  4. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Thanks for the feedback. I'm glad it worked!

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice