How to solve this problem with IP/Mac BW Limiter (Victec's firm)

Discussion in 'Tomato Firmware' started by chukelo, Mar 1, 2009.

  1. chukelo

    chukelo Addicted to LI Member

    I need to configure my network with bandwidth limiter. I installed this version "Tomato_RAF_1.23.8513-ND"

    My network topology is like this:

    1- Router ADSL PPPoA (192.168.x.254)
    2- Router Linksys WRT54GL v1.1 WAN:(192.168.x.10) and LAN (192.168.y.1)
    3- Eth port 1: PC and Eth || port 2: Powerstation5 (192.168.y.10) in AP-WDS bridge mode.
    ** Radiolink 6Km**
    4- Powerstation5 (192.168.y.20) Station-WDS (bridge too) mode
    ** Cable UTP **
    5- Nanostation2 (192.168.y.30) in AP-WDS bridge
    ** 5 Radiolinks with distaces between 0.5-1Km **
    6- Nanostation2 (192.168.y.z0) WAN: Station-WDS LAN mode Router

    I tried bandwidth limiter with Linksys with 2 clientes: laptop (via wifi) and other computer (via eth) and worked fine. No obstanding, It doesn't work in that network.

    For example, I tried adding 192.168.y.10 to "IP/MAC BW Limit" but with no luck. I tried adding all the Nanostation2 (from point 6) to the list but It didn't work too.

    How could i config the network?

    Sorry for my English.
  2. humba

    humba Network Guru Member

    All your XYZStations just bridge your Subnet so you need to put the actual endpoint addresses into the limiter config - not the address of the bridges.
  3. chukelo

    chukelo Addicted to LI Member

    I did that but it didn't work.

    I put Nanostation2 (point 6) MAC with 200/200 64/64 in "IP/MAC BW Limiter" and I can download without that limit. The point is the BW limit worked fine with end clients connected via cable or wifi to the WRT54GL.

    Maybe I modified too many times the Linksys parameters, and I need to restore factory defaults and erase nvram to start again.

    Then I associated in ARP Binding my Nanostation2 (as router, #6) to resolve IP 192.168.y.50 but it always get 192.168.y.139.

    Another weird thing that happens to me is in WAN network settings. I'm getting IP with DHCP and it gets 192.168.x.65. If I change this to Static IP 192.168.x.10, It seems to work but if I log in with SSH and I type "ifconfig" I get 192.168.x.65 again.
  4. humba

    humba Network Guru Member

    I'm not sure if you're really doing what I suggested.. you said you put the Nanostation2's MAC address into the limiter. But that's not the endpoint.. the endpoint is the PC/gaming console/Wifi phone/etc. that you connect behind the Nanostation2.
  5. chukelo

    chukelo Addicted to LI Member

    Nanostation2 are in router mode and the PCs is in another network (behind the router). My purpose is to limit the speed to all "end" Nanostation2 routers.

    For example, We have 6Mbps ADSL connection and I want to limit 1Mbps for 6 routers. So if I have 3 PC behind my router, the maximum speed I could get (with all downloading at same time) is 1Mbps.

    If I put the "end" Nanostation as bridge and I have 3 PC, it would be difficult to manage the bandwidth or if my neighbourd add a new laptop/desktop computer. There would be more ARP network trafic with more PCs in the same network.
  6. chukelo

    chukelo Addicted to LI Member


    The problem was due to NVRAM values. I erased NVRAM and configured all again and It works!

    I put final routers ip in the IP/MAC BW Limiter and all PCs behind this router share 1Mb.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice