How to Switch From Toastman to Another Firmware?

Discussion in 'Tomato Firmware' started by Xplorer4x4, Sep 7, 2018.

  1. Xplorer4x4

    Xplorer4x4 LI Guru Member

    I have an ASUS RT-56U. I was thinking of switching from TomatoUSB Toastman Builds to either giving DD-WRT a try again(have not tested it in years), or more likley Asuswrt-Merlin or FreshTomato. Should I flash back to stock firmware before I flash one of the other firmware listed? I am using Manjaro linux on my PC. What method should I use? Will the ASUS Discovery tool work under wine?
     
  2. Monk E. Boy

    Monk E. Boy Network Guru Member

    Just use the MiniCFE website (hold reset at power on until power light starts slowly turning off and on) to flash your firmware. No discovery tool needed, just plug your system into port 1 and assign an address within 192.168.1.0/24 (192.168.1.2, 192.168.1.30, 192.168.1.250, etc.) then browse to http://192.168.1.1 and use it to upload the new firmware. After it restarts (automatically) if you can't get into the new firmware turn it off, hold down WPS, then turn it back on, hold until the power light starts flashing quickly, keep holding it for a second or two, then release and wait for it to finish booting.

    Note that after uploading to the MiniCFE you want to let the router sit until its regularly responding to pings and generally this means the website should be online. Some models (I'm looking at you N66) take a very long time after uploading, this is because the flash chip is very large and very slow (when flashing a new firmware the entire flash space is written to). It's common for MiniCFE flash to take 45 minutes when going between firmwares on an N66. I'm not aware of any other router that's this slow, though they all need at least a couple minutes if not 5 or 10 minutes to finish. The ASUS Discovery Tool has a long pause after it uploads the image, this is equivalent to the pause you have to patiently wait out on your own, so its not any faster or slower this way.
     
    Xplorer4x4 likes this.
  3. Xplorer4x4

    Xplorer4x4 LI Guru Member

    Thank you. Nice and easy instructions! I use a static ip so i skipped that part. I did go to the MiniCFE website, flash Asuswrt-Merlin.trx file and let it upload. It prompts me to conitnueon screen, I do, only to be brought back to my Toastman instilation. I know I uploaded the proper firmware. I don't have the stock firmware in that directorey.

    EDIT: From Toastman, I factory reset, I flashed Merlin. Again it claims flash sucesful. I erased NVRAM this time. After reboot I am back at toastman build. Any ideas?!
     
    Last edited: Sep 8, 2018
  4. Monk E. Boy

    Monk E. Boy Network Guru Member

    I would try going back to the OEM firmware to insure you have hardware support in the image you're using.

    Frankly the N56 is a Ralink (A1 / v1) or Medatek (B1 / v2) SoC, while Tomato only supports Broadcom SoCs. Are you sure you have an N56?

    Only other thing I can suggest is to disable jffs support, that can prevent upgrades from going through, although if you did a WPS (factory) reset that should take care of that setting. Usually flashing from the CFE bypasses that limitation altogether.
     
  5. Xplorer4x4

    Xplorer4x4 LI Guru Member

    My router is an ASUS RT-AC56U. I have verified it in the Tomato Web UI and the stickers on the router. I have tried to flash
    Asuswrt-Merlin-RT-AC56U_384.6_0,
    freshtomato-RT-AC56U-ARM-2018.3-AIO-64K and I have tried stock
    ASUS_FW_RT_AC56U_300438250624. I tried to flash stock after previously trying Fresh Tomato. It still took me back to Fresh Tomato. Not stock.

    Edit: I tried a factory reset by holding reset for 30 seconds with power on. Release reset and have trouble getting recovery mode. With the router off, I hold reset, and press power on. After 30 seconds the status light on front of router goes dark. Usually I can access recovery web ui at this point but it acts like maybe it is stuck in a bootloop.
     
    Last edited: Sep 8, 2018
  6. Xplorer4x4

    Xplorer4x4 LI Guru Member

    Here's what worked. Long story short, from MiniCFE website/recovery, I flashed the oldest stock firmware from asus website. It rebooted to MiniCFE, I erased NVRAM. Reboot normally. Stock firmware should boot. Use auto-update to bring you up to date on stock firmware. I believe it flashes 2 builds all together!Then reboot to MiniCFE/recovery. Flash Firmware of your choosing(Merlin,DD-WRT, FreshTomato, etc) and it should reboot to recovery. Erase NVRAM. Reboot. Log in to Web UI and congifure as needed.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice