How To Test WRT54G Serial Port Modification

Discussion in 'Cisco/Linksys Wireless Routers' started by BobCochran, May 29, 2005.

  1. BobCochran

    BobCochran Network Guru Member

    I just did Rod Whitby's Dual Serial Port modification which is here:

    Now I would like to test whether my serial port really works on my WRT54G v2. How can I do that? Do I need to open a serial console with minicom first? What would be a good test procedure? I'm using Satori-4.0 firmware.

    Thanks a lot for any advice and help that can be offered.
  2. jagboy

    jagboy Network Guru Member

    i think you use hyper terminal or something
  3. BobCochran

    BobCochran Network Guru Member

    Serial Port Mod -- It Seems To Work!

    I'm happy to report that the serial port modification seems to work. I took the WRT54G board out of it's case and put it in a PanaVise clamp. Then I connected the ribbon cable from the modified AD233BK to the freshly installed IDC header on JP1 of the WRT54G. I connected a serial cable from the serial port on my PC (I'm a Linux user, and the PC serial port I used is /dev/ttyS1) to the DB9F adapter on the other end of the AD233BK. Then I opened a minicom terminal and made sure the connection parameters were set to 115200, 8-N-1. When all seemed readiy, I plugged in power to the WRT54G board using the power supply that came with the device. Presto! There was a flood of output as the board booted up. I was seeing standard Linux kernel messages as the board booted. It then paused for a second and I think it was expecting me to issue a tftp incantation of some sort.

    I still need to investigate more and practice flashing firmware from a serial console in case I brick the unit. Also, it would be very nice if I can get a shell prompt and be able to explore a little more. I have taken photos of the modification process and I'll try to post them in the next few weeks.

    One last technical note, I'm a Fedora Core 3 user and if you try to access the serial port on your PC as an ordinary user, you will be denied. To change this, edit /etc/udev/permissions.d/50-udev.permissions. This line:


    needs to change to this:


    I wanted to have udev make use of the new permissions without spending a lot of time researching how to restart udev, so I simply rebooted the PC, and that worked fine.

  4. jagboy

    jagboy Network Guru Member

    good to hear it worked
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice