HyperWRT 1.4 Problem

Discussion in 'HyperWRT Firmware' started by stumped, Sep 29, 2004.

  1. stumped

    stumped Network Guru Member

    I loaded HyperWRT 1.4 today, primarily for the ability to raise signal strength on the transmit side. After configuring it and getting the computers back online I began to notice an odd problem.

    Some web sites just will not load. Windows Update, Disney.go.com, thejackcat.com to name three.

    Here's the history on the setup.

    Was running a D-Link 624 AP. The signal strength was just way better than linksys. After obtaining a couple new computers, I required WPA. The D-Link started the notorious 3 min rebot, so I obtained a LinkSys WRT54G. Everything worked well, except for one computer. It was unable to see the AP, but I could see the card from near the AP.

    The HyperWRT 1.4 boosted to 48 on the transmit signal got everything running just fine.

    Everything connects fine. I can VPN into various places I work at. I can send and receive email, from multiple accounts, from multiple computers, simultaneously. I just can't connect to some web sites.

    Connecting computers directly to the DSL modem causes them to work fine. All sites load. Behind the router, they won't load.

    Anyone have any ideas at all?
  2. Bathel

    Bathel Network Guru Member

    try setting the MTU to manual and 1492.

    Also set the MTU on your local PC using DRTCP to 1492.

    This cleared up all issues I had with the newer firmwares and some websites not loading.
  3. rizsher

    rizsher Network Guru Member

  4. stumped

    stumped Network Guru Member

    I already had the settings at 1492 based on previous posts I had found elsewhere. I had not set it from end to end though. Setting it from computer through the modem didn't change the problem.

    It's odd that using the linksys firmware clears the problem, yet with the same settings this firmware causes timeouts in the http protocol. Whether wired or wireless the problem persists. Locally (wired and wireless) I cannot produce the problem. Remote sites (wan port) are the only ones.

    I went so far as to use wget to rip down entire sites to a couple layers to tests them locally.

    I was unableto get any other protocol to produce this effect. And there are no problems out bound.

    I obtained a copy of Sveasoft to try that, and I can't reproduce the problem with that firmware either.

    I tried playing with different default settings, but honestly, being unable to save all the different versions off, I'm not sure I found all the differences.

    I have no clue what's causing timeouts in the http protocol. I'm open for any further suggestions.
  5. Judex

    Judex Network Guru Member

    Could it be be that you have enabled tcp_ecn? Some sites (routers, firewalls, loadbalancers) on the web can't handle such IP packets. Try to turn it off, if enabled - under Linux you do that by typing
    "echo 0 > /proc/sys/net/ipv4/tcp_ecn" or just check with
    "cat /proc/sys/net/ipv4/tcp_ecn"" - 0 means disabled.

    My HypertWRT 1.4 has it turned off by default.

    Regards, Judex
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice