HyperWRT 2.0b3 Bug List

Discussion in 'HyperWRT Firmware' started by Avenger20, Nov 18, 2004.

Thread Status:
Not open for further replies.
  1. Avenger20

    Avenger20 Network Guru Member

    If you find any bugs in HyperWRT, post them here
  2. Acid-drop

    Acid-drop Network Guru Member

    On page "access restrictions"

    Middle of the page, blocked services
    I got problem with interface, visually i mean.
    No big deal :)
  3. Avenger20

    Avenger20 Network Guru Member

    Could you post a link to a screen shot? And which browser are you using?

    PS : Policy 14 didn't work for me. Would block all internet traffic. Just not using it will work. No problems with other policies. Don't understand why this one is so stubborn :wink:
  4. Toxic

    Toxic Administrator Staff Member

    Could you possibly make Telnet Daemon just a two button selection.

    Enable and Disbaled button and not a new popup window?

    keep up the good work...
  5. Acid-drop

    Acid-drop Network Guru Member


    Using latest IE (xp with sp2 installed)
  6. Avenger20

    Avenger20 Network Guru Member

    Thanks, will fix that one in next release.
    Only used FireFox here for testing.
  7. Toxic

    Toxic Administrator Staff Member

    thats the problem with MSIE :) it does that on some alchemy pages as well.

    firefox just ignores those and shows it the way it should.
  8. reverie

    reverie Network Guru Member

    FYI - On Windows 2000 with MSIE 6 SP1 the problem does not occure.

    keep up the good work
  9. kpenner

    kpenner Guest

    Passwords except ADMIN

    If I change the password to anything other than ADMIN it will not recognize the new password, except in the case when you go to change the password back to ADMIN in the routers firmware, then it recognizes the new password, just long enough to set the router back to the defaults ADMIN.

    In other words, changing the password causes access to the router to fail.
  10. Green

    Green Network Guru Member

    I suppose the problem with Max Idle Time is still there (unable to set the value to 0). Will check it later from home, but I'm sure it was not fixed ;-)
  11. phild_mande

    phild_mande Network Guru Member

    DHCP Clients table empty


    Sorry .... I enter my message as a new topic ... ...
    message : DHCP clients table empty ... not listed in status/network/dhcp clients
    and some questions
    I hope that somebody is able to move it in this topic
  12. Green

    Green Network Guru Member

    just upgraded, without resetting to factory
    1. same damaged screen around blocked services (XP SP2)
    2. some hidden pages are empty - /SysInfo1.htm and /Cysaja.asp
    3. it seems that Blocked Services are not working at all - checked with ssh & ping
    4. cannot set Max Idle Time to 0 for PPPoE
  13. Avenger20

    Avenger20 Network Guru Member

    2. Everything from other hidden pages is now in /SysInfo.htm

    3. Are you sure you entered an ip address (or range) and enabled the rule?
  14. Green

    Green Network Guru Member

    You mean range of ports? Yes!
    'ping' service was already there and I've added 'ssh' service for test - tcp, from 22 to 22.

  15. chris-at

    chris-at Network Guru Member

    You also have to enter an ip-address range or just a single ip for which this rule should be applied. If you didn't do this, nothing would be blocked :wink:
    It's a separate button within the page where you enter the port-ranges.
  16. hotfix

    hotfix Network Guru Member

    Also seen this with W2K+SP4 and IE6+SP1.
  17. hotfix

    hotfix Network Guru Member

    Because I use a SpeedTouch 510 in SIP-spoof mode I normally typed some "nvram set" lines in the Command Shell.
    This is giving me the message "nvram: not found" with 2.0b3

    Lucky me it's going fine with the Telnet Deamon.

    One more thing: The lines nvram set 'static_route=...' and nvram set 'static_route_name=...' are not show when I type nvram show to check myself. No big deal but only wanna let you know. :)

    Thanks for the great work. :D

    (I love the Telnet Deamon to take a peek inside the WRT.) 8)
  18. Green

    Green Network Guru Member

    You're right! It was my mistake. On my old BEFSRU31 this procedure was less advanced :roll:
  19. reverie

    reverie Network Guru Member

    Since I am using the same setup (W2K+SP4 and IE6+SP1), and I don't see it, I tried to figure out what might cause this to happen. It seems that the problem will occure if you change MSIE Encoding to anything other then Western European, or Unicode. My guess is that Windows probably just uses wider fonts for other encodings, or perhaps different spacing. To set the encoding right click, and choose encoding.
  20. Acid-drop

    Acid-drop Network Guru Member

    Well, i'm in western european (iso) ...
    But the problem might come from there, it's a good thought.

    Anyway, problem is easy to fix, just make 4 lines instead of 2 and it's over.
  21. hotfix

    hotfix Network Guru Member

    @ reverie:

    Where do I have to right click :?:
    Let me know so I can check my settings.
  22. reverie

    reverie Network Guru Member

    anywhere on the web page that is not a hyperlink or an image, in other words, any open space in the web page. you can also find it in the view menu. for myself, when I change encoding the problem apears, and when I go back to Unicode it disapears.
  23. hotfix

    hotfix Network Guru Member


    It's also here Western European (ISO)
    Your right, when I switch to Unicode (UTF-8 ) it's OK. :)
  24. 3dogs

    3dogs Network Guru Member

    If I change any setting on the "Advanced Wireless" config page, I can't contact the unit until I power cycle twice. I can change all other settings with no problem.
  25. dellsweig

    dellsweig Network Guru Member

    router re-boot

    I just noticed my WRT54G - HyperWRT 2.0b3 rebooted.. Checked up time and it did re-boot. I have a Wallwatcher log showing the syslog messages from the time of re-boot. Looks like the WRT54G ran out of memory..

    If I can figure out how to add an image to this post, I will take a screenshot of the log

    Anyone else notice the box doing unsoliceted reboots??

    It had been up for several days....
  26. dellsweig

    dellsweig Network Guru Member

    NO MORE reboots - and logging is fixed


    The reboot issue I was having was due to the logger script which did a killall of klogd from cron and then restarted it. It appears the killall did not work correctly when run from cron and after a while - the excessive number of running klogd processes crashed the router.

    Here is a working version of the logger code for hyperwrt - no more reboots:

    Use this in the startup script

    sleep 2
    /sbin/syslogd -R
    echo "#!/bin/sh" > /tmp/loggit.sh
    echo "while true" >> /tmp/loggit.sh
    echo "/usr/bin/killall -9 klogd" >> /tmp/loggit.sh
    echo "sleep 1" >> /tmp/loggit.sh
    echo "/sbin/klogd" >> /tmp/loggit.sh
    echo "sleep 960" >> /tmp/loggit.sh
    echo "done" >> /tmp/loggit.sh
    chmod 700 /tmp/loggit.sh
    /tmp/loggit.sh &

    Firewall Script:

    /usr/sbin/iptables -R INPUT 7 -j logdrop
    /usr/sbin/iptables -R INPUT 1 -j logdrop -m state --state INVALID

    Avenger - if you want to post this in the FAQ - feel free. This seems to fix the issue where multiple klogd process were using resouces and causing the 54G to run out of memory...
  27. dmm

    dmm Network Guru Member

    Bigpond Cable Heartbeat Issue

    I upgraded to the latest version of HyperWRT on my WRT54GS the other day from a previous version. From memory 1.37 -> 2.0b3??

    With previous version (1.37) everything seemed to work just fine.
    After the upgrade, while the router and wireless component still works, I frequently loose my internet connectivity. The problem is temporarily fixed, by going the the status screen and disconnecting then reconnecting to the heart beat server (Telstra bigpond).

    The router seems to have failed again today. When i get home, I'll start up the bpalogin daemon on my linux server, and see if that restores my connectivity.

    If it does, I suppose there is a newly introduced bug in version two for the bigpond heartbeat stuff.
  28. dmm

    dmm Network Guru Member

    Re: Bigpond Cable Heartbeat Issue

    Well running bpalogin on my linux server did resolve the problem. Therefore it looks as though there is a bug.

    Oh dear. I'm rather tempted to try running the sveasoft firmware to see if that works better. I believe they use bpalogin (also I'd like to try kaistation!)
  29. Avenger20

    Avenger20 Network Guru Member

    Re: Bigpond Cable Heartbeat Issue

    This is most likely a bug in official Linksys firmware. You should contact Linksys about this problem.
  30. Gheimposse

    Gheimposse Network Guru Member

    *.ebay.de didn´t work with the 2.0b3 fw

    I bought the WRT54GS yesterday and quickly run through the different alternative firmwares until I decided to use the HyerWRT firmware.
    Now after patching the 2.0b3 fw I realised that I can´t load ebay any longer.

    I´m using Windows XP SP2 as well as Windows XP Tablet Edition SP1 (on a tc1000 compaq) and none of the IE6 as well as Firefox was able to load any ebay site. Each pc is using a symantec firewall system, spywareblaster, pestpatrol and spybot registry control.
    For testing purpose I tested with enabled as well as with disabled security features to ensure that these errors are not caused by my installed software.

    So I did some cross checks with other firmwares. Here´s the result.
    After testing all firwares I reactivated my old D-Link DI-614+ which go ebay sites immediately!!!! To ensure that the firmware tests are done based on false firewall settings all testings were made after resetting the fw to default settings!!!:

    Unable to get a dsl line:

    Unable to connect *.ebay.de sites:
    original Linksys WRT54GS v3.37.2 (US code for Speedbooster v1.1).bin

    Able to connect *ebay.de sites:

    Anyone an idea where this great "features" came from? That the HyperWRT firmware had the same problems as the original Linksys firmware was obviously clear cause HyperWRT is based on original Linksys firmware ... but can anyone fix this error???

    Oh ... and if possible ... to kick the sveasoft guys ass on the moon ... please can anyone (I´m not a programmer!) add the following functions to the hyperWRT firmware???:

    - 14 wifi channels
    - 0-251kW wifi power
    - VLAN support
    - Client/Router VPN

    THANKS ... and a good new year 2005
  31. Gheimposse

    Gheimposse Network Guru Member


    Hi ... I told you that the HyperWRT firmware didn´t connect to *.ebay.de as well as the original Linksys firmware.
    However ... and I´m a IT Specialist (but not a programmer!) ... the problem is solved.
    After flashing the HyperWRT 2.0b1 *.ebay. addresses worked! Than I flashed the 2.0b2 firmware and the *.ebay sites still loaded ... and after I flashed the 2.0b3 firmware the *.ebay.de sites also still load.
    Don´t ask me why this didn´t work when I did it the HyperWRT 2.0b3 starting with the emty factory defaults ... but this way I solved the problem.
    Maybe a UIE (user imcompetent error)??? *hope not* :lol:
  32. lucboz

    lucboz Network Guru Member

    Re: Passwords except ADMIN

    no problem here
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice