HyperWRT 2.1b1 on Linksys WRT54G 4.20.6 released

Discussion in 'HyperWRT Firmware' started by Rupan, Aug 1, 2005.

  1. Rupan

    Rupan Guest

    A while back I built a firmware image using HyperWRT 2.1b1 and Linksys' official 4.20.6 source code. It is not available:


    I believe this also contains Tiny-eDNS and scyld's ether-wake client for DDNS via everydns.net and wake-on-lan.
  2. dcrane6

    dcrane6 Network Guru Member

    I've been using this for a couple days now, having stumbled across it on your own forum. Cheers for all your hard work Rupan, the firmware is great! :D
  3. NemesisChild

    NemesisChild Network Guru Member

    Your above link isn't working!
  4. IsaanFarang

    IsaanFarang Network Guru Member

    Cannot unzip the .gz file in Win-XP using both Winzip v9.0 and Alpha-ZIP ... appears empty

  5. ifitzgerald

    ifitzgerald Network Guru Member


    WinRar can open .gz files, along with many other formats. It's a pretty good compression program.

    You can download a trial copy here
  6. GPhreak

    GPhreak Network Guru Member

    @IsaanFarang: it's always the same problem - internet explorer decompresses while downloading :thumbdown:
    Use firefox instead or just rename .gz to .bin and flash it (1st method recommended)
  7. luga

    luga Network Guru Member

    you are using this firmware in wrt54g version 4 which one came with firmware 4.20.6 the newest one??
  8. Touchy

    Touchy Network Guru Member

    Yes, thats right. I´m currently online with it! :)
  9. luga

    luga Network Guru Member

    And does it work great or it have some bugs????

    another thing what options does it has this firmware????

    where i can se some details??

    thank you!!!
  10. ravn

    ravn Network Guru Member

    So far no problems with mine... Though I have some problems with seing the dropdown boxes the rigth way(?) They are emty untill I mark them and choose a value:

    They should say "BOTH"
    (Running Mozilla)
    Other than that, it works perfect and great to see WPA2 support.
    Btw the WPA2 personal setting, has: AES and AES+TKIP? Is it so that clients with both AES and/or TKIP settings can connect?
  11. RTSAnime

    RTSAnime Network Guru Member

    i think wpa2 is AES only
  12. pharma

    pharma Network Guru Member

    That is correct ... I'm currently using WPA2 with two computers connected, one using TKIP and the other using AES.
  13. Gn0ver

    Gn0ver Network Guru Member

    WRT54G no longer useful as DNS relay?

    Hi guys,

    So far haven't found any major bugs in this fine release of HyperWRT 1.21b on codebase 4.20.6 . The only problem I had was that my linksys WRT54G no longer works as an DNS relay. For my primary PC I have a static IP set in windows (XP) and I've always enterd the linksys as my DNS. The linksys would then automatically relay the requests to the DNS of my ISP.

    Now this function no longer works. I have to set the DNS-servers of my ISP in windows, or else there is no resolving of any domain name.

    Any one else has this problem?


  14. asterger

    asterger Network Guru Member

    Hmm, I too use the DNS relay through my router and it's still working with Rupan's upgrade. I removed ISP's DNS entries and rebooted. ipconfig /all indicates:

    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . :
    DNS Servers . . . . . . . . . . .. :
    NetBIOS over Tcpip. . . . . . . : Disabled


    -- Alan
  15. Gn0ver

    Gn0ver Network Guru Member

    I did some further investigation and it turns out that the WRT54G stops relaying DNS queries in case I have a heavy bittorrent stream. When I upgraded to this firmware I had an active torrent client, up and downloading to several peers. When I stop the client and close the ports for torrent traffic, then the DNS relay comes available again.

    I did not have this issue with the previous firmware. I didn't change torrent clients or versions of it between firmware upgrades.
  16. Jennifer

    Jennifer Network Guru Member


    I downloaded " HyperWRT 2.1b1 with WRT54G 4.20.6 codebase" and just can not get it to upgrade.

    I have a WRT54G v2.2 and have tried everything I can think of, always comes up that upgrade failed. Firewall has even been turned off, as is anti_virus. Tried it also via tftp and that says, no response from server.

    Any help with this would very much appreciated.

  17. jagboy

    jagboy Network Guru Member

    let me get this striaght you flash with the HyperWRT 2.1b1 with WRT54G 4.20.6 codebase and now you can not flash with any other firmware?

    is the power light blinking?
    can you get internet through the router.
    did you try a hard reset (holding reset button for 30 seconds)
  18. kaplanfx

    kaplanfx Network Guru Member

    Its likely what you are seeing is a case of lack of upstream bandwith. Because bittorrent likes to send packets, unless you throttle its bandwidth a little bit you can easily clog your upstream bandwidth. This will in turn cause the routers memory to fill up (I think its only 8 MB) to the point where it starts rejecting packets because it has no place to buffer them to. If your DNS request was one of these packets you only get a few attempts before a time it so it will appear your DNS is not working when in reality its timing out becuase the router was rejecting the packet carying rhe request.

  19. Pommmes

    Pommmes Guest

    WRT54gs Update mit WRT54G_4_20_6_kaienabled.bin

    hallo leute habe hier ein problem :( habe mein wrt54gs mit der WRT54G_4_20_6_kaienabled.bin update. und nun kann ich nicht mein altes image aufspielen ... kann mir vielleicht einer helfe ? danke msg pommes
  20. zhesho

    zhesho Network Guru Member

    i have problem unrar the program. It say no archve found. i'm using winrar to open it.

    Could someone pls provided a new link to download this firmware.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice