HyperWRT not picking up DHCP on 54G

Discussion in 'HyperWRT Firmware' started by dbotkin, Oct 20, 2006.

  1. dbotkin

    dbotkin LI Guru Member

    I tried using HyperWRT on my WRT54G V2, S/N CDF50Dxxx.... Everything seems to work fine, other than the fact that it steadfastly refuses to acquire a DHCP lease from the WAN side (Cox). Here's what I have tried so far:

    Linksys firmware works fine (such as it is).

    EWRT works OK, picks up DHCP lease, but does NOT put the default route in the routing table. I can SSH in and add it manually, and it works until the default route is dropped at some random interval < 1 day later. No one responded in the EWRT forum, so maybe it's just me.

    Hyperwrt cannot seem to get a DHCP lease at all, regardless of what else I tried. Finally had to return to Linksys firmware.

    I'm not doing anything weird. I have the LAN side DHCP server turned off. Tried enabling it just for giggles, it made no difference. The ISP is Cox, I've been on them for 5+ years with the same DHCP-assigned IP address. I am using MAC cloning to look like the MAC of the NIC I was originally using.

    Ideas? Is there something I missed??
  2. digitalgeek

    digitalgeek Network Guru Member

    try disabling the mac clone and then reset the cable modem (don't forget to disconnect the coax cable durring the power cycle on the modem)

    upon repowering the modem your isp should grab the mac from your router.
  3. dbotkin

    dbotkin LI Guru Member

    Well, I would have... BUT...

    I loaded HyperWRT again, rebooted, and the sucker DHCP'd itself just fine. Later on I added a port forward, and it suddenly lost its WAN connection. I noticed the cable modem said there was no Ethernet connection from the '54G. Power cycled the router, it came back up and all's well. I'll watch it for a few days and see if it's stable, but so far so good. Anyway, thanks for the suggestion. If it gives me any more trouble I'll try your suggestion. I had used MAC cloning back when some ISPs were blocking MAC addresses used by NAT routers, which they've long since stopped doing.
  4. digitalgeek

    digitalgeek Network Guru Member

    Unfortunately cable ISP's don't condone the use of a router. They still beleive in the pilosophy of one signal for one appliance... gotta love my dsl they keep bugging me to use their router (what a piece of junk that thing was) Cable in our area uses mac to assign IP, but a simple reset of the modem and upon repowering the modem, ehternet is attached to router, they just lock on to that... so you can't just change a router... (who wants to change a Tomato/linksys router any way)... best of luck with your DHCP problem.
  5. dbotkin

    dbotkin LI Guru Member

    It's been wokring fine for a couple of days now, so whatever it was it seems to be fixed.

    Cox doesn't have a problem with routers it any more - in fact, they encourage it if only for the firewalling. Now if only I oculd get them to unblock port 80, or at least incoming TCP connections on port 25. sigh...
  6. digitalgeek

    digitalgeek Network Guru Member

    blocking port 80 kinda bites... at least my dsl (at least not yet) does not block anything... I don't think they throtle p2p?? not a bad connection 5M/800K... they are talking about uping to 7m (reg high) and 10 m (ultra high) except current neighbor hood infrastructure doesn't support it
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice