Hyperwrt options

Discussion in 'HyperWRT Firmware' started by SFCRAIG, Oct 7, 2004.


    SFCRAIG Network Guru Member

    I was thinking of another question I have regarding 1.4

    Differences between command shell, startup, firewall and addons?

    1) Command shell is self explanatory, enter linux commands , see filesystem etc.
    2) Startup .. Not sure when you would use. the add ons kick in on startup right, for example the batbox script, when the box gets rebooted so this would run commands without having to re enter them any time. What would startup have that this wouldn't?
    3) Firewall? -- you can enter iptables commands in command shell? I'd imagine you can put in add ons as well to have these start on boot?
    4) Add ons-- to add extra packages..

  2. Avenger20

    Avenger20 Network Guru Member

    There actually isn't any difference between startup, firewall and addons.
    I just seperated them for convenience and safety (very large scripts would brick your router).

    All scripts are executed on startup or when you save them.
    Addons is executed first, then startup and firewall.

    It's possible that the script won't execute on startup, but a 'sleep 1' as first line will fix most problems.

    SFCRAIG Network Guru Member


    Hi ,
    Thanks for reply "avenger". So it will execute all three on a save, ahh. If you need to (lets say) rekick off, the syslogd , for wallwatcher , is there any problem in having this in add ons, and having the batbox add on re-execute without rebooting the router? I thought I read where it mentioned not to redo the commands without a reboot, but I didn't have a problem when doing this.

    Also, the command part appears kind of flakey. At first I tried putting syslogd in the command part and executing but it didn't stay up. Then added to addons all went well. Wallwatcher working etc. Syslog(d) ended as others had experienced with busybox 0.60. I tried adding just this one line to command and executed it. It showed up as a process, but wallwatcher didn't work. The logging itself on the router was seeing my grc scan, but Wallwatcher didnt see anything. It seemed hung up on /sbin/check_ps process.

    When I resaved the add(ons) with syslogd, kernel logging, iptables etc, then all worked. The initial messages were syslogd started , then an
    M klogd: available key index is 0, klogd: exit vlan1 setting mac address and then typical dns queries for my dns servers and off we went. So, something different about the command, and autolog entries for starting syslogd.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice