I bricked it up !

Discussion in 'DD-WRT Firmware' started by pmaior, Dec 15, 2005.

  1. pmaior

    pmaior Network Guru Member

    Well, I finally encountered my first Brick :shock:

    I followed the directions I found here and elsewhere to recover it. Finally after hours of trial and error it took the load. Here is what I found that helped. Timing is everything!

    Here are the steps I followed.

    Before you start rename the .bin file for the linksys version you are using to code.bin and place it in the root. C:\

    Check the downloads area of this website for the one you need. Or go to linksys.com and get it. For the instructions below use the .bin version.

    I suppose you can use the .exe version in step 6 after you get the ping going, but I have not tried that. It is worth a shot as it is much easier than using tftp. I'll try that next time and reprort back if it works.

    Connect a lan cable from your pc to any lan port on the router. NOT THE WAN PORT !

    1. Set lan card to static ip. (Windows TCPIP Properties)
    Duplex of the card does not seem to matter. I left it at auto and it still worked. Others recommend setting to 10mb half duplex or full duplex.
    2. set Gateway to Subnet Mask
    3. Open a cmd window ( Start Run cmd) and type
    ping -t Press the Enter key (will continue to ping until you stop it. Don't know how this helps, acts like a clock, or keeps port alive during reset ??? anyway just do it ). Here is the part I missed the first time. KEEP THIS WINDOW OPEN while proceeding to next steps.
    4. If address returns successful go to step 6.
    5. Open the case by removing the antennas and push forward on the front of the case (WARNING THIS WILL VOID YOUR WARRANTY)
    The case will snap apart and then remove the top gray part of the unit to reveal the circuit board. Locate the chip labeled intel and short pins 15 and 16. There are small white marks that indicate increments of 5. I found that quickly running a screwdriver across the pins to be effective and causes no damage, as the pins are quite small and hard to isolate. Watch the cmd window to see if pings start returning successfully(not timeout).
    6. Open another cmd window ( Start Run cmd) and type in
    c:\ Press the Enter key.
    tftp -i PUT code.bin (DO NOT PRESS ENTER YET)

    Hold the reset button on the back of the router in for 30 seconds. Immediatly upon releasing the reset button press enter.

    Hopefully you will see the lan port led flash very quickly for about 5 seconds and the cmd window will report what was transferred successfully.

    You may need to repeaT this step several times to get the timing right, but it will work as long as the port is being pinged successfully.

    Use the f3 key so you don't have to keep retyping the tftp command.

    Now don't be impatient. Wait a few minutes to let the router reset.

    The power light will go to a steady state. Give it at least 5 minutes, Go get a coffee or a beer if you have been at this a while.
    Always try a reset before removing power. Give it time to work.
    Watch the lights. Also check the ping window that should still be going. When it starts pinging again you should be able to close all windows and access the router though the GUI by opening a browser window and typing in

    If you remove power at this point, you may damage the code to a point where nothing will work, ( As I did the second time this happened to me) I got impatient .

    Don't forget to set your lan card back to Get dynamic ip address.

    If you just purchased the router, I would reccommend returning it to the store before opening the case and voiding the warranty. But if you've had the router a while, What Do you have to lose ?
    It's useless anyway.

    My router now has all the lan leds lit steady and the Internet led lit as well. I can't get it to do anything, but I'll keep playing and then try to return it anyway if I fail. Nothing ventured nothing gained.

    If anyone knows how to recover from the state I have now Please respond.

    Good luck all. Click the link below to get a pdf with some great pix and some good info.
    Get This great pdf with nice pix

    I love this forum, great tools and info :rockon:
  2. matthiaz

    matthiaz Network Guru Member

    There's a debricking guide posted under Articels on this side already. Which is far more readable than yours... Yours btw is apparently wrong for all never models and WRT54GS models... :cheerup:

    But thanks for posting this in a firmware only discussion forum... :(
  3. dellsweig

    dellsweig Network Guru Member

    I feel your pain!!!!

    I got mine back to the point that the LED's look normal - wireless appears to be on but I cant talk to the router - no ping, nothing. Its almost like it defaulted to a differernt subnet

    BE VERY CAREFUL if you choose to use the 12/14 DD-WRT build.

    I am a faithful user but there is smoething wrong with this build - many bricked routers - bricked in a different way, not power flash but not IP either
  4. pmaior

    pmaior Network Guru Member

    Is there a contribution here ?

    First of all this procedure worked twice for me on a newer router. wrt54g v 4.20.6 so I don't know how it could be wrong. Care to elaborate ?

    Second of all If I had seen the article I would have not posted it or at least referred to it to be helpful to others.

    About this being a firmware only forum, what do you think causes the bricking of routers ? Let me give you a clue . It's loading the firmware unsuccessfully, and not necessarily incorrectly.

    Besides the bad spelling, where is your contribution ?
  5. sterix

    sterix Network Guru Member

    I agree with delssweig that there is something wrong with this build. Not sure what , but I bricked a wrt54g ver 1.1 which was working fine and now unbrickable ....
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice