I have a WRT54G v5 and want to shoot myself

Discussion in 'Cisco/Linksys Wireless Routers' started by Vendetta, Apr 1, 2006.

  1. Vendetta

    Vendetta LI Guru Member

    Okay I have a WRT54G and if anyone has a gun, I'll use it to blow this total peice off my desk.

    It works relatively well, its stable and gives me a good connection through out my home.

    Here is the issue:

    I love Command and Conquer: Generals. However with the v5 connected I cannot play online at all! I get disconnected or it won't allow me to connect to other players. How do I know it is the router? Well here is a list of things I have done:

    - Port Trigger
    - Port Forward
    - Port Trigger + Port Forward
    - DMZ
    - DMZ + Port Trigger
    - DMZ + Port Forward
    - DMZ + Port Trigger + Port Forward
    - QoS
    - QoS + Port Trigger
    - QoS + Port Forward
    - QoS + Port Trigger + Port Forward
    - QoS + DMZ
    - QoS + DMZ + Port Trigger
    - etc, etc
    - Downed the MTU

    Each of these settings then requires me to try the game 3 differnt times (for all of the settings in-game). The only thing I can do is unplug the router (which I'd rather not do becasue that then requires an entire network reset).

    Nothing has worked. People with the v4 and below have reported no problems setting everything up.

    Here is one thing I did notice. In previous versions you were able to turn the firewall on the router off completely. With v5 that doesn't seem to be possible which I suspect to be my issue.

    If you goto www.portforward.com and look up my model and Command and Conquer Zero Hour then you will find all the ports I need to forward (fyi, I tried their guide to no avail).

    I'm hardwired into ethernet port #1 on the back of the router and I am running v1.006 firmware.

    Dear god please help me......
  2. Vendetta

    Vendetta LI Guru Member

    115 views and not 1 response.....wow.
  3. Toxic

    Toxic Administrator Staff Member

    firstly I take it the PC your using has a static IP so that Port forwarding can point to the same PC all the time?

    you should only have to use Port Forwarding and not anything else.

    have you tried enabling UPnP?

    it should look like this...making sure ws thecorrect IP address of your PC

  4. Toxic

    Toxic Administrator Staff Member

    unless someone has experienced this problem and fixed it i doubt most would answer. especially in such a short time.
  5. mazilo

    mazilo Network Guru Member

    Please don't do such a thing. If you still have its original box with its UPC + S/N intact, you certainly can go to any of local stores that sells this WRT54G and start looking for the version (v1, v2, v3, v4) you want to buy. Then, return this v5 the next day to get your 100% money back. Be sure to factory reset and put your v5 in its original box.
  6. TalonFyre

    TalonFyre Guest

    I've got this problem too. My friend has this router and the same problem is happening with BFME2, which also uses the C&C Generals engine.

    UPnP is enabled and I have even tried putting his computer in the DMZ. I've run out of ideas!

    Here's the link to the thread that describes the problem.

    And here's the link to another thread that has the same problem reported from others.

    Any help would be appreciated!
  7. vincentfox

    vincentfox Network Guru Member

    Return it. With a few comments about what junk it is if you can spare the time, so the store knows what junk it is.

    Then get a WRT54GL or WRTSL54GS, which are fantastic units.
  8. Vendetta

    Vendetta LI Guru Member

    Hey Toxic thanks for the reply.

    Yes UPnP is enabled on the router and I re-tried Port Forwarding those ports again just to make sure I wasn't crazy. Still the same thing, I can be online in-game for a random amount of time before I get kicked.

    I just read in another thread that I may have to port trigger the ports until the new Firmware comes out, I will try this and let you guys know what happens.

    I would return the router but its well outside the return policy.

    Has anyone heard anything on the Buffalo routers? I know they use the same Broadcom chip that Linksys does, so I was curious to try of them if my Linksys keeps giving me problems.
  9. Vendetta

    Vendetta LI Guru Member

    I seemed to have solved my problems. Apparently the router blocks some outgoing UDP requests which caused my game not to be able to work. I have played about 4 games without problem so that was the problem :) I am happy again with my router lol
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice