I think I flashed the wrong firmware...

Discussion in 'HyperWRT Firmware' started by mikeyis4dcats, Jul 31, 2006.

  1. mikeyis4dcats

    mikeyis4dcats LI Guru Member

    I have (according to the label) a WRT54G, but I flashed some HyperWRT firmware last week. All was fine for a few hours, then it stopped working.

    Now when I go into the Setup console, it says the Router name is WRT54GS. Did I accidentally flash GS firware instead of G?

    I've tried reflashing Linksys OEM firmware, but it tells me the upgrade failed.

    according to the SysInfo page:

    firmware v4.71.1
    boot version 3.4.2

    any ideas on how to fix this mess?
  2. Toxic

    Toxic Administrator Staff Member

    thread moved
  3. swinn

    swinn Network Guru Member

    There is nothing to fix. HyperWRT is based on the WRT54GS firmware so it is of course going to default to that name. You can change your router's name to whatever you want if having it called a WRT54GS bothers you.

    Also make sure you reset your settings since you just moved from one brand firmware to another to ensure you don't have problems.
  4. mikeyis4dcats

    mikeyis4dcats LI Guru Member

    well the issue arose because as I said, a little bit after i flashed, my router became inoperable. I cannot connect to the net at all...
  5. swinn

    swinn Network Guru Member

    Did you reset the router after flashing?
  6. RonWessels

    RonWessels Network Guru Member

    You imply in your first message that you can still connect to your router. Did it suddenly stop working, and if so, what else was going on at the time? What does the Status page say? What sort of internet connection do you have? If you have DSL, is your modem operating in bridge mode so the router is performing the PPoE? What connection mode have you specified?

    You'll have to be a bit more detailed, rather than just saying "it stopped working" and "my router became inoperable".

    Try going to the Administration -> Factory Defaults page, select "Clear NVRAM, restore factory defaults" then press the "Restore Factory Defaults" button. Then re-enter your configuration information for the router.
  7. mikeyis4dcats

    mikeyis4dcats LI Guru Member

    I've tried resetting, both with the button and web interface.

    I can ping the router, but I cannot connect to the internet (says nework unreachable when pinging from the router)

    it stopped working suddenly, a couple of hours after I flashed the firmware. I thought something was wrong with the firmware, so I tried reflashing it with OEM and other 3rd party versions, but they all tell me it's unable to be reflashed (wrong code pattern, etc.)

    I'm obviously a dummy when it comes to networking...
  8. RonWessels

    RonWessels Network Guru Member

    Go to the Status -> Router page. What is the information in the Internet section?
  9. mikeyis4dcats

    mikeyis4dcats LI Guru Member

  10. RonWessels

    RonWessels Network Guru Member

    Ok, that says that the router is unable to establish a connection with the outside world, but is connecting with your LAN just fine.

    What sort of Internet connection do you have? Cable?

    Have you tried bypassing the router and connecting your PC directly to your modem? If that doesn't work either, then your modem is either broken or not connected properly. If that does work, then the problem is in your router.

    Assuming you _do_ have cable, it is often the case that the router host name needs to be set to some magic name that your cable company has provided you. That does not appear to be currently set correctly.
  11. mikeyis4dcats

    mikeyis4dcats LI Guru Member

    yeah,. i know it's the router. My desktop runs fine when run through the cable modem, but my laptop and desktop both are fouled when I connect the router
  12. RonWessels

    RonWessels Network Guru Member

    Ah - cable modem!

    According to your Status page, the host name field is not set. As I mentioned previously, at least _my_ cable connection requires a magic host name to be recognized.

    Another possibility is that the Ethernet cable between your cable modem and router is broken. Did you use the same cable when connecting your desktop?

    One final possibility that does not explain your initial failure, but does explain your continuing failures, is that your desktop still has an open DHCP allocation from your ISP from when you tried it. If you simply disconnected your PC from the cable modem without first releasing the DHCP allocation, your router would have requested a new allocation when it was connected to the cable modem, and the change in MAC address might confuse your ISP's DHCP server. Did you clone your PC's MAC address to your router?
  13. mikeyis4dcats

    mikeyis4dcats LI Guru Member

    Well, would the fact that my laptop also does not function via wireless negate those issues *except* the host name?

    How can I determine the host name required by my ISP?
  14. mikeyis4dcats

    mikeyis4dcats LI Guru Member

    some preliminary googling indicates that Cox probably does not require a hostname
  15. RonWessels

    RonWessels Network Guru Member

    If your desktop works when connected to your cable modem, if there is a magic hostname required, your PC is also set to that hostname. Right-click "My Computer" and select Properties. Select the "Network Identification" tab to check what your PC's hostname is set to.

    Now, if wireless access to the router stopped working around the same time that your Internet connection failed, that does point to something bad in the router. Try re-flashing the Thibor firmware.

    Firstly, power-cycle the router to clear any previous attempt at re-flashing (when flashing fails once, apparently subsequent flashing attempts will also always fail until power-cycled). Then re-flash with Thibor's GS firmware (yes I know you have a G - don't worry about it). Once successfully flashed, reset the router via the web page (clear NVRAM) and try again.
  16. mikeyis4dcats

    mikeyis4dcats LI Guru Member

    reflashing is a no-go...tried the v4 and GL version both

    guess I'll just chalk it up as a lost cause unless you have any other ideas
  17. RonWessels

    RonWessels Network Guru Member

    Did you power-cycle between flashing attempts?

    If the error message was "wrong codepattern", did you try the GSv3 version?
  18. mikeyis4dcats

    mikeyis4dcats LI Guru Member


    thanks a million Ron!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice