I think I might have bricked my router! Anyway to check?

Discussion in 'Tomato Firmware' started by paparay, Oct 30, 2008.

  1. paparay

    paparay Addicted to LI Member

    First of all, I am using a Buffalo WHR-54G. I applogize if this is not the right forum, since it is a Buffalo. I've looked through a ton of other sites for help, but couldn't find anything, and I read some posts here saying some people use Buffalo.

    Anyways, here is what happened. I downloaded the newest Tomato, 1.21, and tried to get it to work last night.
    I changed my ip/gateway/sub, I reset and unplugged the router, I plugged it back in, and quickly ran that dos batch file, that does stuff automatically. I tried a couple times, but it kept giving me some message that it wasn't working. It was getting pretty late, so I thought I would try again in the morning.

    So I woke up early and thought I would give it another go.
    I unplugged the router, plugged it back in, and ran that little file...it said the firmware was accepted! So I go to and I now see the Tomato GUI (this was the first time, normally it was Buffalo).
    HOWEVER, I remembered afterwards that I forgot to change my ip/gateway/subnet! I don't know if this could have cased a problem, but it was the only thing I forgot to do (I should have waited until I was more awake!:frown:)

    Anyways, the internet will not work for me. Not even on the computer that is hardwired to the router/cable modem. I tried using a old router and it works fine then.

    Using a wireless laptop, I can still get signal from the router, although I still cannot connect to the internet.

    I tried doing ping (not sure if that's the right way to do it) from the wireless laptop and I got the following


    Did I brick the router? Is there a fix?
  2. makGuitar

    makGuitar Addicted to LI Member

    If you can connect wirelessly from your laptop to your router surely you haven't bricked it. Can you access the web interface?, if that's the case, check if the router gets an external ip from your ISP, it may be the case that it uses MAC Adress Cloning so you should try with those settings. If not, try re-flashing the router via TFTP and after all that don't forget to do a hard reset to the nvram.
    Good Luck!
  3. paparay

    paparay Addicted to LI Member

    I can connect wirelessly, but I can't access any webpages. Wirelessly and from the hardwired I can access the web interface (this means the screen, right?)

    I've been using this ISP for a while now, would using Tomato be a reason for just now getting a external ISP? What should I call my ISP and ask? "Do I get external IP?" Is there anything more I need than a yes or no answer?

    I tried the NVRAM thing from the admin/connections menu that did not do anything.

    Thanks for the reply
  4. az2008

    az2008 Addicted to LI Member

    What kind of ISP do you have? DSL? Cable? I'm not an expert on this, but I've had both. The basic settings changed between the two. Like, DSL used a PPoe connection type. Also a userid and password. Cable used "normal" (or "default", I forget). No userid and password. The MAC address of the cable modem is registered with the cable company. That's the authentication. I've heard of people who had to clone the mac address to the router. I didn't have to do that.

    I've also experienced conditions where I have to power off/on the cable modem to get it to recognize my router. Just recycling the router doesn't do it. That condition resembles what you describe.

  5. paparay

    paparay Addicted to LI Member

    I actually did turn the modems power off, i forgot to mention that.

    I am using a cable modem as well.

    At least it sounds like my problem might be fixable!

    How do I do the mac address stuff?
    Should I call my ISP and ask them for it's mac address or is there another way to get it.
    And what about cloning, do they have to do something with it, or is that on my end.
  6. az2008

    az2008 Addicted to LI Member

    I don't know the answer to that. You could go to www.dslreports.com/forums/all and see if there is a forum for your cable provider. Then ask there how to configure your "new" router.

    You could also call the cable company and say you bought a new router, and don't know how to configure it to work with their system. (I have Cox and they're not too helpful, preferring to charge a monthly fee for "home networking" which they support.).

    Either way, I wouldn't go into the whole thing about how you flashed your modem, etc. I'd just say it's a new modem, and try to map what you're told to Tomato's terminology.

    Worse comes to worse. It sounds like you can flash it back to the original vendor's firmware. Get it functioning again. And then try to apply what you learned (from reconfiguring the factory firmware) to Tomato (burn it again).

  7. paparay

    paparay Addicted to LI Member

    I got it working!
    I called up my ISP and they told me to a couple things and it wound up working.

    Who would have thought an ISP could actually help out, right?
  8. makGuitar

    makGuitar Addicted to LI Member

    surely it was MAC address cloning :p
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice