I think my WAG354G router is dead.

Discussion in 'Other Linksys Equipment' started by BarryChuckle, Feb 19, 2006.

  1. BarryChuckle

    BarryChuckle Network Guru Member

    I have a WAG354G modem/router and it had firmware 1.01.03. I wanted to upgrade the firmware to 1.01.05 so I went to the UK Linksys site and downloaded the firmware file (WAG354G-EU_AnnexA_ETSI_v1[1].01.05_004_code.bin).

    I unplugged all my wireless adapters and used a computer that was connected to the router using a cable. I went into the router setup pages and went to the firmware upgrade page. I selected the firmware file from my desktop and clicked upgrade. The box filled with the loading bars and after a short while a new page loaded which said "upgrade successful". This page just sat there doing nothing. Then the network icon in my systray changed to "limited or no connectivity".

    I unplugged the power to the router and plugged it back in but now it does not work. When I plug it in the power light flashes red and the LAN lights flash green. Then the power light flashes green for a couple of seconds before sitting there solid red. I have tried pressing the reset button but it does not work. I have also tried using the tftp program but that also fails.

    I do not understand what went wrong. I used the right firmware, since it was the only one on the UK Linksys site for the WAG354G, and the upgrade was not interrupted, it said it was successful. So why does it now look like it is dead?

    Any help is gratefully appreciated. Thankyou.
  2. BarryChuckle

    BarryChuckle Network Guru Member

  3. OlegR

    OlegR Network Guru Member

  4. BarryChuckle

    BarryChuckle Network Guru Member

    I worked out what happened...

    I have the WAG354G-UK and I used the WAG354G-EU firmware.

    The thing is though, I was not even aware that there were different versions. No where on the box/manual does it mention this except for one small sticker on the box next to the bar code, which I had to search for to even notice.

    I assume that the -UK version is the only one sold in the UK (hence the name), yet on the UK Linksys site they have the -EU firmware and nothing else. Even though I installed the wrong firmware I feel that it is still Linksys's fault for 1. not making it clear enough that there are different versions, and 2. offering the wrong firmware on the Linksys UK site.

    I called Linksys and have an RMA number and will be sending it back for a replacement next week so we will see what happens.

    By the way, their customer support actuallly seems to be quite decent. The number you call is free and appears to be 24 hour (well atleast it worked at 10pm for me), and the people you talk to, although they are foreign and have weird accents (maybe Dutch?), are helpful. They email you a UPS packing number thing which you stick on your parcel and then UPS come and collect it, all for no charge. Let's just hope I get my replacement.
  5. BarryChuckle

    BarryChuckle Network Guru Member

    An update if anyone is interested...

    On Monday UPS came and collected the router free of charge using the packing tag Linksys emailed me. By Wednesday it had arrived in Holland and I received an email from Linksys saying they had received it and would take two days to examine it. Yesterday I received an email saying they would be sending a replacement unit to me.

    So a good outcome overall and I would say their customer support is excellent.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice