Inexplicable 54G Problem

Discussion in 'Cisco/Linksys Wireless Routers' started by flasic, Dec 19, 2005.

  1. flasic

    flasic Network Guru Member

    -WRT54G v2 w/ various firmware (currently tofu v11)
    -Motorola Surfboard Cable Modem

    The router is getting an IP from the modem, but it won't communicate with it otherwise. ifconfig shows the WAN as having 6MB RX and 92KB TX, which is probably ARP traffic. I've been able to release/renew the DHCP lease, so I know there is some activity, but the modem won't respond to pings from the router. Right now I'm connected directly to the modem from my PC.

    I've tried NVRAM resets, power cycling, rolling back the firmware to Linksys, etc. etc. :( This problem started after a power outage, which was the first time the router had been rebooted in nearly ~170 days. The last issue was a failure of the default WAN port, which was solved by remapping a free LAN port to the WAN.

    I'm beginning to wonder if this particular unit is possessed by a demon. :eek:
  2. RTSAnime

    RTSAnime Network Guru Member

    If it happened after a power outage there is a chance either one of them could have been fried from a surge afterwards. Otherwise have you tried connecting the modem directly to a computer and then trying to communicate with it? Also the some of the modem's settings may have been changed or reset after the power outage. I would reccomend just connecting the modem directly to the comp and making sure all of its settings are correct.
  3. flasic

    flasic Network Guru Member


    Both are connected to a UPS, so it's unlikely they were exposed to a surge. I haven't had any problems when connected directly to the modem.
  4. vibe666

    vibe666 Network Guru Member

    do you have the LAN cable and modem cable routed through a surge protector? you can have all the surge protection you like on the power cables, but if the data line of whatever you are using (modem, cable modem, DSL gets a big surge from a lightening strike, it's not going to make a difference.

    that said though, if they were fried then you wouldn't be getting anything from them so if you're using the modem now then that's okay, and if you're able to connect with the router then i guess that's working too, so i don't think that's the case.

    just read that back, and i don't think i've really been any help to you, sorry. :(

    silly question, but do you have them in bridge mode and all that stuff?

    have you tried the vanilla linksys firmware? maybe it's something in tofu causing it.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice