Intel 2200BG Connection problem fix ....

Discussion in 'Tomato Firmware' started by Toastman, Jan 17, 2009.

  1. Toastman

    Toastman Super Moderator Staff Member Member

    Intel 2200BG (and others) Connection problem fixes ....

    *** I will try to keep this thread updated with any info on connection problems, most of this will of course be related to Intel cards, but there are some others too. There are also many weird scenarios which have been found to cure or relieve connection problems, so it pays to read through the entire thread and experiment, if you are having difficulty.

    Intel 2100, 2200BG and many other Intel Wireless Card problems

    Hi All

    As most of you will know, some Intel cards caused router reboots with the normal driver. Changing to the ND driver cured the reboot problem, but wireless Intel cards could often no longer associate at all.

    So, this fix is for the problem where Intel 2100, 2200BG, and many 3945ABG cards, can't associate with the router, using firmware compiled with the ND driver. It may also help with the newer Intel "N" cards which appear to be little better than their predecessors. The 1000BGN is one of them, but it seems all Intel wireless adapters can be buggy. [ NB - often, all Intel wireless adapters do not work correctly with the ND driver either. Googling for more information reveals that they often have trouble connecting with many different makes of router. At our local university, most users of laptops with Intel cards cannot use them on the campus].

    The Fix:

    Telnet to the router, log in and enter the following lines:

    nvram set wl_reg_mode=off
    nvram set wl0_reg_mode=off*
    nvram commit

    (* technically this second line isn't necessary, the router will detect wl_reg_mode and set it to match on reboot).

    This switches off (or sets to a known state) the redundant features in the wireless drivers, apparently related to 8011h spectrum management additions and not used in these routers, that were causing the problems. It has solved the problem here with almost all older Intel cards, and a few others which previously were unstable such as the occasional Atheros card and Ralink based USB adapters.

    ( Some related info: )

    Tested with the following drivers in Tomato 1.23. - and later.

    Here's some information on what 80211h was supposed to do:

    " IEEE 802.11h is the IEEE standard for Spectrum and Transmit Power Management Extensions. It solves problems like interference with satellites and radar using the same 5 GHz frequency band. It was originally designed to address European regulations but is now applicable in many other countries. The standard provides Dynamic Frequency Selection (DFS) and transmit Power Control (TPC) to the IEEE 802.11a MAC. "

    Hopefully there will be no other issues associated with this mod.

    Thanks to "Teddy Bear" for jointly finding this mod and who is incorporating this in his new release, (along with Victek) :biggrin:"
    Some more information on regulatory "domain" here:

    EDIT: June 2009 - Official tomato now also incorporates this mod in v1.25 upwards, it does not have the latest wireless drivers, however, which have some benefits.
  2. Toastman

    Toastman Super Moderator Staff Member Member

    Intel PRO Wireless 3945ABG WiFi Radio Adapter Shut Off Randomly

    Some information for general interest:

    On laptop or notebook computers that use Intel PRO Wireless 3945ABG built-in Wi-Fi network adapter with Windows Vista, the WiFi radio signal just suddenly turns off, shuts off or disables randomly, with the Internet or network cut off. The wireless network connection may still appear as active and connected with Excellent signal strength in Network Center, but the network status will change to Limited Connectivity. If the system has LED indicator for Wi-Fi wireless radio signal status, the LED light also turns off (or ir may also stay on) and Wi-Fi radio power cannot be toggled back on with Function hotkey (such as Dell QuickSet), even though the software detects the toggling or pressing of keys with WiFi and Bluetooth logo pop up. It looks like the Wireless adapter card loses its power and is completely shut down and powered off.

    Even when the problem happens, the network device appears working properly and normal in Device Manager. The IP address auto-discovered by DHCP may be lost or gone. And there is no way to recover the Wireless radio signal other than restart the system. But the problem will happen again. Even changing configuration settings of roaming aggressiveness, transmit power, wireless mode (between 892.11a/b/g) or power-saving mode does not permanently resolve the Wireless network adapter off problem.

    There have been many adverse comments about Intel's implemenations of the wifi standards, with particular reference to the power management and PSM (Power Save Monitoring) function. This one (by Michael Kassner, July 30 2008) is particularly interesting:

    The notebook or laptop computers that affected by the suddenly auto shutdown of Wireless signal adapter include Dell Inspiron E1505, Dell Inspiron E1705, Dell Inspiron 6400, Dell Inspiron 9400, Dell Latitude D830, Dell Latitude D630, Dell XPS M1210, Dell XPS M1710, Dell Precision M90, Sony VAIO VGN-SZ430NB, Acer, ASUS S6Fm, HP Pavilion dv9000, Alienware Area-51 M5790 and many other Vista system.

    The issue with the WiFi adapter is caused by incompatible Vista driver, as the problem does not happen under Windows XP system. Previously, users have used two workarounds as a temporary solution - “XP Fix” which uses Intel PRO Wireless 3945ABG driver designed for Windows XP, or rollback and switch back to Microsoft driver comes with Vista for Intel PRO Wireless 3945ABG network card. However, these workarounds have an drawback and disadvantage that the Wireless network or LAN is not optimized for fastest possible speed, instead opt for lower reliable speed throughput, and also have poor radio signal level problem.

    Luckily, Dell has released a new updated driver supporting Intel PRO/Wireless 3945ABG Network Connection and Intel Wireless WiFi Link 4965AGN. The driver version dated 08/08/2007 comes from provider Intel, is packaged as R164259 ( - A05 - August 2007 release. It fixes the following bugs (changelog):

    Addresses 3945ABG radio disable seen with some systems running with Bluetooth modules
    Addresses 3945ABG radio disable seen in some 802.11a environments after Standby or Hibernate
    Addresses installer upgrade behavior where Windows Vista Preferred Networks would be lost
    Addresses installer interaction with InstallShield Update Manager causing an unwanted prompt during installation
    The new driver will likely to solve the Wireless cuts off problem in Vista. Download the driver version from It’s a Dell installer package, which should work on other brands too. Otherwise, simply extract the driver by using WinRAR and manually update the driver for the network card from Device Manager.


    Although this piece said that this issue does not happen with Windows XP, we are all finding that it, or something remarkable similar, is indeed happening with XP.

    Sometimes a simpler strategy works .......! See here:-
  3. guillaumy

    guillaumy LI Guru Member

    Very interesting news! Does this mean we can now deploy ND versions of Tomato on devices with corerev>=6?

    This issue with the Intel wireless chipsets was why I had to move away from ND releases.

    Incidentally, what does this patch change, and how does it work?
  4. peyton

    peyton Network Guru Member

    Don't think so, it will just cure the problem between client 2200BG chipset and ND drivers.

    Thanks Toastman, i'm going to try and connect my sony vaio there after. ;)
  5. astehn

    astehn LI Guru Member

    Just to clarify...

    Does this mean I can now use the ND version on my WRT54GLs, without fearing that users with Intel 2200B cards will have connection troubles? This has been the only thing keeping me back from running the ND version, since I know the core revision on the GL = 9. But any "upgrade" to new drivers that prevents some users from connecting is no upgrade for my particular setup with lots of users with older intel cards:)
  6. peyton

    peyton Network Guru Member


    It's working great with the tips on my 2200BG connection.
  7. Toastman

    Toastman Super Moderator Staff Member Member

    Be cautious, it seems to be OK - I have had no complaints from anyone after 24 hours. Please give your feedback!

    guillamy, yes, I'm running on WRT54GL's and ASUS WL500GP v2.

    UPDATE: Running for 3 days on 10 AP's with no reboots and no Intel problems.
  8. vanhh

    vanhh Network Guru Member

    Can we get the status of both wl_reg_mode, wl0_reg_mode in our router before turning them off? I tried with 'nvram get' command, but my router didn't show anything. I'm running non ND on my router at this moment. This is just out of curiosity.

  9. teddy_bear

    teddy_bear Network Guru Member

    That's correct. In the original Tomato this variable is not set. That's what confuses the Broadcom driver, since it's expecting it to be either "off" (default in any official firmwares with this driver), "h" or "g". The driver does some initial setup when it finds one of these values, but it does nothing when regulation mode is not set.

    Somehow the state the wireless module is in by default is invalid for Intel adapters...
  10. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    Sounds like it should be considered a bug in the ND version of tomato. Have you contacted Jon to get these variables added to router/nvram/defaults.c?
  11. nsumner

    nsumner LI Guru Member

    I can confirm that for me this also corrects the problem. It sure sounds to me like a bug in the tomato firmware. Probably makes sense for Jon to add the option like Teddy Bear with the default being to off.
  12. ringer004

    ringer004 LI Guru Member

    Working here also

    Loaded 1.23-ND on my WRT54G v3 router. Working fine here for 20+ hours so far. Connection appears much more stable. I have two 2200BG cards in different laptops.
  13. wittereus

    wittereus Network Guru Member


    Thanks for this great tip!! I wanted to use ND drivers for a long time but I have Intel chips.
    After applying these settings they finally work. Good job!!
  14. greatscott

    greatscott Addicted to LI Member

    What is the benefit of using the ND version?
  15. Toastman

    Toastman Super Moderator Staff Member Member

    2 reasons...

    1) Certain Intel wireless clients caused random reboots of Tomato routers. The later ND driver cured the reboot problem but introduced a new one - where many Intel clients could no longer associate with the router. Now that we know that these additional commands fix the problem, we finally have a cure for *most* of the random reboots of many routers such as the WRT54GL, which can accept the newer driver.

    2) More recent Broadcom chipsets really do need the new driver to function. To find out if your router needs it, telnet the router and type: nvram show | grep wl0_corerev

    You will get a response something like "wl_corerev=9"

    EDIT: from this thread:

    The above has a list of routers and their core revisions, to assist people in choosing what version to run.

    "If it is greater than 4, then ND drivers should work, but may be flaky or provide no benefit. If it is 7 or greater, you almost certainly will benefit. If it is 4 or lower, you will brick."
  16. Planiwa

    Planiwa Network Guru Member

    So, my WRT54GL routers (corerev=9) "really do need the new driver to function"?
    Plain 1.23 won't work somehow? How so?

    Weird, it's the old WRT54Gv2 (corerev=7) that random-reboots
  17. Toastman

    Toastman Super Moderator Staff Member Member

    I've rechecked and changed that core_rev information.... GL can use both.

    I used many WRT54GL's and had to put DD-WRT on them to cure the reboot problem.... now this has changed everything!
  18. greatscott

    greatscott Addicted to LI Member

    I get 9 when I run the command. I have been using the regular firmware and don't have any problems even with my Intel 2200BG. Can you be more specific on reason 2)? I probably will just use the ND version, but will there even be any gain in stability, performance, or anything?
  19. Toastman

    Toastman Super Moderator Staff Member Member

    It's a little early to say with Tomato. Probably we'll get some feedback when more people start using it, and the modders have finished tweaking. If you've had no problems with your 2200BG then you may not benefit from the mods. In my apartment block, the old driver was simply too unstable, WRT54GL AP's running tomato rarely stayed up for more than a day or so, and I couldn't use the older ND driver as I had so many Intel 2200BG clients. That all changed when DD-WRT v24 SP1 came out, it solved the Intel problem, and they have never rebooted since.

    Now I put 1.23 with driver on 10 AP's and so far, up 3 days, no reboots and no Intel connect failures. Fingers crossed :thumbup:

    EDIT: Confirmed - AP's have never rebooted since the day I installed the firmware over a month ago. Routers still do reboot from time to time, this is often due to something else. Later in this thread I will expand on this and add any cures I try/hear of in case it helps someone.
  20. ringer004

    ringer004 LI Guru Member

    Couple of questions

    "Now I put 1.23 with driver on 10 AP's...."

    1) Did you somehow choose which wireless driver was used? My boot-up log of my WRT54G v3 router says eth1 is using As far as I know, I did not get to choose which driver is being used. Maybe it's a function of which H/W version of the router you have? Just curious.

    2) If this hidden nvram setting is needed, it makes me wonder if there are other unknown nvram settings that need to be set also. Since this is difficult in a binary only driver, how can one be sure we have everything initialized correctly? Just curious again.

    And finally, thanks a ton for the nvram info. This has been extremely useful, and looks like it solves a thorn in the side of many users.

  21. darthboy

    darthboy LI Guru Member

    I'm running 1.23.8505 of victek's mod and having Broadcom BCM4318 802.11 Wireless Controller driver.

    how do you integrate newer drivers?
  22. Toastman

    Toastman Super Moderator Staff Member Member

    The driver version is coded into the firmware by the developer - currently Teddy Bear and Victek are experimenting with the newer driver versions, but the mod works with the earlier driver (ND) too.

    ringer004 - exactly. There are hundreds of settings, we don't know what many of them do, and each wireless driver and also each variant customized for a particular router model can and may well have different settings for stability. We just don't know...
  23. spicoli

    spicoli LI Guru Member

    Due to an obvious difference in nvram between regular and ND firmwares, would the nvram need to be erased when flashing from regular tomato to ND?
  24. astehn

    astehn LI Guru Member

    I just upgraded four WRT54GL APs from the regular Tomato 1.21 to the ND Tomato 1.23. I didn't do an nvram clear, and all four of my access points are without problems 24 hours later. Of course, since they're only running minimal services as access points, there is less to go wrong.

    In general, from what I've read on these boards, an nvram erase is only imperative when switching between "flavors" of Tomato (e.g. from regular Tomato to a modified version like Victek's). Though if you have any problems, trying an nvram erase is a good first step just to make sure everything is clean.
  25. Toastman

    Toastman Super Moderator Staff Member Member

    There is currently a lot of development going on with different wireless drivers, USB, FTP, SAMBA, NAT traversal, and other interesting bits about to hit the market, be aware that any of these mods which add new NVRAM entries or delete old ones are potential problems. We're also probably going to be switching versions to see which ones we like best. So please, always do an NVRAM erase before posting to the boards that a particular version doesn't work. This is one of the most common queries on the forum, and probably the one that causes the most problems for developers. Remember, every time they have a report that something doesn't work, it takes many hours to examine what's going on, recompile, flash, test, etc. - all a big waste of their time if the problem is self-inflicted !

    With more "N" clients arriving, I would remind everyone that in order to get more than 54Mbps with "N" connections it is absolutely necessary to enable WMM. Intel cards particularly will not play ball otherwise.


    Bon Voyage .. !
  26. greatscott

    greatscott Addicted to LI Member

    I'm running Tomato RAF 1.23.8505ND with my Intel 2200BG without any problems. Thanks for the fix, Toastman.
  27. Toastman

    Toastman Super Moderator Staff Member Member

    Other causes of wireless connection instability

    OK, there are new releases by Victek and Teddy Bear with all sorts of new goodies. If you're going to try one of these releases, please do check whether your router can run the new wireless drivers - if you choose to run an unsupported driver it may brick your router, or you may get other problems. And don't forget to erase NVRAM before raising a query...


    I am highlighting this post because of its importance.

    The greatest amount of strange problems people experience with Tomato and modded versions come from failure to rease NVRAM after flashing firmware. Although the Tomato FAQ says it is not necessary to do this when flashing to newer versions of the same software, I would advise people to do it anyway. There have been countless examples of weird problems going away when NVRAM has been cleared and information re-entered from scratch.

    So - if you have something odd happening that you cannot resolve, try this:

    1) Erase NVRAM and then install a backup config from a time when the problem did not exist.

    2) If that does not work, then erase NVRAM and enter all of your configuration details from scratch.

    3) If that doesn't work, call a priest.

    4) Because I have several hundred WRT54GL's in service, I've been able to confirm, over the last year, that NVRAM does often get corrupted in some way and cause "weird" problems. I can even reproduce it sometimes: cut power, restore, then cut again while the router is rebooting. This happens often during brown-outs. A listing of NVRAM configuration shows no change though. To prevent this kind of corruption, you can use a UPS.

    5) On occasions, NVRAM will become corrupted after saving a change in configuration. I have also verified that sometimes a change in a QOS setting makes the router behave unpredictable. I think it is when too much data has been put into one entry, such as too many ports in a clasification. Some versions of Tomato - 1.25/6/7 - now give an error message if you try to enter more than 10).When this happens, deleting the change (if you can remember what it was!) restores things to normal.


    There are several different encryption standards supported by Tomato. Unfortunately, some of them are unstable in some situations, and some don't work at all when used with WDS etc., for example.

    If you have any connection problems, before you do anything else it is always wise to turn off encryption. Set up your system first, then add encryption. I personally use WEP because in my application encryption is unnecessary (as a means of restricting access) as my clients always give the password to anyone that asks for it anyway. WEP has been trouble-free. So this is a fall-back if your own chosen method doesn't work or causes random disconnections.

    More reading:
  28. SJG1

    SJG1 Addicted to LI Member

    Not working :(

    I have a new dell precision M6400 from work and it refuses to work with tomato firmware on my buffalo WHR-G54-HP.

    It just wont associate with the router, I have tried both the ND version and the non ND version with no success and have also tried the fix at the beginning of this thread to no avail.

    The laptop has an Intel WiFi Link 5100 AGN card in it with Vista 64 Enterprise. I have had to give in and use dd-wrt on my router which works fine with this new laptop.

    I have another 6 laptops that work fine with tomato (Including one with a 2200BG card), but for some reason this new laptop refuses to connect.

    Any pointers as I really love tomato, and dd-wrt seems so much slower with this router...
  29. Toastman

    Toastman Super Moderator Staff Member Member

    sjg1 - Interesting. DD-WRT uses driver. What tomato mod versions did you try??

    I have not come across this card before.

    EDIT: Whoaaa - I just searched on Google for information on user experiences with this card. It wasn't good - Intel have done it again! I found posts about association problems with several well-known router brands. So many users complaining - having to use a USB dongle instead :frown:

    I also came across a possible reason for Intel cards suffering more problems than other manufacturers.

  30. SJG1

    SJG1 Addicted to LI Member

    Thanks for the info Toastman.
    I have tried the official Tomato release, and Victeks latest version.

    I think I will probably look into changing the wireless card in this laptop until Intel release a more compatible driver, or a fix is found..
  31. Toastman

    Toastman Super Moderator Staff Member Member

    D-Link DWA110 USB Adapter

    With the newer drivers, some USB adapters based on RALINK chipsets have some problems staying connected. There is some evidence that this began with Windows XP SP3, but perhaps did not happen before.

    The cure is sometimes to remove the manufacturer's software. Plug in the card, get Windows to look for the driver *only* and install it, and use the built-in Wireless Zero Config to take care of the connection.

    There are occasions and other wireless cards where the reverse is true, and the manufacturer's connection software works where Zero Config does not. See what works for you !

    There is a new (?) high power USB adapter made by TP-Link, the TL-WN422G. I tested it, seems OK and gave greater range than anything else I've tested before. The hardware has been around for some time by several manufacturers, but only now seems to be becoming popular.
  32. Toastman

    Toastman Super Moderator Staff Member Member

    Atheros wireless cards with ND drivers

    Some Atheros cards have been having connection problems with the newer drivers. One possible cure, posted by kabar, is to disable WMM in Advanced -> Wireless.

    Regulatory mode set to "off" seems to effect a cure with the Atheros cards I have tried here.

    I've had a few people with Zyxel USB adapters whose connection was very intermittent and internet speeds very slow. No cure was found. Except for the time-honored method of dealing with Zyxel products. Throw it in the bin :biggrin:
  33. sjc80

    sjc80 Addicted to LI Member

    Thanks for this great tip!

    My frequent reboots seem to have disappeared by using the ND version and disabling 80211h as you suggested.
  34. kabar

    kabar LI Guru Member

    ive also noticed that you have to put the Regulatory Mode to Off to prevent the atheros-based wifi cards from constant reconnecting and resolving ip adress. both d and h modes does not work well with them. cheers
  35. Toastman

    Toastman Super Moderator Staff Member Member

    Note - to Tomato 1.23 ND users - transmit power adjustment is not working correctly. See this thread:

    A cure can be had for the WRT54GL by putting the following into the "init" script box and rebooting, when everything works normally again (so far)...

    nvram set wl0_country=US
    nvram set wl0_country_code=US
    nvram set wl_country=US
    nvram set wl_country_code=US
    nvram set pa0maxpwr=251
    wl country US

    Teddy Bear has added a GUI selection for country, and set pa0maxpwr=251 as a default in his latest version 23.

    Victek has released 8514 with the same mod incorporated.

    Please note that with ND drivers, channels 1-8 will allow the selection of full power, but 9-13 appeared to operate at reduced power. See this post for more information
  36. mejobloggs

    mejobloggs Addicted to LI Member

    I have a 3945ABG card with Victek's latest ND, wrt54gl, plus the driver in the second post, and my wireless still hangs and I have to reboot :(
  37. Toastman

    Toastman Super Moderator Staff Member Member

    Oh :frown: That's a pity. I have a lot of 3945ABG laptops in the building here, and they all seem OK on connecting with any of Victek's ND versions which have this mod. If you do find any cure, do please come and post it ? Perhaps the knowledge that they are capable of associating without hanging will help you find a cure.


    In the meantime, I came across this in the ASUS forum - food for thought? For those of you who do not knopw "oleg" - he is the author of a popular third party mod for the ASUS platform.

    Note the date - so it is at about 6 years now that Intel have failed to correct the widespread problems with their wireless card drivers.

  38. Toastman

    Toastman Super Moderator Staff Member Member

    D-Link DWA110 USB "g" wireless adapter

    I pointed out a problem with this D-Link USB adapter in a previous post.

    This RALINK RT73 based adapter seems to work well with older motherboards with 10/100Mbps ethernet, but on later motherboards with 10/100/1GB ethernet, there is a problem - it doesn't associate properly. The problem began here when I changed my motherboard. Previously I had found these adapters very reliable, and I have been trying to find out what has happened to change things.

    This USB adapter comes with a short USB cable extension and stand. Somehow this has an effect on the operation of the adapter. If the adapter is plugged directly into the PC's USB port it will sometimes work perfectly. It does the same when plugged into SOME screened extension cables, especially if a USB hub is on the far end of it. Also, seems like the adapter will work on some of the USB ports and not others. But when plugged into the supplied extension cable/stand, it doesn't associate, although it otherwise seems to be working. There doesn't *seem* to be anything unusual about the cable/stand, it works OK as an extension with anything else I have here.

    An SMC EZ connect "g" USB adapter (atheros) will *usually* work when plugged into the short D-Link extension, but not always. It always works here on any other USB extension cable.

    Mine is a Gigabyte board with Realtek RTL8168C(P)/*111C(P) PCI-E Gigabit ethernet NIC. I've tried this on several newer motherboards and laptops now with similar results, the D-Link adapter usually doesn't work well. There are about 8 people in my building using these adapters and nearly all of them have some problems on occasions. The ones with newer motherboards are the ones suffering!

    Anyone got any ideas on what may be wrong?

    EDIT opened new thread
  39. mejobloggs

    mejobloggs Addicted to LI Member

    I've now installed the intel wireless driver that was on windows update. It's improved things heaps. Occasionally the problem still happens, but only once a week or so instead of once a minute :)
  40. Toastman

    Toastman Super Moderator Staff Member Member

    Thanks, can you post the version number of the new driver for anyone else with the same problem?
  41. mejobloggs

    mejobloggs Addicted to LI Member is the one I have from win update. Which seems newer than the current one at intel (
  42. Toastman

    Toastman Super Moderator Staff Member Member

    It seems to be commonplace that some Intel cards connect to an AP but have no web access - no IP is issued by the router's DHCP. They seem to receive no traffic from the router. I found hundreds of complaints with google.

    They will often work if given a fixed IP, gateway, and DNS (a good place to enter this is in the "advanced" section of TCP/IP properties) - but not always.

    Recently this problem happened to a resident's laptop that had previously worked well for several months. Despite reinstalling Windows XP and exploring every known cause and any other clues I could find on the web, plus new drivers from Intel and other manufacturers, nothing worked. I concluded that something had changed, and that it was probably with the router. But what? I began to experiment with a spare router setup.

    If I changed the SSID of the AP or router to one including a space or a hash (#), I could provoke the issue. (Despite not strictly allowed, many routers will accept this). But, when the space was removed, the client still couldn't connect! The change back didn't restore operation.

    Going back to the main router, restoring config from a month-old backup did not restore the original behaviour either! However, I discovered that completely erasing NVRAM and then restoring the same config file made it work again. Something is very weird about this. It means that whatever issue causes a problem is very hard to identify. I am currently waiting for it to happen again so that we can compare NVRAM dumps for clues.

    I expect there are also some other causes for the incompatibilities which can be discovered in time.

    In the meantime, if you have a weird problem, DO NOT FORGET to erase NVRAM and restore a previous config, or re-enter config from scratch, before you start to do anything further.
  43. Sunspark

    Sunspark LI Guru Member

    I read today that the wireless must be down in order to set regulatory mode. So, I am currently testing the following init script:

    nvram set wl_country=CA
    nvram set wl_country_code=CA
    nvram set wl0_country=CA
    nvram set wl0_country_code=CA
    nvram set wl_reg_mode=d
    nvram set wl0_reg_mode=d
    nvram set pa0maxpwr=251
    wl down
    wl regulatory 1
    wl country CA
    wl up

    This script sets the regulatory mode on and the country when the wireless is down. The nvram set reg_mode settings lock it into "d" rather than "h". I don't have a 2200BG, but I'm thinking that "d" won't hurt it any since the issues seemed to be with "h" as I understand it.
  44. mejobloggs

    mejobloggs Addicted to LI Member

    I've had no disconnects whatsoever after using this driver + Victek's ND
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice