Intel 2200BG Problem Solution Here NOT ROUTERS FAULT

Discussion in 'Cisco/Linksys Wireless Routers' started by cranky, Jun 29, 2005.

  1. cranky

    cranky Network Guru Member

    I know this really isnt' directly related to the WRTXXX routers. But I'm sure there are many other people as evident by some other threads I've seen, that seem to be mistaking problems with their Intell 2200BG adapters as problems with their routers. For some reason there doesnt' seem to be any conclusive information or discussion on what seems to be a common problem with the Intell 2200BG adapter easily locatable via google either. If this thread gets moved I just hope that it stay easily visible.

    I have a internal Intel 2200BG wireless card and I was getting varying connection speeds, dropped connections, jumping around throughput, just a general headache.

    The problem is the fault of the intel drivers plain and simple. Initially I thought it was because I had a single AP in my home. I added a second AP hoping to improve the coverage over my house. After adding the second AP (a WAP54G to augment a WRT54G) I would get stuck connected to the AP that had the weaker signal. The problem turned out to be that the connection to the closer AP would drop, the driver woudl fail over to the other AP since it had a very faint signal but it would not automatically reestablish the connection tot he closer AP.

    I decided to try upgrading to a newer version of the intel drivers. What was supplied with the notebook was based on the intel 8.0.x.x driver base, so I upgraded to generic from the intel website. The connection did not improve.

    I then tried adding a Hawking omnidirectional antenna, no improvment. then I upgraded the WRT54G to DD-WRT and the WAP54G to hyperwap, hoping that a modest boost in power might help. Still got wildly fluctuating connection speeds and dropped connections. All the while my friends notebook with a atheros (I think thats the type it had) base internal wireless card had no problem connecting and maintaining a connection to my APs, while my notebook had this problem with other wireless networks.

    Towards the end I was getting a condition where I would connect to the AP but could not obtain a DHCP address and had a limited connection (static ip and dns and the connection was servicable) I was just about to order a PCMCIA based wireless card (something I rather not do because of the way the machine gets used) and I stumbled on this thread at notebookreview regarding the 2200BG.

    Three things stuck out in this thread and I present them for anyone else having a problem.

    1) make sure that the Power Management and the Transmit Power option sliders in the hardware configuration (Control Panel->Network Connections->Wireless Network Connection 2200BG->Properties->Configure->Advanced) are set to their max positions. It was even suggested somewhere to deselect default, set them to a low position, ok the dialog and then go back again and raise them to full just incase something wasnt' picking up the default value of "high" properly.

    2) Install the Windows XP update Update for Windows XP (KB893357) which adds support for WPA2 but also seems to include a improvment to WPS for network discovery.

    (stupidly I installed this and redid my power level sliders on the same reboot and I don't know which had the observed effect, the connection did seem somewhat more stable, whether or not this update is required or even beneficial I do not know at this point)

    3) Make sure you are running the newest Intel drivers. I am currently running a beta version of the Intel 9.0.2.x drivers and the connection has been rock solid for me. No more dropouts or sudden connection speed changes. From that thread at notebook review it seems the drivers are the minimum revision effective at remedying the connectivity issue. You can obtain the latest drivers by contacting Intel's tech support or you can use the distribution supplied by IBM which currently contains the version. (IBM distribution - Intel driver)

    I don't know for a fact which of these steps was most instrumental in establishing a solid connection. But now my connection to either the WAP54G or the WRT54G is rock solid. My connection indicates either 48 or 54mbps reliably and the signal meter shows a signal level in line with my expectations (excellent within 10 feet direct line of sight to the AP, Good two rooms over, etc). Connection dropouts have not been a problem.

    However I did notice one odd thing along the way. After I installed the WPA2 update and readjusted the power management and transmit levels, I rebooted the connection seemed somewhat more stable but more insterestingly, actual throughput increased to 2.2MBy/sec as measured between a computer hardwired to the network and this notebook using NetCPS.

    I never before had been able to break 1.1MBy/sec throughput with between this notebook and either AP with or without WPA enabled while a IBM thinkpad equipped with what I believe to be a atheros a/b/g card was able to do a solid 2.2MBy/sec.

    While examining this new found throughput I noticed that the transfer would start off at about 140KB/sec for several seconds and then suddenly jump up to a solid 2200KB/sec for the remainder of the test. By comparison prior to installing the WPA2 and adjusting thesliders I was averaging 1.1MBy/sec and the transfer speeds reported during the testing was varied, 800KB, 1100KB, 1600KB, 600KB.

    After about an hour of tsting around I did get a dropped connection (this was already much improved compared to the dropped connection every few minutes prior) and I decided to go for broke and install the Intel drivers. These drivers improved the connection quality but reverted me back to the 1.1MBy/sec throughput and the same fluctuating rates during the course of a trasnfer test.

    Additionally I did notice that the intel 9.0.2.x drivers add a configuration option to change the "Roaming Aggressiveness" which is described in the driver as "This setting allows you to define how aggressively your wireless client roams to improve connection to an access point.". Unforutnately it doesn't seem to work well enough yet and I have to keep my APs on different SSIDs and switch between them manually.

    I hope this thread makes some sense and more importantly helps someone else because I know it was very difficult finding any information regarding the "weirdness" of the 2200BG.
  2. cranky

    cranky Network Guru Member

  3. AEhrlich

    AEhrlich Network Guru Member

    Well, there is something wrong with this Centrino G indeed, or somewhere around it, maybe in WinXP.

    I had lived for a long time with D-Link DI-624+ (h/w A3) accesspoint together with D-Link G650+ PCMCIA on a Windows 2000 SP2 and had relatively few problems (a hang once a month or so). When I bought a second laptop, with Intel 2200BG this time, equipped with WinXP Pro SP2, the problems begun. Constant wireless disconnects and hangs requiring AP power cycle sporadically (i.e. a week without disconnects then 10 disconnects a day) for both computers, but only if the second one (with XP and CentrinoG) was used. Two more cents about config: power settings on maximum both on AP and clients, WPA-PSK used, MS WZC used on XP, and another accesspoint of my neighbours nearby with a very low signal.
    When I had enough disconnects and AP hangs I went out and bought my Linksys WRT54G (2.0). To my surprise, wireless issues didn't go away. I was even going to exchange my 8-years-old refrigerator suspecting it is a source of interference ;-).

    But now I have seen no disconnect for last two months, since I did THE FOLLOWING:
    1) Installed generic Intel 9.0.1 drivers and told not to use MS WZC on WinXP
    2) set Beacon interval to 50 (from default 100), Fragmentation threshold to 2304 (from 2346) and RTS Threshold to 2307 (from 2347) on Linksys AP; official firmware 3.03.1 EU.
    And, btw, if I said "use Microsoft client" then I'd get disconnects back quite soon...
    Didn't apply WPA2 fix.
  4. cranky

    cranky Network Guru Member


    Hrmmmm, I tried setting the beacon interval to 50, and I also tried changing the framgmentation and threshold (dont' remember what values I did try) and the improvments were minimal and towards the end it was becoming unusable with all the unusable connectiosn where it couldn't even make it to the dhcp server. Using a driver newer than the one packaged in generic definately helped considerably.

    At the minimum I'd recommend a pacakge with the driver (intel needs to do something with their nomenclature since the pacakge, the driver and the software are very similar in name/version number) But since you seem to be functioning, if it's broke don't fix it isn't bad advice.

    I basically started this thread because it was a pain in the butt to find information pertaining to it when I thought it was the router.

    I have been toying with the idea of doing a clean install to see which/what changes help most but I really don't have the time to dedicate to it.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice