Intel Smart Wireless being stupid

Discussion in 'Cisco/Linksys Wireless Routers' started by moerl, Mar 22, 2006.

  1. moerl

    moerl Network Guru Member

    I had a problem with my WRT54GS v2 and today decided that I have to do something about it. So I installed the HyperWRT Thibor 14 firmware and I have to say I love it. It's packed with features and greatly enhances the usability of the router. It's hard to believe how many features are actually customizable in the router and that Linksys doesn't even let you change/set by default...

    Anyway, I have an Intel 2200BG wireless card in my laptop. Intel and Linksys together came up with the "smart wireless" feature that is supposed to make connecting to the right router easier. And it really would if it actually worked. The Intel wireless management utility detects the router and then asks me to give it the router's Ownership ID and Device ID, which are both printed on the bottom of the router. When I do that and click next to continue with the network configuration wizard, the authentication of the ownership and device ID just loops indefinitely, and I get this message that if the authentication fails, I should look at my Linksys documentation. How helpful!



    What can I do to fix this?

    Two more things. How can I change my password here on the forums? I don't see that option anywhere.
    Secondly, I was thinking.. does flashing the router firmware mess with the ownership and device ID's? Because that would explain why I'm having this problem.
  2. Lazor25

    Lazor25 Guest

    I can't help you make that feature work. Do you really need it though? I say save yourself a headache and dissable that feature.

    Near the top of the page, where it says "forums" in little red letters (picture of a router next to it) there are blue buttons. Click the "profile" button.
    I seriously doubt it. After all, you can download firmware updates from Linksys and they don't change either of those things; the firmware you'd download from Linksys wouldn't contain any Device IDs either so the fact that one's from Linksys and the other is not shouldn't make a difference.
  3. moerl

    moerl Network Guru Member

    It's not about "needing" the feature. It can't just be disabled! If I can't get through this step it means I cannot connect to my router using Intel's ProSet Wireless Management utility! I'll be forced to use Windows' built-in Wireless Zero configuration tool, which I guess is ok, but I do much prefer the Intel tool because it lets me configure profiles and is generally cooler than the default Windows one.. :(. This sucks.

    Thanks for pointing out the profile link. Found it.

    And yeah.. you have a good point about the custom firmware thing. But see.. the Linksys firmware might have specific code in it which lets the Intel ProSet Wireless Management tool SEE the device/ownership ID's, something the custom firmware may not be doing.. :/
  4. moerl

    moerl Network Guru Member

    One way to find out if it really is the firmware that's causing the problem is to reload the stock Linksys firmware and see if I still have the issue with Intel's ProSet software. If I don't, I know what the problem is. If I do, then I have no idea...

    Or I could just use the Windows wireless manager. It just sucks that I lose the functionality of Intel ProSet over something so stupid. Guess they didn't think their software could hang or otherwise not work with their Smart Wireless idea... and they didn't leave an alternative to that. Bastards!
  5. jgutz20

    jgutz20 Network Guru Member

    ive always used the windows utility over the vendors utilites, i think its easier and more reliable than their software. A lot of customers get confused when the windows wireless icon shows a red X on it while connected using a different utility. I'd say just use the win utility unless you absolutely need the profiles, why do you need these profiles anyway? are you connecting to a wireless network with a static IP address or one with a Proxy?VPN?
  6. moerl

    moerl Network Guru Member

    Ah crap. I might have messed up wireless functionality completely with my last installation of Windows. I used nLite to customize my Windows setup and remove certain components. Perhaps I removed something crucial to wireless networking? In any case, I switched from Intel's ProSet tool to the Windows utility and I was able to connect to the router bout the icon in the tray never stops "acquiring a network address. It just keeps doing its thing and doesn't stop. Doesn't it usually say there's something wrong with the connection and that there's limited or no connnectivity or something like that? Well, the icon here's just spinning, and nothing's happening :(
  7. sded

    sded Network Guru Member

    For the spinning Icon

    go to "connect to/all connections" and hit F5. There is a bug in SP2 that causes it not to recognize that the IP address has been assigned, so that may be the problem you are seeing. You also need to have installed the Windows WPA2 upgrade.
  8. moerl

    moerl Network Guru Member

    Where's "connect to/all connections"? I checked out the properties of this particular connection and the encryption dropdown in the Windows properties showed just about all encryption methods I know, including WAP and WAP2, so my Windows setup must have that patch already. For some reason, explorer.exe keeps freezing when I deal with wireless settings. Funny thing is that explorer works fine for all other applications in Windows.. everything else stays normal.. but device manager just crapped out and now it's locked. It happened because I selected REPAIR after right clicking the wireless connection.. that is now locked at DISABLING THE NETWORK ADAPTER. The window saying that is up and I can do nothing to close it :(
  9. sded

    sded Network Guru Member

    Connect to/show all connections is usually on the start menu

    but it sounds like you may have other problems. But reboot and try again at this point is all I can suggest.
  10. moerl

    moerl Network Guru Member

    Do me a favor.. will you? Do this:

    1. WINKey + R
    2. Type "services.msc"
    3. Find the Wireless Zero Configuration service, right click it and select "properties"
    4. Go to the last tab and tell me about its dependencies.

    I may be missing something there. I don't know why my system's so damn unstable right now. But then it's not actually unstable.. it's just that explorer-related windows keep freezing after I perform specific tasks. The system's still running fine and everything else is perfectly ok. Hm.

    BTW, here's the list of what I removed from Windows:

    Customized by nLite v1.0 RC7 -

    Components removed:

    Accessibility Options
    ClipBook Viewer
    Internet Games
    NT Backup
    Display Adapters
    Display Adapters (old)
    Ethernet (LAN)
    IBM Thinkpad
    Logitech WingMan
    Microsoft SideWinder
    Portable Audio
    Sony Jog Dial
    Sound Controllers
    Tape drives
    Toshiba DVD decoder card
    Wireless Ethernet (WLAN)
    Gravis Digital GamePort
    Multi-port serial adapters
    Smart Cards
    Teletext codec
    Windows CE USB Host
    AOL ART Image Format Support
    Intel Indeo codecs
    Luna Theme
    Media Center
    Mouse Cursors
    Movie Maker
    Music Samples
    Old CDPlayer and Sound Recorder
    Speech Support
    Tablet PC
    Client for Netware Networks
    Communication tools
    FrontPage Extensions
    Internet Connection Wizard
    Internet Information Services (IIS)
    IP Conferencing
    MSN Explorer
    Network Monitor Driver and Tools
    NWLink IPX/SPX/NetBIOS Protocol
    Outlook Express
    Synchronization Manager
    Vector Graphics Rendering (VML)
    Web Folders
    Windows Messenger
    .NET Framework
    Administrative Templates
    Administrator VB scripts
    Color Schemes
    Desktop Cleanup Wizard
    Disk Cleanup
    Document Templates
    File and Settings Wizard
    Out of Box Experience (OOBE)
    Private Character Editor
    Search Assistant
    Web View
    Beep Driver
    Distributed Link Tracking Client
    Error Reporting
    Fax Services
    Indexing Service
    Network DDE
    Network Location Awareness (NLA)
    Remote Registry
    Removable Storage
    Secondary Logon
    Service Advertising Protocol
    System Restore
    Telnet Server

    See anything there I might DEFINITELY need for Windows to be able to handle wireless connections properly?
  11. sded

    sded Network Guru Member

    Only a couple of dependencies

    NDIS User Mode IO protocol
    Remote Procedure Call (RPC)
  12. moerl

    moerl Network Guru Member

    Re: Only a couple of dependencies

    ... neither of which are in the list I posted, so I should be fine, right? Also, another poster in another forum has just suggested that he had serious difficulties trying to use WPA2 with is Linksys WRT54GS router. Could it be that that's the problem? I have an odd feeling that if I try WPA it will work..

    We'll see. The other thing I could try doing is reloading stock Linksys firmware onto the router and THEN trying to connect, using WPA2 and also with Intel Smart Wireless. BTW, this same guy who said he used to have problems with his WRT54GS and WPA2 also suggested, independently of me, that the firmware may be the culprit in not making the Intel Smart Wireless feature work anymore..
  13. sded

    sded Network Guru Member

    Based on previous forums

    you may be the only user of the Smart Wireless :D Certainly there are not a lot of users of SES-one of the main features of the 3rd party firmware is to allow you to turn SES off so you can use the button to turn wireless on and off instead. :thumbup: But try WPA instead of WPA2, with TKIP+AES.
  14. moerl

    moerl Network Guru Member

    I will try WPA2 one last time, this time with TKIP+AES :). Also.. one thing I realized in that other thread I mentioned is that I switched the router to use channel 2 instead of the default, which is 11. Then I remembered that I never switched my WNIC to channel 2! That's because I figured Intel ProSet would recognize this automatically and switch to channel 2 if necessary, which I think it would if the Intel Smart Wireless crap actually worked :p. But the Windows utility may not be able to do that, I don't know. Either way, I switched the WNIC to channel 2, retried, and I had the same problem as before.. I never get past ACQUIRING NETWORK ADDRESS :(

    And then I'll try WPA with AES and if that doesn't work, WPA with TKIP+AES :D

    Also.. what is SES? You keep referring to it and I don't know what you mean.
  15. sded

    sded Network Guru Member

    SES is Secure Easy Setup

    a Linksys only capability for doing what Intel Smart Wireless does. Important because there is actually a pushbutton on later WRT54 routers to initiate it. But you need a Linksys NIC with SES enabled to make it work. Smart Wireless is probably SES ported to Intel to take advantage of all the builtin WiFi cards.
  16. moerl

    moerl Network Guru Member

    I just tried WPA with AES, and still no success. I never get past ACQUIRING NETWORK ADDRESS. Something else is up here. It's not the encryption method. Damn it!
  17. moerl

    moerl Network Guru Member

    Ok.. I just tried connecting to an UNSECURED WIFI network elsewhere in my building, and I get the same problem. It gets stuck on ACQUIRING NETWORK ADDRESS. What the hell is going on? :(
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice