interesting issue with WRV54G

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by RAD_MAN, Feb 16, 2005.

  1. RAD_MAN

    RAD_MAN Network Guru Member


    i own a WRV54G and a WET54GS5 for hooking a older notebook to a wireless network. the issue i am having can't be explained by linksys. basicly i can hook up to the WRV54G via a wireless card in a notebook or PC and it works fine. i can hook a cable up to the WRV54G and it works fine. but if i hook a computer to a wireless bridge (in this case a WET54GS5 but i have also tested with a WET11 and had the same issue) i cannot recieve an IP address from the router. like i said on 2 seperate test machines with regular wireless cards the DHCP server gives out a proper IP to the computer. also i have tested both wireless bridges on another linksys router (the WRT54G) and both bridges work fine. the kicker is if i set an IP manually on the computer hooked up to the wireless bridge, gateway dns etc it functions thru the wireless bridge just fine. it just won't recieve an IP address when set to automaticly obtain an IP address. i have tested in both windows XP and windows 2000 pro, with the same results both times. linksys sent me the beta 2.37.7 fireware (sadly no readme to tell me what got fixed) in the hopes that issue would be addressed. no dice on that either. does anybody have a bridge working with a WRV54G and if so was there anything special that had to be done because i am at my wits end. thanks for any help =)

  2. TazUk

    TazUk Network Guru Member

    Couldn't you just use a USB wireless NIC with the laptop?
  3. RAD_MAN

    RAD_MAN Network Guru Member

    because the notebook is owned by the company, i cannot install or add anything to the notebook beyond what is already there. =\
  4. kspare

    kspare Computer Guy Staff Member Member


    What are you using for wireless encryption? Try using WEB and Open encryption. I had a similar problem with some Wireless Wyse terminals
  5. RAD_MAN

    RAD_MAN Network Guru Member

    i tried WEP at first, then WPA, when it still didn't work i turned all encrytion off and i still couldn't get them to fuction correctly. the other day i went so far as to replace the router with an identical brand new one i borrowed from work and i still have the same issue, so i know it isn't something wrong with my peticular router.
    does anybody have a wrv54g and a linksys wireless bridge working at all? cause i am thinking something is just plain broke with the firmware =(

  6. DocLarge

    DocLarge Super Moderator Staff Member Member

    Just for giggles, try using a crossover cable to make the connection. There's a possibility one of your devices (most likely the wrv54g) does not have builtin crossover ports...
  7. RAD_MAN

    RAD_MAN Network Guru Member

    when hooking a cable up to the WRV54G, that works fine, i get an IP from the router and everything is good. if i use a wireless card it gets an ip fine and everything is good. it is only when i use a wireless bridge ( ie WET54GS5 and WET11 both tested ) i cannot get an IP address from the router, but if i setup a static ip on the computer connected to the wireless bridge it will talk to the router fine. i know the bridges work i have tested them with with a WRT54G router and it is perfect. i am of the mind that it is a bug in the firmware and there is nothing i can do about it until there is a patch to the firmware to fix that issue =(

  8. aegarza

    aegarza Guest

    I had the same problem with wet11 since BEFW41, upgraded to the WRV54G and nothing was solved. I installed a Router on the other side of the WET11 and things worked but on two networks, the "bridge" didnt work as expected. I was able to get my hands on a D-Link 614+. Gave it a try and it works flawless. I need to reboot the WET11 every couple of days. Now the "bridge" works (printing, sharing, network) and might add that a lot faster than the WRV54G.
  9. DoctorMoreau

    DoctorMoreau Guest

    I have exactly the same problem. The WET54GS5 does not seem to pass the DHCP requests of any machines going through it. This is true whether the bridge itself is using a static or dhcp address. If I assign static addresses to all such machines, they work fine.

    Seems like a pretty obvious use case for a product that advertises "bridge" functionality.

    Oddly enough, when I let the bridge use DHCP to get its address, I can no longer get to the admin web page, even using that dynamically assigned address.

    Sounds like a little basic quality work is in order for the WET45GS5 product group.
  10. RAD_MAN

    RAD_MAN Network Guru Member

    i finally had to give up on the WRV54G and WET54GS5 combo because i needed dhcp to work, i replaced my WRV54G with a normal dull WRT54G. with that router the WET54GS5 works perfectly. there is something seriously wrong with that WRV54G, and there hasn't been a firmware update on the linksys site since 12-2-2004, even a few beta's have come out since but none of them solve the issue either, i don't know if linksys gave up or there is a fatal flaw in the hardware but the WRV54G won't work properly with a bridge (WET11, WET54G, WET54GS5). i haven't tried a different brand, i got tired of buying things after replacing my brand new, and not exactly cheap, WRV54G =\

    if linksys comes out with a new firmware in the future for the WRV54G i'll test it again and let ya'll know if it fixes the issue.
  11. TazUk

    TazUk Network Guru Member

    What was the most recent firmware version that you tried?
  12. RAD_MAN

    RAD_MAN Network Guru Member

    Hate to bump this but just wanted to post the solution. upgrading to the newest 2.38.6 version of the WRV54G firmware complete fixed the issue and now the bridges fuction like they are supposed to. this newest firmware is availible in the downloads section. thanks for all the input =)
  13. chriscox

    chriscox Guest

    DHCP screwy

    I have the same problem of getting DHCP to pass, however this is what I saw with my wet54gs5. While doing a network trace of the wireless network the DHCP request (from wired client behind wet54gs5) will src from the mac of the wet54gs5 which the DHCP server then hands back to that address and the wet54gs5 drops it at that point, I never see the packet make it back to the wired network. DHCP does not work across two different layer 2 networks, but I thought that a bridge worked at that level. Is this a limitation of bridging? Is a bridge supposed to spoof the mac address of the clients connecting through it or at layer 2 should it supply it's own address. If this is the case wouldnt a dhcp relay (dhcp helper address) agent on the bridge take care of such a thing?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice