Internet disconnect when AP used

Discussion in 'Networking Issues' started by gobigdave, Dec 17, 2005.

  1. gobigdave

    gobigdave Network Guru Member

    I've had a WRT54G for a while now, and it worked fine. Recently, I added a few more wired connections so I switched to a Linksys BEFSR81 V3 cable router with 8-port switch. Since I still wanted wireless, I flashed my WRT54G V2 with the Alchemy V1.0 firmware and set it up as an AP. I have a similar setup in my office except there is a Cisco PIX firewall there.

    My problem is that my internet connection drops within 10 minutes of turning the WRT54G on. Until the drop everything works normally. After the drop, my internal network (including wireless) works flawlessly, but nothing can see the internet. If I don't turned on the WRT54G, my wired network, including internet, stays connected just fine.

    I don't claim to be a network expert, but I know enough to be dangerous. I think I have a routing problem, but I can't figure out the right combination. I've tried dynamic routing, and a few static routes, but no luck.

    Anyone have any suggestions??
  2. atinexus

    atinexus Network Guru Member

    Sounds like an IP conflict between the WRT54g and the BEFSR81
  3. gobigdave

    gobigdave Network Guru Member

    I don't think that is it. The BEF is, and the WRT is

    At this point, I'm about to send the BEFSR81 back to Linksys. Not only am I seeing this behavior, but even without the WRT54G connected, my internet throughput is several times slower than when the WRT54G is the main router. For example, takes 1 second to load with the WRT54G, but it takes 10-20 seconds to load the same page when the BEFSR81 is the main router.
  4. hudnut

    hudnut Network Guru Member

    I have a different setup but the behavior sounds similar to my problem. The problem with the wireless dropping started when I flashed to DD-WRT, I messed with it for a day but could never get it to work. I tried hyperWRT and still have the problem. I have yet to go back to the linksys firmware to see if that solves the problem. If anyone has a solution please let us know.
  5. hudnut

    hudnut Network Guru Member

    I tried the original linksys firmware and that didnt help a thing.
  6. gobigdave

    gobigdave Network Guru Member

    I sent the Linksys BEF back and replaced with a similar model from SMC. Now everything works fine.
  7. Mr_X

    Mr_X Network Guru Member

    Next time try to use a network analyser before sending things back. You should try ethereal ( to see what's happening to your network. It's very powerful and opensource.
  8. gobigdave

    gobigdave Network Guru Member

    I've used those before, but I'm not sure what it would have told me in this case. I set things up in a configuration that I knew worked with different hardware. Plus, after looking around, it seems I wasn't the only one with a similar problem. Given this and the fact that things work with the SMC (I tried that before sending it back), I'm pretty certain the issue was with the BEF.

    Note, the other issue I was having is that my internet connection speeds dropped to below dial-up even without the WRT54G on. Pages that used to take 1 second to load were taking 20-30 seconds to load. Again, looking around on the web, I wasn't the only one with this problem either.

    The bottom line is that I'm pretty confident I had a bad BEFSR81.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice